TV AutoPlay on PS4 ....

  • 26 December 2016
  • 3 replies
  • 284 views

Badge +4
I know you can disable this but its a bit of a hassle...

Anyways when I play PES I like to listen to music over the top, but the Sonos auto connects to the TV audio after every game when it goes back to the main menu. Is there anyway to make the auto connect to the TV so its only when you first turn the TV on and not at every other screen on the PS4 ??

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 6
Badge +3
HI chrisredmayne,

Welcome to the Sonos community

You can turn off "TV Auto Play" Go to room settings and then to the "PlayBar", "TV setup"

Play with it. I leave mine on because when the wife wants to switch it back all you have to do is turn the tv off and on and you are back to TV audio.

Play with it and see the best way for you.
Badge +4
HI chrisredmayne,

Welcome to the Sonos community

You can turn off "TV Auto Play" Go to room settings and then to the "PlayBar", "TV setup"

Play with it. I leave mine on because when the wife wants to switch it back all you have to do is turn the tv off and on and you are back to TV audio.

Play with it and see the best way for you.


yeah I know how to do that, I want it to auto play when I change channels but not when the ps4 changes menu screens
The Autoplay function switches on when it senses a lack of signal, followed by an active signal on the optical connection of the Playbar. Unfortunately, the PS4 seems to be dropping, then reintiating audio as you go through the menus, causing the Autoplay function to kick in. There is no fix on the Sonos side. I doubt the PS4 has one either, unless they have an option to keep a constant signal on the optical port, or to turn off audio entirely.