Tunein radio station stops playing infrequently


Userlevel 1
Badge +4
When listening to tunein radio stations (several, not limited to a specific one), sometimes and varying intervals, playback is stopped and does not resume unless I press the play button on either remote.

Media stored on our NAS plays fine and without hiccups.

Anything I can do to have Sonos resume once connection has been lost? Quite annoying...

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

135 replies

Userlevel 7
Badge +26
Hello Helge,

Some radio stations have a stream limit for the amount of time they can maintain a connection. This can be a couple hours or no limit at all, but it's dependent on the station itself. If your players lose connection to a radio stream they'll retry it, but after a handful of failed attempts, they'll stop trying.

Can you please https://sonos.custhelp.com/app/answers/detail/a_id/142 from your system and reply back with your confirmation number after you'd have this happen? Which stations have you noticed this happen on?

Thanks.
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?
Userlevel 7
Badge +26
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?


Hello Annie,

Thank you for that diagnostic. It looks like there's some interference on the system and network latency which could cause a problem streaming stations. It isn't a lot, but there are some spikes which can cause this. Do you have trouble with your local music library, or with other music services (such as Pandora)? 
Can you try out a few more radio stations too, to see if it's just a specific station?

Are you able to log into your router and check it's wireless channel? This is usually under Wireless Settings? Your Sonos system is on channel 11 so it's best if you can have your router on channel 1 or 6.

You can also change you Sonos wireless channel by following the directions here.

If you have another cutout, please submit a diagnostic again and reply back with the confirmation number.

Thanks
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?


Thank you, I'll look into your router channel suggestions and will see if it cuts out on other radio stations. It has not occurred on pandora or in my music library. So far it's only been on radio stations: kboo & klcc. Is it possible that the drop outs occur durring very popular radio shows? I tune in for a special show and know that many people tune in just for this weekly show.
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?


I have the exact same problem - occured after joining the beta program and updated the system. I have tried all channels but my radio drops out all the time. I have diagnostic number 3597894.
Userlevel 7
Badge +26
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?


Hi Christian,

Thanks for the diagnostic. It looks like your wired CONNECT (stue) is getting some bad spiked in interference. If you've tried all of the channels than it's likely something sitting around that CONNECT for what electrical devices are there. If you have a wireless phone or speaker within a couple meters it could be causing the problem. 

If you ungroup the other units from the CONNECT and just try playing music to it, do you have any cutouts? 

Annie is having trouble with specific radio stations, do you have trouble with a source in particular?

Thanks
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?


(See above)
Userlevel 7
Badge +26
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?


Hi Annie,

As to your question, yes, it's possible that the station will have trouble playing to it's audience during peak hours. A radio station is independently hosted and Sonos connects to a specific stream (provided by TuneIn Radio). That stream could certainly be taxed causing it to stop playing. Most streams will have limits as to the number of listeners allowed at one time. It would be good to know if this only happens from these shows at a specific time.

Also, try the same time, but a different source.

Since there are some signs of interference, it could also be that around the time of those shows, the wireless environment gets noisier (from neighbors or something turning on like a microwave).

Thanks
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?


Hi Ryan,
Thanks for your answer. I had a Chromecast lying abt 30cm from the connect box. I have also ungrouped and are now only playing on my two other devices (apart from STUE).  I have now unpowered the Chromecast and retried my radio channel. No dropouts for 5 mins. New diagnostic nr 3598067.  Could maybe be interesting to see if this was the cause of the interference?
Userlevel 7
Badge +26
I am having exactly the same problem. #3590376  "unable to play KLCC connection to TuneIn was lost"  I have also had this with KBOO ... this is quite frustrating.  I've had my sonos players for 8 years and have never had this problem before.  for the last 4-6 weeks my radio drops out 50x times a day,  SONOS WHAT CAN YOU DO TO HELP ME?


Christian, the interference is definitely still there. The Chromecast is going to be receiving the wireless signal so it shouldn't cause too much interference. Could there be a wireless subwoofer or cordless phone base station there? If STUE is on top of a cable box or router it could also be the problem.
Userlevel 2
Hi I have a large amount of Sonos set up in an office and am also having a lot of trouble playing the radio stations... they wont play for more than a few minutes 

I have 7 rooms of sonos components diagnostic has been submitted 
Hi, I have exacly the same problem -  LTE internet connection, 3x Sonos 1 in different rooms - and whatever I'm traing to do all stations stops after 5-10 minutes. It's really a pain becouse i bought that stuff for radio! At the some time my music from cloud  storage works fine. ????

Adam
Userlevel 7
Badge +26
Hi, I have exacly the same problem -  LTE internet connection, 3x Sonos 1 in different rooms - and whatever I'm traing to do all stations stops after 5-10 minutes. It's really a pain becouse i bought that stuff for radio! At the some time my music from cloud  storage works fine. ????

Adam


Are you able to submit a diagnostic from your system and reply back with your confirmation number when this happens? Does this happen with any specific radio stations?

Also, do you have any music services which work well and access the Internet? We'll want to identify if this is a problem with the radio stations or connection to them, or if it's an issue with the network connection there in general.

Thanks
I have the same issue, I have a ONE in my bedroom and a connect downstairs, both were perfectly fine throughout the summer and over the last few months it cuts out! I have tried moving my bridge to be nowhere near routers etc, have made the wireless channel different to the sonos. sometimes it can last only 1 song, sometimes a few. Not sure what to try now.
Userlevel 7
Badge +26
I have the same issue, I have a ONE in my bedroom and a connect downstairs, both were perfectly fine throughout the summer and over the last few months it cuts out! I have tried moving my bridge to be nowhere near routers etc, have made the wireless channel different to the sonos. sometimes it can last only 1 song, sometimes a few. Not sure what to try now.
I'd be happy to take a look at a diagnostic for you. Can you follow the directions here to submit a diagnostic from your system and reply back with your confirmation number when this happens? 

Is it only Internet radio you're having trouble with or other music sources? Any radio stations in particular?
I have the same issue, I have a ONE in my bedroom and a connect downstairs, both were perfectly fine throughout the summer and over the last few months it cuts out! I have tried moving my bridge to be nowhere near routers etc, have made the wireless channel different to the sonos. sometimes it can last only 1 song, sometimes a few. Not sure what to try now.
It appears to only happen on the radio stations, I think spotify works fine, I have just submitted a diagnostic 4278065 a few mins after it cut out. Thanks
I am having the same issue with the radio stations, which is frustrating since I purchased the Sonos system to listen to my radio stations.
I know we do not have the best internet, but I do not believe it is dropping out every 2 - 3 minutes. I have done a test with the network with software that monitors every 5 seconds, with no interuptions over several hours.
Any thoughts?
I am having the same issue with the radio stations, which is frustrating since I purchased the Sonos system to listen to my radio stations.
I know we do not have the best internet, but I do not believe it is dropping out every 2 - 3 minutes. I have done a test with the network with software that monitors every 5 seconds, with no interuptions over several hours.
Any thoughts?

Hallo, sorry for long silence but I have no chance to try anything till today, but just torday I bought new router dlink DWR-921, so I start use that instead old router edimax and 4G LTE USB modem of Huawei. New router has sim card slot. And !!!! for last few hours I'm listening to my radio without any problems . Ryan thanks a lot for fast contact. It seems it was hardware problem???  bye bye for now. 

Happy user.

Adam
I have the same issue, I have a ONE in my bedroom and a connect downstairs, both were perfectly fine throughout the summer and over the last few months it cuts out! I have tried moving my bridge to be nowhere near routers etc, have made the wireless channel different to the sonos. sometimes it can last only 1 song, sometimes a few. Not sure what to try now.
Hi Ryan, did the diagnostic show up anything as it's still happening?
Userlevel 7
Badge +26
I have the same issue, I have a ONE in my bedroom and a connect downstairs, both were perfectly fine throughout the summer and over the last few months it cuts out! I have tried moving my bridge to be nowhere near routers etc, have made the wireless channel different to the sonos. sometimes it can last only 1 song, sometimes a few. Not sure what to try now.
Hi Peter,

That diagnostic shows that your Living Room player is getting hit with a lot of interference. Are there any electrical and or wireless devices sitting right around that CONNECT? What is it sitting on top of? If you have a cable box within 3 feet please see if you can separate them. A cordless phone base station can cause trouble too within 10 or so.

It looks like one of the Ethernet ports is active on the Living Room, but not run back to the network, do you have a Bluray player connected to it for a network connection?

Thanks
I have the same issue, I have a ONE in my bedroom and a connect downstairs, both were perfectly fine throughout the summer and over the last few months it cuts out! I have tried moving my bridge to be nowhere near routers etc, have made the wireless channel different to the sonos. sometimes it can last only 1 song, sometimes a few. Not sure what to try now.
Ok, I will give it a go, what about the sonos 1, that has no devices near it at all.
Userlevel 7
Badge +26
I have the same issue, I have a ONE in my bedroom and a connect downstairs, both were perfectly fine throughout the summer and over the last few months it cuts out! I have tried moving my bridge to be nowhere near routers etc, have made the wireless channel different to the sonos. sometimes it can last only 1 song, sometimes a few. Not sure what to try now.
The wireless around that one looks pretty good. When it's not part of a group do you have any trouble playing in that room?

Also, are there any radio stations in particular you have trouble with? 
I have the same issue, I have a ONE in my bedroom and a connect downstairs, both were perfectly fine throughout the summer and over the last few months it cuts out! I have tried moving my bridge to be nowhere near routers etc, have made the wireless channel different to the sonos. sometimes it can last only 1 song, sometimes a few. Not sure what to try now.
I have tried what Adam suggested below and opted to replace my router to an Asus RT AC68U. Appears that the radio doesn't cut out, early days but looking good. I would guess that as my router was overloaded with devices it may have struggled, I haven't removed and devices. I would say that sonos to radio is less tolerant to packet loss compared to sonos to spotify?
I have just started experiencing this also, works fine on other streaming services but tunein is now regularly dropping out.

diagnostic #4373061

Thursday, February 19, 2015 - 18:39 Greenwich Mean Time : Dublin, LondonUnable to play 'BBC Radio 2' - network connection speed insufficient to maintain playback buffer.

However running a speed test I have 38Mb downstream... does the diagnostic show anything else?

Cheers
Adrian
I have just started experiencing this also, works fine on other streaming services but tunein is now regularly dropping out.

diagnostic #4373061

Thursday, February 19, 2015 - 18:39 Greenwich Mean Time : Dublin, LondonUnable to play 'BBC Radio 2' - network connection speed insufficient to maintain playback buffer.

However running a speed test I have 38Mb downstream... does the diagnostic show anything else?

Cheers
Adrian

Hi, suffering the same with BBC radio 2 on a more frequent basis. Currently streaming for another radio station to check if the problem is with BBC radio 2 specifically.