Answered

Surround sound not working with tv but with music

  • 30 March 2016
  • 19 replies
  • 16850 views

Badge
I have read the forums and there is a patch for my problem.
I have a playbar, sub, and 2 surround play 1s. I dont have surround audio with tv but I do have normal audio surround with music.
I have read that there is a patch for my problem.

My diagnostic number is 5608402
icon

Best answer by sspyker843 11 December 2017, 22:42

Solved ATT Uverse / Samsung Qled TV 2017 - Surround Sound not working - Sonos only works with surround when streaming not with normal tv. Here is the solution - Pick up your ATT controller and hit "Menu" / Go down to "Options "/ Then scroll down to "Audio Options" and select "Digital" / Turn it on. It took me a while to figure this out. It has nothing to do with Sonos or TV - it is a setting on your cable box. Hope that this help all Sonos - New Samsung TV owners out.
View original

19 replies

Userlevel 3
Badge +1
Hi Oilisab and welcome to the forums!

Seeing as your music is working fine but you don't get surround with tv, I think the first thing to check is whether or not your tv receives Dolby Digital 5.1 and passes it through. You can find this under settings -> about my Sonos system, it will show the 'audio in' of the Playbar.

If you're getting anything but Dolby Digital, then it's either your tv or the input it receives (not everything has DD, it's mostly for movies and such).

If you DO get Dolby Digital, then it might be a good idea to play around with some surround settings in the Sonos app.
Userlevel 7
Badge +20
I have read the forums and there is a patch for my problem.
I have a playbar, sub, and 2 surround play 1s. I dont have surround audio with tv but I do have normal audio surround with music.
I have read that there is a patch for my problem.

My diagnostic number is 5608402


Hi Oilisab,

It looks like your PLAYBAR is not receiving a Dolby Digital 5.1 signal from your TV. CrusaderElly is correct in that there's probably a setting on your TV that you can change to adjust the audio type of the optical output.

If you have trouble finding the correct setting, reply with the make and model of your TV.
Badge
I have a samsung smartv model UN50FH5303.
I looked for the output settings in the tv and PCM id selected, i tried changing it to dolby digital but is grayed out.

The cable set-top box is connected to the tv via a hdmi. I also tried connecting the set-topbox directly to the playbar using the digital output and same thing.

Is it possible that the tv channel is not sending surround audio?
Userlevel 7
Badge +20
I have a samsung smartv model UN50FH5303.
I looked for the output settings in the tv and PCM id selected, i tried changing it to dolby digital but is grayed out.

The cable set-top box is connected to the tv via a hdmi. I also tried connecting the set-topbox directly to the playbar using the digital output and same thing.

Is it possible that the tv channel is not sending surround audio?


Hi Oilisab,

The Samsung UN50FH5303 series TV does not pass Dolby Digital through its optical port. Your best bet is to bypass the TV and wire the PLAYBAR directly into your cable box, or use an HDMI switch which can accept your various audio/video sources and output via an optical cable to the PLAYBAR.

Your cable box should output Dolby Digital from its optical connection. If you only get stereo, it's probably that particular station. Are you able to find any stations outputting Dolby Digital when your PLAYBAR is connected directly to your cable box?
I have a brand new 65' LG OLED. How do I get my system to broadcast in Dolby digital? Is shows "stereo" and sounds horrible. Volume has to be all the way up to get any sound from the surround play 1 speakers at all. The system sounds great on Apple TV and with music. Super frustrated.
Userlevel 7
Badge +20
I have a brand new 65' LG OLED. How do I get my system to broadcast in Dolby digital? Is shows "stereo" and sounds horrible. Volume has to be all the way up to get any sound from the surround play 1 speakers at all. The system sounds great on Apple TV and with music. Super frustrated.

Hi Tschub67,

The exact settings differ from TV to TV but you're looking for an option on your TV's settings menu to change the audio output to Dolby Digital. This might be under audio settings, or sound settings. It may even be called external speakers.

If you reply with the make and model of your TV I'll see if I can find the manual online and locate the exact menu settings.
Badge
I have a samsung smartv model UN50FH5303.
I looked for the output settings in the tv and PCM id selected, i tried changing it to dolby digital but is grayed out.

The cable set-top box is connected to the tv via a hdmi. I also tried connecting the set-topbox directly to the playbar using the digital output and same thing.

Is it possible that the tv channel is not sending surround audio?


Hi Oilisab,

The Samsung UN50FH5303 series TV does not pass Dolby Digital through its optical port. Your best bet is to bypass the TV and wire the PLAYBAR directly into your cable box, or use an HDMI switch which can accept your various audio/video sources and output via an optical cable to the PLAYBAR.

Your cable box should output Dolby Digital from its optical connection. If you only get stereo, it's probably that particular station. Are you able to find any stations outputting Dolby Digital when your PLAYBAR is connected directly to your cable box?


I will try using the optical connection of the cable box and reply with the results.

Thanks
Hi All,

I'm looking to purchase a sounder but worried that the passthrough from my tv won't work. My sky box and PS4 will be connected to my TV and the optical cable fed to the soundbar.

Do you know if my TV is compatible for 5.1 - Panasonic 58ax802b?

Any help would be much appreciated.

Thanks
Badge
Anything you play in your tv will make noise if you have connected the digital audio cable to the bar. The 5.1 doesnt depend in your tv. It depends in the outputs you have. Ie: A soundbar and a sub will give you 3.1, if you add a pair of play 1 to your set, you will have 5.1. So the tv here doesnt play any role because the sound is produced in the external speakers.
For some reason if i plug my ps4 into my TV and then run an optical lead to my amp from my TV it doesn't push 5.1 to my surround 5.1 speaker setup only 2.1. If i run the optical lead direct to the amp from the PS4 then it pushes 5.1 to my speakers, my worry is that my TV isn't capable of doing this if i buy a sonos soundbar?
Badge
That way it do depends in your tv. I remember that i used to connect the optical from the tv to the bar and it wont give me 5.1, but if i connected the cablebox directly to the bar worked, so I guess that depends on what kind of output you can get from your tv. Try using different output settings in your tv to see if any works.
8156140 I need a patch my surround sound stop working I have a playbar and 2 play3 only sound out of the play bar
Solved ATT Uverse / Samsung Qled TV 2017 - Surround Sound not working - Sonos only works with surround when streaming not with normal tv. Here is the solution - Pick up your ATT controller and hit "Menu" / Go down to "Options "/ Then scroll down to "Audio Options" and select "Digital" / Turn it on. It took me a while to figure this out. It has nothing to do with Sonos or TV - it is a setting on your cable box. Hope that this help all Sonos - New Samsung TV owners out.
Solved ATT Uverse / Samsung Qled TV 2017 - Surround Sound not working - Sonos only works with surround when streaming not with normal tv. Here is the solution - Pick up your ATT controller and hit "Menu" / Go down to "Options "/ Then scroll down to "Audio Options" and select "Digital" / Turn it on. It took me a while to figure this out. It has nothing to do with Sonos or TV - it is a setting on your cable box. Hope that this help all Sonos - New Samsung TV owners out. old thread but I finally came across it. This worked perfect for me
Another potential solution if you have a Spectrum cable box. Go to Menu - Settings - Devices, then scroll to Analog Output and make sure ‘Surround’ is selected instead of mono or stereo. Mine was set to stereo which prevented the surround sound from working with the TV.
I have the same problem as everyone on this thread but all the fixes have been for Samsung TVs; I have a Sony 4k tv and ive tried playing with similar settings; i still cant figure it out.
Is there a resolution for Sony tvs? As above I'm having the same issue and cannot figure it out.
Userlevel 5
Badge +13
I have the same problem as everyone on this thread but all the fixes have been for Samsung TVs; I have a Sony 4k tv and ive tried playing with similar settings; i still cant figure it out.

Is there a resolution for Sony tvs? As above I'm having the same issue and cannot figure it out.

If you check your sound/audio settings... are you able to find the format type? Do you have the option to change it to Bitstream?

Hello,

I’m having the same problem where my beam that is plugged into HDMI 1 of my Sharp Roku TV is correctly playing, but the two play:1s that i’m using as surround sound aren’t. It all used to work properly for a few weeks and now the play 1s only work when playing music, but not the TV. 

I made sure in the audio settings that my “S/PDIF and ARC” is set to Dolby Digital. 

My diagnostics number is 1957193703. Thanks a bunch. 

Reply