Answered

Support for BBC Radio HLS Streams



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

928 replies

Badge
At least it's not just me. Also you're right I am also getting short sections of audio repeating themselves. Can anyone from Sonos help us please? Tx
Userlevel 7
Badge +21
I've been on holiday this week and Radio 4, Radio 2 or Radio 5 Live have been on for about 8 hours Sunday until today. I think I have had 1 drop-out which I linked to a power cut rather than an issue with the streams.


I would be loathe to assume there is a problem beyond your 2 set-ups at this point in time.
Badge
I would really like to agree with you as I am huge Sonos fan but my setup hasn't changed for a couple of years at least. Kit is in the same place, same ISP, same router, music from any other source plays fine. I get a steady 60mbs internet connection and wifi signal is very strong through out the property. I listen to BBC radio daily with no issues up until a couple of days ago. Happy to take any suggestions as to how my setup might be causing this issue but I'm retired after 40 years working in IT and am pretty confident it's not a local issue. Tx.
Userlevel 7
Badge +22
I would submit a diagnostic and have Sonos review for any issues.
Badge
Chris, thanks for that. Never done it before, could you point me to how I do it? Many thanks.
Userlevel 7
Badge +21
In PC Controller, Help, Submit Diagnostics.

Or give Sonos a call when at home with system. They are pretty good
Userlevel 7
Badge +22
Sure - on mobile version go to settings...advanced....submit diagnostic. That will send Sonos all the info on your system and give you a diagnostic number.

I would normally say post here but as big as this thread is it may get lost in shuffle. So I would post a new question thread with your diagnostic number and issue and a Sonos rep. should come on to review. Or if you want maybe faster/easier then you could call Sonos with that diagnostic number.

Best of luck.
Badge
Thank you both for your help I will submit a diagnostic and just drop a note back here with any significant findings.
Badge +3
I've been having the same problem since yesterday with 6Music.
Drop outs between 1 to 10 secs and skipping back a few seconds.

Initially I blamed the extra Play 1 I'd added as a stereo pair yesterday, but I've reverted back to how it was before and still having issues.
Badge
Exactly the same symptoms as me. I thought I would wait 24 hours before submitting diagnostics in case the problem goes away. This evening I have had no issues at all. Will see what tomorrow brings.
Badge +3
Is yours OK now Nigel? Mine was fine all yesterday.
Badge
Hi, yes mine has been fine for the last 48 hours so I will hold off on contacting Sonos for now. Clearly there was an issue somewhere since a number of us had the same symptoms which have now cleared. I will post back here if it happens again so we can compare notes!
Bit late to this but I'm still having the same issues as above. Sorry if I've missed it in the thread but did you do anything specific to sort it?
Badge
Hi, no I didn't change anything. That's annoying you are still having issues because it brings back the question as to whether the problem lies locally or centrally somewhere. As I said I will be straight back on here if I get a repeat of the problem so in the interim if you hear nothing from me then my issue is 'quiet' .
Hi, no I didn't change anything. That's annoying you are still having issues because it brings back the question as to whether the problem lies locally or centrally somewhere. As I said I will be straight back on here if I get a repeat of the problem so in the interim if you hear nothing from me then my issue is 'quiet' .

Thanks! Sonos support have asked me to ring them so will report back what they say. Sadly I doubt its local as my system hasn't changed in ages but you never know.
Userlevel 2
I have also been suffering with BBC Radio dropouts over the last few days. I had hoped that the HLS problems were behind us.
Badge
I have had no dropouts at all for 5 days now so it would appear the problem varies by location. Will post back her if I get any more dropouts.
Okay so i called support and i've had better perfromance but i;m not entirely sure what fixed it. The guy said the hls system was stable so it MUST be my local system, and was in the middle of checking my connection from bridge to speakers when i, frankly, got bored and said i'd call back, being virtually certain this wasnt the issue due to being able to stream everything else perfectly.

HOWEVER, somewhere along the line something improved matters so here are the steps we went though, maybe it will help someone.

Do a Reset in the wifi settings in the sonos controller app.
Am sure you've deleted any radio station entries in sonos favourite or "my radio stations" and add them again. You need to do this on all the device you use to control sonos i think.
Restart the bridge and re add the speakers.
do yesterdays(?) update - no idea if this had a fix for this in it.

So yes, i did all of the above together and at some point it started working, or rather has been fine for an hour since. Sorry i know this isn't very specific but might save someone a 40 minute call to suppport
Userlevel 4
Badge +9
Reference the dropouts and repeats, note that (from my observation) Sonos starts by connecting to the highest bit-rate HLS stream available for the station (eg 320kbps). If, for whatever reason, it deems that that stream is unreliable (eg buffer empties or too many retries at fetching the next HLS 'chunk', I imagine), then it eventually connects instead to the next highest rate stream (eg 256kbps). If this is running behind the first stream, you will hear a repeat of the content. This process continues until it finds a stable stream.

The only way to see what bitrate stream Sonos is currently playing is to dig in to the diagnostics, so all the listener will hear is the dropouts and possible repeats, and then when it stabilises, will believe that the problem has gone away when in fact it has only been masked by the switch to a lower bitrate.

I observed this happen with Radio 1 a couple of weeks ago, and it ran right down from 320kbps to 48kbps(!) until it stabilised. That's despite the fact that I could play the 320kbps stream reliably from my old minimstreamer workaround without any hitches. A possible explanation for that is that Minimstreamer seems to load a bigger buffer (up to 14s, I believe) than Sonos appears to.

Coincidentally (probably), my BBC streams were reliable until I installed an early, pre-general release, Apple Music beta. Now we have a public beta, I'll be interested to see if stability improves.
Badge
Thanks for the detail in both of those last two replies. The explanation of what is happening when we see the dropouts and repeats is REALLY interesting because in order to fix any problem like this you first need to know why it's bahaving the way it is and the explanation of the system trying to find the fastest stable stream fits the symptoms perfectly. My setup is still stable ATM so am not going to touch anything for now!
Userlevel 6
Badge +3
Okay so i called support and i've had better perfromance but i;m not entirely sure what fixed it. The guy said the hls system was stable so it MUST be my local system, and was in the middle of checking my connection from bridge to speakers when i, frankly, got bored and said i'd call back, being virtually certain this wasnt the issue due to being able to stream everything else perfectly.
HOWEVER, somewhere along the line something improved matters so here are the steps we went though, maybe it will help someone.
Do a Reset in the wifi settings in the sonos controller app.
Am sure you've deleted any radio station entries in sonos favourite or "my radio stations" and add them again. You need to do this on all the device you use to control sonos i think.
Restart the bridge and re add the speakers.
do yesterdays(?) update - no idea if this had a fix for this in it.
So yes, i did all of the above together and at some point it started working, or rather has been fine for an hour since. Sorry i know this isn't very specific but might save someone a 40 minute call to suppport


I have had no dropouts at all for 5 days now so it would appear the problem varies by location. Will post back her if I get any more dropouts.

I have also been suffering with BBC Radio dropouts over the last few days. I had hoped that the HLS problems were behind us.

Hi sagalout, nigelp, and richtann.
Sounds like you three are most likely experiencing wireless interference or network problems. Mind submitting a diagnostic within the first 20mins your system is giving you any trouble and reply with the diagnostic confirmation number. Here's an article explaining how: How to Submit Diagnostic
Badge
Thanks Max, I will do as you suggest the next time I have an issue.
Out of the blue, I can't listen to BBC Radio London this morning - 'unsupported media format'. I could listen to it yesterday, and other BBC radio stream I have tried are okay. I can find no reference to BBC Radio London changing their stream format so I'm baffled.
Userlevel 6
Badge +13
Possibly a side-effect of the BBC hack on Thursday .....
Userlevel 1
Badge +2
No problem with 6 Music here.