Answered

Stop and skipping songs

  • 30 May 2018
  • 8 replies
  • 4881 views

My Sonos 1 speaker is skipping music half way through songs using Amazon Prime Music
icon

Best answer by UKMedia 30 May 2018, 13:09

Hi

Have you followed the steps in this article:

https://support.sonos.com/s/article/305?language=en_US

Let us know how you get on.
View original

8 replies

Userlevel 7
Badge +20
Hi

Have you followed the steps in this article:

https://support.sonos.com/s/article/305?language=en_US

Let us know how you get on.
I agree with many of the writers here. My system has been working perfectly since I purchased this using the same I phone and music library. My internet is also the same. The Sonos system now constantly skips songs. This is in my opinion not a wifi issue but rather a Sonos software issue. A message to the Sonos ceo and leadership team. Stop prevaricating and being evasive. You have dropped the ball here. Seriously thinking of going back to Bose. This is unacceptable. Fix the software now and own the issue now.

Look forward your early reply Sonos leadership
Do any of my fellow Sonos community members share my frustration here.
Userlevel 7
Badge +20
I agree with many of the writers here. My system has been working perfectly since I purchased this using the same I phone and music library. My internet is also the same. The Sonos system now constantly skips songs. This is in my opinion not a wifi issue but rather a Sonos software issue. A message to the Sonos ceo and leadership team. Stop prevaricating and being evasive. You have dropped the ball here. Seriously thinking of going back to Bose. This is unacceptable. Fix the software now and own the issue now.

Look forward your early reply Sonos leadership
Do any of my fellow Sonos community members share my frustration here.


9/10 this issue is caused by some form of duplicate IP issue or poor internet connection. It's not normally a Sonos issue but because of the Sonos system uses your local network environment to stream music simultaneously is impacted more. Typical triggers for this behaviour is a Router re-boot (Router forgets the IP addresses it has already issued and allocates the same number to duplicate devices) or a Sonos Update boots all of the Sonos devices (Router allocates an IP address already allocated) This 'issue' is a well known problem that Router manufactures have failed to resolve for home networks for many years but isn't in my experience a 'Sonos' issue to fix.

Can you please power down these devices for 5 secs, allowing each to complete the boot sequence before moving to the next device:

- Router
- Any wired network switch
- Any wired Sonos product
- Any other Sonos product
- All other connected network devices - A pain I know!

If this fixes the issue, I suggest that you reserve IP addresses in your Router set-up for your Sonos devices. (I use the range 192.168.0.200 and above for Sonos devices). Let us know how you get on?
I have tried all the network items that sonos has suggested. HERE IS A SOLUTION. My Solution - Go into iOS settings and go to "Display and Brightness". go to "auto-Lock" and turn that setting to never. Songs no longer skip. Just remember to change that back when you are done playing sonos. Something within iOS, the screen saver/auto-lock and sonos causes skipping when the auto-lock engages
I be been having this issue, and it is exteeenly annoying. So much so I am thinking of ditching Sonos. Whenever I play a song from my phone (100% of the time) it’s skips after 30sec - Minute. It’s not consistent how long it plays songs but skips always. That is when I am not “on” the phone ie: doing things on the phone. If if do stuff it’s plays. If I just put it down and it locks then this issue occurs. Suspect it has to do with some behind the scenes iOS power / connection settings. When streaming a Radiostation etc, it doesn’t occur. Please fix this ASAP. It’s very disruptive, and I end up not using Sonos, also why I spend $$ to get more speakers.
Userlevel 7
Badge +20
I be been having this issue, and it is exteeenly annoying. So much so I am thinking of ditching Sonos. Whenever I play a song from my phone (100% of the time) it’s skips after 30sec - Minute. It’s not consistent how long it plays songs but skips always. That is when I am not “on” the phone ie: doing things on the phone. If if do stuff it’s plays. If I just put it down and it locks then this issue occurs. Suspect it has to do with some behind the scenes iOS power / connection settings. When streaming a Radiostation etc, it doesn’t occur. Please fix this ASAP. It’s very disruptive, and I end up not using Sonos, also why I spend $$ to get more speakers.

Hi Have you looked at the article I mentioned above, in particular:

https://support.sonos.com/s/article/305#musicservice

Quote:

We are currently investigating issues with audio playback from an iPhone or iPad to Sonos when using the “From this iPhone or iPad” music source.

If you use other apps that use the iOS device audio, such as making a phone call, YouTube, social media apps, or use Bluetooth headphones while playing from “This iPhone or iPad,” you may experience audio interruptions on Sonos until you completely close or quit those apps. Until this issue is resolved, we also recommend disabling Bluetooth for the best experience.

Additionally, if there are any AirPlay devices on your network, such as an Apple TV or Airport Express, audio from “This iPhone or iPad” may stop abruptly until AirPlay is disabled on those devices.

We recognize this isn't an ideal solution for those who use AirPlay regularly at home, but if you prefer to continue playing to Sonos from “This iPhone or iPad” without interruption, refer to the device manufacturer’s instructions for disabling AirPlay. Once AirPlay is disabled, close and re-open the Sonos app and start playback again.
I have tried all the network items that sonos has suggested. HERE IS A SOLUTION. My Solution - Go into iOS settings and go to "Display and Brightness". go to "auto-Lock" and turn that setting to never. Songs no longer skip. Just remember to change that back when you are done playing sonos. Something within iOS, the screen saver/auto-lock and sonos causes skipping when the auto-lock engages Sonos shoudl really fix that. its a good IOS feature.
We are currently investigating issues with audio playback from an iPhone or iPad to Sonos when using the “From this iPhone or iPad” music source.

If you use other apps that use the iOS device audio, such as making a phone call, YouTube, social media apps, or use Bluetooth headphones while playing from “This iPhone or iPad,” you may experience audio interruptions on Sonos until you completely close or quit those apps. Until this issue is resolved, we also recommend disabling Bluetooth for the best experience.

Additionally, if there are any AirPlay devices on your network, such as an Apple TV or Airport Express, audio from “This iPhone or iPad” may stop abruptly until AirPlay is disabled on those devices.

--
Hi,

I dont use Airplay, Apple TV etc
I don't have (nor want to) install Sonos on my laptop as all my music in on my phone and external drive.
I don't play music from my latop - so its always going to be "this iPhone or iPad"
As mentioned the interruptions have nothing to do with making a phone call or YouTube etc.
It also happens when bluetooth is off

When do you expect to have this issue solved. sound like this has been plaguing Sonos for a while.
I would suggest that turning off any native functions on a device to make Sonos work is not really a solution.

Best

Reply