Answered

Spotify skips to next song or stops playing, other sources work just fine meanwhile


Userlevel 1
The past couple of months when playing music from Spotify on any of the sonos speakers the music skips to the next song or stops playing at random points. It can be after 2 songs or half a day. The controller reports connection to spotify lost. Sometimes i can immediately click play again and it starts over but sometimes it takes 1-10 min before i can resume. Meanwhile i can play from other sources just fine so it seems like a Spotify specific issue. If i try to play using spotify connect then as i select the speaker, it changes it back to the previous target.
icon

Best answer by Edward R 19 June 2019, 13:58

We have noticed this thread gaining a lot of traction of late, with most visitors to this thread opting not to actively engage in troubleshooting. The information in this post will be marked as the best answer to assist those reading along. If you are currently engaged in troubleshooting in this thread, we will of course continue to assist you.

Aside from the advice listed in this thread, if you are encountering playback issues with your Sonos devices, there are a few points you will need to explore. Some sources may seem fine, while others present problems. Often, services can be accessed in slightly different ways, with some methods being more susceptible to disruption, as when compared to others.

Is the issue the fact that your music is being interrupted? Commonly, this can come as a result of wireless interference. Are you perhaps using an incompatible network configuration or hardware that does not meet our system requirements?

Having read the information linked above, if you are still having issues, please post a response in this topic, with the following information:

  • What devices do you have?
  • Has anything changed on the network?
  • Which service(s) are you trying to listen to?
  • Is the behaviour always the same?
  • Can you recreate it with ease, or is it random?
Be sure to include the a diagnostics confirmation number, too.
View original

231 replies

This is for Paul in the escalation team  ref:_00D1N2JMtd._5002Kmcmy0

I use a ethernet cable to connect my Sonos, the router Is 6 inches away. None of your options make any difference. My router is made by Sky And only has my Sky box plugged in, no change for 10+ years apart from router upgrade a couple of years back. I have tried everything I’ve been asked to, nothing in my setup has changed for years and as this is a new problem and the amount of people complaining about this, may I suggest the problem is at your end not mine.

Chiming in to offer my perspective on the issue at hand.  I can certainly appreciate John G’s attempts to help as an IT professional myself… However… there is definitely something wrong with the Sonos app and streaming Spotify.  I am a longtime amazon music subscriber (still am) while recently also subscribing to Spotify to test it out and potentially switch over.  This is the annoying issue I immediately noticed after having ZERO issues with Amazon music for years…  Jamanda posted back on the previous page and included a screen capture which shows the connection to Spotify being lost.  I’ve also seen another one where a song gets skipped completely which indicates the song is not encoded properly…  Odd since I can go back and play the song.  As others have suggested piping the sound directly from the Spotify app works perfectly however this is not preferable as you lose the Sonos playback features.

So before everyone goes ripping through their network trying to find issues which don’t exist I’d say keep the pressure on Sonos!

Same issue here recently. When streaming Music on Spotify via the SONOS App on iOS, Songs randomly skip to the next song in the middle of the song.

 

I do have a Playbar, a Sub and two One SL

 

Diagnostics confirmation number 1002688233

So have been playing with it for a while…

 

Started playing a playlist and following happened: 

  • skipped in the middle of song 2 to song 4 of the playlist: Diagnostics number 295796789 & 1204798310
  • skipped in the middle of song 6 to song 8 of the playlist: Diagnostic number 660836147, 1476917138, & 2043341486

It’s getting pretty annoying. 

Userlevel 1
Badge +1

Hello!

I have the same problem since yesterday using Spotify on my Sonos system. Songs skip, music stops randomly.

I suppose there is a problem between Spotify and Sonos. Don’t tell me to check my wifi, everything is ok...

Userlevel 7
Badge +14

I get this too lately.  I don't think Sonos have a clue of the cause to be honest (it started quite suddenly in a particular update quite some time back) and you will go through the usual diagnostics and troubleshooting.

My Sonos playlists tend to be a mix of NAS and Spotify tracks and you know which are Spotify by when it just skips to the next track - even if that is another Spotify one.  When my daughter plays playlists from the Spotify app directly (I hate that App!), it never (as far as I can recall) skips.

We are experiencing the exact same issue with erratic cut outs of songs followed by restarts in 5 - 15 seconds playing the next song. While we usually use Spotify we have seen this happen with Google Music as well. We have two Sonos 3 that are wired and three Sonos 1 that are Wifi. It's making the system unusable

Just adding my voice to the crowd. I am eperiencing  this on all my devices, wired and wireless. And I have had a ping running to 8.8.8.8 (google) with 11ms rtt and non dropout when the problem occurre. Starts a song… then skips ahead two tracks. 
 

When it happens I get a pop up “unable to play ’[song]’ - The connection time Spotify was lost. Note that I am a Spotify premium subscriber. 
 

here is a diagnostic code: 1621423807

Userlevel 1
Badge +1

I will do these steps, however I can tell you, that if I start playback from the Spotify app and set to play through my Sonos devices, everything works perfectly. If I start the exact same playlist through the Sonos app, the skipping issue starts.

 

Something must be wrong in the Sonos app, when playing Spotify. 

 

 

This! EXACTLY!

I’m almost sure that the problem doesn’t come from our wifi, systems, or anything else. The problem is either with Spotify way of streaming or Sonos app. There wasn’t any problem and suddenly since some days it occurs… So please don’t tell us to check our installation when there is 99% chance the bug is related to Sonos app or way of streaming or I don’t know what else that shouldn’t concern us...

And soon there is the big new update with Sonos software… Perhaps it’s only chance, but I suspect something. I hope we won’t have to wait the Sonos update in June to have this problem fixed!

 

Thank’s!

We all seem to have started to experience the specific skipping issue within a very recent timeframe. So it’s likely not interference from all of our separate WiFi’s, all simultaneously… it’s likely a Spotify or Sonos app/server issue that they need to acknowledge and then rectify.
 

My WiFi has been the same for 5 months. Perfectly stable, strong connection. I’ve only had issues since last week. Therefore the underflow errors were probably always present and have had no real-world effect on my Sonos’ performance at all, as I would have noticed their impact ages ago.
 

If there is a way to escalate the issue internally, whilst we all troubleshoot, can you do that @John G ?

I totally agree with you, and I think that for this very reason Sonos should be transparent and honest about it, rather than acting as if it were a “costumer setup” problem. It would save us all much time to avoid all these useless manipulations, and phone calls and trials and errors that have actually absolutely nothing to do with the actual problem. We’re in a bad PR handling here, in my view. But like you say, Sonos doesn’t have much leverage with a giant such as Spotify.

My Sonos system (I have 3 Play1s and a Beam) is having ongoing issues when streaming from my Spotify account.  A song will get hung in the Queue (can see bars dancing for 5secs with no sound) and then a box will pop up saying “Unable to Play” XYZ Song “the Connection to Spotify has been lost.”  The issue is almost constant now.

Re my unsuccessful diagnosis: Have 300mbps symmetrical and other steaming (incl video) video services are 100% fine (so would not think it is a broadband issue).  In Sonos, other music services (eg, Amazon Music) work without issue.  So would appear to be an issue with Spotify and Sonos integrating?  On the Sonos App, I tired Removing and Re-adding my Spotify account, but that doesn’t improve things.  Is there a solution to this … been working poorly to not at all for days.

 

https://status.sonos.com/

Hello @RonSingapore ,

Can you submit a diagnostic report from your system while the Sonos player is wired to the network and after 5 minutes of testing?

I’d like to be able to look at the communication data from that configuration so I can offer you more specific and less general advice. It’s great that Sonos is able now to run on Wifi but a WiFi network environments are almost as unique as fingerprints and sometimes a wired connection  will bring superior connectivity. 

As I’ve mention before, Sonos can create it’s own mesh network and be isolated on it’s own channel but that will only happen if one Sonos product is wired to the network. Being able to compare these configurations against each other will all me to offer a more tailored analysis of your situation.

@Jean C. I submitted diagnostic report 492588371 as requested. After you review, please advise how I can switch back to wifi. Thanks

Same probleme here.

Diagnose number: 1827134823

 

  • What devices do you have?
    • multiple sonos speakers
  • Has anything changed on the network?
    • addition of boost
  • Which service(s) are you trying to listen to?
    • Spotify
  • Is the behaviour always the same?
    • Yes
  • Can you recreate it with ease, or is it random?
    • Happens very often but random. Easy to replicate

Diagnostic report: 1792487440

Spotify playback has been randomly skipping and stopping for months now, on both Sonos S1 and S2.

I have Spotify Family Premium and the Spotify user-account is definitely NOT being used on other devices, as it was setup specifically for this one system.

As far as I am aware, starting the stream from within the Spotify app uses a different server than starting it from within the Sonos app. So it’s entirely possible the issue is at the server side, which is owned by Spotify. All Sonos does is point to the server stream that Spotify built in to the interface. 

Badge

Can anyone confirm if things have been better since the update? Mine has been 100% for the past few days surprisingly, I didn’t want to jump the gun and jinx myself, but I heard back from support today (again) with this:

We just wanted to confirm if these issues are still occurring now. There have been a few things on our end which may have contributed to these errors that have since been resolved.

I wonder if they found an issue with Spotify and were able to rectify it? 

 

Yes, it seems like the issue is finally fixed! It has been working flawlessly for the last few days without skipping. Wished they would have officially acknowledged that there was a problem though but glad that it’s fixed now. *fingers crossed* 

Mine has started doing this from last week.

worked fine for 8 years, all of a sudden Spotify plays for 5-6 songs then mid song skips 2 along, always 2 along. Been through different t set ups with different twitter chats nothing changes! 

Same here

  • What devices do you have? 
  • Has anything changed on the network? 
  • Which service(s) are you trying to listen to? 
  • Is the behaviour always the same? 
  • Can you recreate it with ease, or is it random?

 

I’ve been having this issue for months but recently realized it is only with Spotify played through Sonos. Spotify through Airplay 2 or through Apple TV works fine and all other sources work fine. I have 7 Play:1, 2x One, 1x Beam and 1x Sub. I’ve used ethernet directly from the router to a One to enable Sonos Net but recently found just using the wireless 2.4 network from the router has less drop outs on Spotify but still quite bad. 

The behaviour is very consistent and I can recreate it with ease.

Diagnostic confirmation number 171272017

 

Thanks for any assistance 

fact is.. spotify sucks on sonos.. 

spotify shoudl figure it out.. 

 i have all of my equipment hardwired and it always skips/drops music.. ridiculous 

I followed Edward R's advice to check wireless interference as a possible reason for the Spotify problem and was able to eliminate the skipping, just by switching the Sonos wireless channel from 1 to 6. I have my Play 3 wired via ethernet cable to my Orbi Satellite router, and they sit < 1 ft apart. But I was able to eliminate proximity as a source of interference. Note that, as others have reported, this problem was oddly specific to playing Spotify through Sonos, whether starting from the Sonos app or Spotify app. I had no problem playing Spotify to my Google Home, to my Airpods or other bluetooth devices, or from the device itself (iOS or MacOS). Nor did I experience issues when playing Pandora tracks through Sonos. With the channel switch, Pandora still works fine, as expected. So, thanks, Edward R!! ☺
Userlevel 7
Badge +20
@gruntso There are still wireless communication errors showing up. Also the data is not getting to your speakers fast enough. Your Sonos system is on a busy wireless channel, channel 1 looks best in your area. Try that, then go through our troubleshooting guide which covers many common troubleshooting tips. If you're still having issues it would be a good idea to continue troubleshooting live with our phone team. Please give us a call, our number is found here.
Badge

Trying to post in this thread since not getting any attention by support on https://en.community.sonos.com/troubleshooting-228999/sonos-loses-connection-to-spotify-6839625 . 

Had these problems just today. New diagnostic: 1183329555. Please stop arguing that it is a network issue, my network is NOT the problem (Spotify on the phone using same network works just fine - other network sources such as last.fm, SR etc works just fine on my Sonos system). This is an issue with Sonos <> Spotify.


Hi Jeff, thanks for your reply.
I switch off the router and sonos speakers by the mains every night and they come back on around 3pm every day. So I don't think rebooting will help as they are switched off daily.
I will give a call on Monday when the lines are back open


If you are doing this every night, if you haven't already you will want to reserve permanent IP addresses for your Sonos devices (at the very least). Most residential routers do not keep track of their assigned IP addresses across a reboot, which can lead to duplicate IP addresses causing sporadic connection problems. In your router setup there will be a way to reserve the same IP for each device, thus assuring it will never hand out a duplicate.

Hi @John G , 

so I took all the steps you suggested:

  1. Tried all kinds of different channels on my router for the 2.4 G network, error still occured
  2. Removed the surround set-up, had a separate room for each of my speakers, tried all of them separately, still skipped songs no matter which speaker I selected to play music.
  3. Connected one of my One SL to the router directly via ethernet cable. Played music only on this speaker, still songs were skipped. Additionally switched channels in the SonosNet settings (making sure channel of SonosNet is not the same like the router channel as suggested in this post Change your Sonos system’s wireless channel. No improvement.

 

Eventually after having tried all of the above without seeing any improvement, I called in with a phone agent. We went thru all different kind of analysis of my Sonos setup, he saw some causes for network interference and worked on solving them. He also said general connectivity for my system is good and should not cause an issue. He also told me, that the skipping of spotify songs via the sonos app is a known issue, due to problems in the interface sonos has in place for third party streaming platforms. However this seems to affect Spotify only. According to his information, Sonos is working together with Spotify in order to solve this issue in the next big software update which will be released in beginning of June. 

I really hope you guys will be able present the solution with the new update, I won’t be liking to play my music through the spotify app the whole time…

 

 

 

Userlevel 5
Badge +16

Hi @wentzel thank you for reaching back out to us. 

At a quick glance, I would try changing the Sonosnet channel from 1 to 11

I’m also including a master list of Unifi and switch settings that you may want to look at:  

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.
  • Force Protocol Version = IEEE 802.1d (Classic)

 

CST Port Configuration

  • Set both "Port Cost" & "External Port Cost" to 0 (Auto)
  • Set the "External Port Cost" to 2 (10Gb)

Please keep us posted on how things are working. 

Reply