Answered

Spotify skips to next song or stops playing, other sources work just fine meanwhile


Userlevel 1
The past couple of months when playing music from Spotify on any of the sonos speakers the music skips to the next song or stops playing at random points. It can be after 2 songs or half a day. The controller reports connection to spotify lost. Sometimes i can immediately click play again and it starts over but sometimes it takes 1-10 min before i can resume. Meanwhile i can play from other sources just fine so it seems like a Spotify specific issue. If i try to play using spotify connect then as i select the speaker, it changes it back to the previous target.
icon

Best answer by Edward R 19 June 2019, 13:58

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

269 replies

Userlevel 7
Badge +18

Hi @Alain 

This thread is relating to playback issues on Spotify, not Deezer. I recommend you start your own topic by visiting Ask A Question, should you need more help.

Note that to put your system onto WiFi, you won’t need any further ethernet connections - no need for a cable from the router to the Playbase. Please follow the instructions in my post above.

Due to the age of this thread, I am now closing it to further activity. Should anyone be having playback issues on Spotify, please start a new topic, or join a more recent one.

Userlevel 2

I can’t say, I am using Deezer, not spotify or Sonos radio.

I will try to remove sonos bridge this week end, but it means I need ethernet cable from router to playbase5 which is not so easy

Userlevel 7
Badge +18

Hi @Alain 

To be clear, are you saying that it seems to be particular tracks on Spotify that won’t play reliably? No, I have not noticed that before.

How is performance from other sources, like Sonos Radio, for example?

As you mentioned, trying out WiFi rather than using the Sonos Bridge might be the way to go - the Bridge is an old product, and no longer up-to-scratch for some uses/environments. Please go to Settings > System > Network > Wireless Setup to set your system up for WiFi, and just unplug the Bridge from power to make the transition. Simply powering the Bridge back on again (with it connected to ethernet) will take your Sonos system back off WiFi.

 

Userlevel 2

Thanks for helping.

Sonos controller is directly connected to the router with an ethernet cable. PlayBase 1 are not in the same room.

Looks like some tracks are hardly read as other ones are always read at first try. You never noticed that before ?

New diag : 2092177498.

 

Userlevel 7
Badge +18

Hi @Alain 

Your Bureau speakers are having trouble receiving the data stream fast enough for uninterrupted playback.

I recommend you reboot your router by removing power for a full minute.

Test playback a few minutes after WiFi returns, and if it’s already better, then I recommend you just reboot your router several times a year.

Normally I’d suggest reducing interference, but there’s no indication of that being a problem. Just in case, however, please ensure your router and Bridge are at least 1m apart.

Finally, it looks like your Playbase might be in the same room as the Bridge - if it is, if nothing else helped, and if you can, please try connecting the Playbase to the router with ethernet instead of the Bridge.

I hope this helps.

Userlevel 2

I got the same issue.

I will try to remove sonos controller this week end if it can help.

Diagnostic : 2036621421

Userlevel 7
Badge +18

Hi @OIH 

Your diagnostic is devoid of speakers, indicating networking issues. I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

Diagnostics # 51926055

Our Sonos will work fine most days and then randomly will skip every other song and then play the next song will start 20 seconds into the song. We music via Spotify through the Sonos app.

Userlevel 7
Badge +18

Hi @Hatclub 

Please remove power from your router and Sonos devices for a full minute, then turn the router back on. Once the WiFi is available again, please power on the ethernet-wired Main Office speaker and wait for a solid white light before turning on the other speaker.

If the issue returns, I recommend you get in touch with our technical support team directly.

I hope this helps.

Hi

I fairly regularly have drop-outs with spotify - sometimes just for a few seconds, sometimes the track skips completely after a longer pause. I’ve just had two in fairly close succession.

I have submitted diagnostic 1466478496

Phil

Userlevel 7
Badge +18

Hi @JohanL 

Your speaker is reporting that your router isn’t performing certain networking tasks reliably. I recommend you unplug your router for at least 30 seconds, then plug it back in again.

Randomly jumps to next track while using Spotify. Usually multiple times within a few minutes and just after a few seconds of playing a track.

#473125029

Userlevel 7
Badge +22

Have had the same issue as others for 3 years+ now and my Sonos is unusable with Spotify, which is the only place I play music from. The problem just suddenly started happening one day.  Whether I play from Spotify app OR Sonos app the tracks skip, stutter, stop all together, and randomly miss out certain tracks. My partners phone posts fine, mine doesn’t (both updated and recent iPhones), neither does my Mac laptop. I love music, was a fan of Sonos for the first year or so we had it ……but now nothing: why is it taking over three years to resolve an issue so many are experiencing? What do we need to do to get the brand to take this seriously? 

 

You claim to have had this issue for 3 years and it makes it unusable, and yet this is your first post on the forum. Hmmm, ok. As has been said four posts above, you need to contact the Sonos tech support folks.

Have had the same issue as others for 3 years+ now and my Sonos is unusable with Spotify, which is the only place I play music from. The problem just suddenly started happening one day.  Whether I play from Spotify app OR Sonos app the tracks skip, stutter, stop all together, and randomly miss out certain tracks. My partners phone posts fine, mine doesn’t (both updated and recent iPhones), neither does my Mac laptop. I love music, was a fan of Sonos for the first year or so we had it ……but now nothing: why is it taking over three years to resolve an issue so many are experiencing? What do we need to do to get the brand to take this seriously? 

Badge

Hi @Guidoooh 

If it’s the problem I’m thinking of (and it sounds like it is), it was fixed 2 weeks ago. Please make sure your Sonos system software is up-to-date:

From the Settings tab, tap System > System Updates > Check for Updates.

If that doesn’t help, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

Solved the problem with the help of support :relaxed:

Userlevel 7
Badge +18

Hi @Guidoooh 

If it’s the problem I’m thinking of (and it sounds like it is), it was fixed 2 weeks ago. Please make sure your Sonos system software is up-to-date:

From the Settings tab, tap System > System Updates > Check for Updates.

If that doesn’t help, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

Badge

I've been experiencing the same problem for a few weeks now. That a song on Spotify is skipped. See also a notification in the app that the connection from Spotify would be broken. I don't have that problem with other services or with local music.

Userlevel 2
Badge +3

Mine started off skipping songs, etc but now over the past few days it’s getting worse, songs stuttering on and off through playback now. 
It’s that annoying I’m having to just turn it off? Never had any problems and loved my set up until a few months back but proving to be to frustrating and annoying at the minute. 
I was going to get a roam but not bothering with that now. 🤦🏼

Hi @rwperio,

 

Thanks for the diagnostic. Unfortunately, you’re running into an issue we’re aware of that can cause players to skip tracks or stutter during Spotify playback.

We are aware of this issue with Spotify, and we are actively working with them on a resolution. For the time being, please make use of Spotify Connect when listening to music on Sonos. We do not have additional information to share at this time, but we will notify as updates become available.


More than 3 weeks and no updates?  I have been patient with the constant interruptions hoping Sonos would fix this but it appears that isn’t going to happen anytime soon and using connect is not the answer.  Is there any update on getting this addressed?

I have been having the same issue as many others with songs not encoded correctly or skipping with Spotify. A couple of things I noticed when I add a song to the queue it usually will not play. If I catch it when this occurs I can hit pause then reverse and the song will play.  I have also noticed that when playing a Spotify playlist, a song will play for a few seconds and fade out to the next song. If your not paying attention you may not catch it. This started for me about a month ago after one  of the updates. I read that Sonos is aware of this and is working with Spotify to fix this. It would be helpful if Sonos would send an email regarding this plus post it where everyone can easily read about it instead of having everyone jump through hoops trying to fix it when you know there is an issue. I waited awhile before posting about this thinking Sonos would fix the issue.  No such luck. 
Ive done the rebooting the router and unplugged my 3 speakers. The problem still exists.  

Badge

Same issue here. :(

Jeff - I am having similar issues where every now and again during the day a song will start playing and ~15 seconds in will skip to the next one. Insanely annoying because there is no rhyme or reason and I have good wifi coverage AND the Sonos Boost.

Diagnostic conf number: 374923933

 

Thanks,

Brad

Badge +17

Hi @rwperio,

 

Thanks for the diagnostic. Unfortunately, you’re running into an issue we’re aware of that can cause players to skip tracks or stutter during Spotify playback.

We are aware of this issue with Spotify, and we are actively working with them on a resolution. For the time being, please make use of Spotify Connect when listening to music on Sonos. We do not have additional information to share at this time, but we will notify as updates become available.

CONFIRMATION NUMBER: 773318790

 

I have the same problem if not worse.

I have 4 x SONOS ONE SL’s + ONE SUB AND ONE AMP.

Each room has a PC with SONOS on there, all speakers are hooked up via ethernet with WIFI turned off. IP addresses are locked by the firewall 10.10.20.170-176

We have been receiving a bunch of dropouts. Music plays but then randomly the music stops playing but the counter is still counting in the application. 

The logs submitted should show the dropouts. It is happening in all 4 rooms without any idea why.

HELP, this is very bad and annoying.

 

Each room using a Spotify account, we have a family account with Spotify.

 

Please contact me ASAP.

Hi, I’m also experiencing this issue starting about two weeks ago after years of no problems. While playing Spotify, the song cuts out and immediately skips to the next song in the queue. A few songs may then play without issue but then it happens again, seemingly at random. I can’t think of any significant changes to my home network that would have caused this. Diagnostic code is 735907413. This is extremely annoying. Please help.

Thanks.