Answered

Spotify skips to next song or stops playing, other sources work just fine meanwhile



Show first post

235 replies

fact is.. spotify sucks on sonos.. 

spotify shoudl figure it out.. 

 i have all of my equipment hardwired and it always skips/drops music.. ridiculous 

My Sonos system (I have 3 Play1s and a Beam) is having ongoing issues when streaming from my Spotify account.  A song will get hung in the Queue (can see bars dancing for 5secs with no sound) and then a box will pop up saying “Unable to Play” XYZ Song “the Connection to Spotify has been lost.”  The issue is almost constant now.

Re my unsuccessful diagnosis: Have 300mbps symmetrical and other steaming (incl video) video services are 100% fine (so would not think it is a broadband issue).  In Sonos, other music services (eg, Amazon Music) work without issue.  So would appear to be an issue with Spotify and Sonos integrating?  On the Sonos App, I tired Removing and Re-adding my Spotify account, but that doesn’t improve things.  Is there a solution to this … been working poorly to not at all for days.

My Sonos system (I have 3 Play1s and a Beam) is having ongoing issues when streaming from my Spotify account.  A song will get hung in the Queue (can see bars dancing for 5secs with no sound) and then a box will pop up saying “Unable to Play” XYZ Song “the Connection to Spotify has been lost.”  The issue is almost constant now.

Re my unsuccessful diagnosis: Have 300mbps symmetrical and other steaming (incl video) video services are 100% fine (so would not think it is a broadband issue).  In Sonos, other music services (eg, Amazon Music) work without issue.  So would appear to be an issue with Spotify and Sonos integrating?  On the Sonos App, I tired Removing and Re-adding my Spotify account, but that doesn’t improve things.  Is there a solution to this … been working poorly to not at all for days.

 

https://status.sonos.com/

Had the same issue… finally just removed the Sonos app from my android phone and reinstalled the app...it re-connected to the wifi and now seems to be working...try that if you have not yet already

Same issue - Spotify loses connection when played thru Sonos, Pandora works fine.  Spotify works on other devices and wifi has plenty of speed and bandwidth.  

 

Using 3 PLAY 3’s, Soundbar, Connect:Amp, and Boost.  The Boost is hard wired into a Linksys Velop nest system with 4 nodes, the rest of the Sonos products are using wifi/Sonosnet.

 

All software is updated.  The router, modem, mobile devices, apps, laptops and Sonos products have all been updated, restarted, reloaded, and unplugged repeatedly.  It occurs with or without the Boost and on all channels (1, 6, 11)  This problem is new in the last 2 weeks, prior to that no issues for several years  Otherwise, no recent changes have been made aside from recommended software updates. 

Thanks in advance.

Diagnostic # 598934767 

Note the Spotify outage on https://status.sonos.com/

Thanks for the prompt response...my only complaint is that I have spent the last week troubleshooting.  I’ve scoured this forum, I feel like this notice should have been more prominent.  Would have saved me hours of messing around!

 

Looking forward to a fix - thanks again for your help.

The outage is roughly 24 hours old. It would be challenging to troubleshoot any other issues you may be having while the Spotify servers are down. I’d wait until the Spotify issues are resolved, as indicated on the status page, and if you’re still having an issue, then submit a system diagnostic within 10 minutes of experiencing this issue, and contact Sonos Support to discuss it. 

I usually suggest the phone folks, they have more tools available, and are available Monday through Friday during business hours. Twitter support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution. 

Sounds good, given how great everything has functioned for years prior I have to imagine the Spotify outage is the problem.   I appreciate the help.

i don’t think the issue is with Spotify...i re-installed the Sonos app and it works for me now….i still think the issue is on the Sonos end…. 

Spotify has apparently rectified the issue, I just saw Ryan post in one of the other many threads that it had been fixed. 

My sonos keeps skipping Spotify tracks. It will say it couldn't buffer. 

 

Diagnostic 1665991096

 

Can you help? 

i am getting this issue again…. it’s less frequent than a few days ago but still sometimes it will skip mid song and say something about buffering and speed issues …. wondering if anyone else is getting it…. it’s so annoying!! Great when it all works but this is happening too often!!! 

Having a similar issue. Just upgraded my Bridge to a Boost. I’ve tried changing wireless channels with no improvement. Diagnostic #: 1411412156

Userlevel 1
Badge +1

Hello!

I have the same problem since yesterday using Spotify on my Sonos system. Songs skip, music stops randomly.

I suppose there is a problem between Spotify and Sonos. Don’t tell me to check my wifi, everything is ok...

Same issue here recently. When streaming Music on Spotify via the SONOS App on iOS, Songs randomly skip to the next song in the middle of the song.

 

I do have a Playbar, a Sub and two One SL

 

Diagnostics confirmation number 1002688233

Same issue here recently. When streaming Music on Spotify via the SONOS App on iOS, Songs randomly skip to the next song in the middle of the song.

 

I do have a Playbar, a Sub and two One SL

 

Diagnostics confirmation number 1002688233

So have been playing with it for a while…

 

Started playing a playlist and following happened: 

  • skipped in the middle of song 2 to song 4 of the playlist: Diagnostics number 295796789 & 1204798310
  • skipped in the middle of song 6 to song 8 of the playlist: Diagnostic number 660836147, 1476917138, & 2043341486

It’s getting pretty annoying. 

Hi, exact same issue as LukasOnTheRun. Started this week. I have 3x SONOS ONE Gen 2 SL’s.

When streaming Music on Spotify via the SONOS App on iOS 13.4.1, songs randomly skip to the 2nd song ahead, in the middle of the current song. E.g: 1st song skips to 3rd song.

 

I ran a diagnostic as soon as it happened, just now. Confirmation # 1308531946
 

I even tried unplugging and restarting my router, then replugging in all my Sonos’ individually. I even assigned them static IP’s too. Seems none of that is the issue…

 

What’s going on??!

Lately regularly Spotify numbers are not played in full through my Sonos Network (regardless which player or channel). Just again, diagnose 233532739. I’ve tried channel 1 (current), 6 and 11. All experiencing the same.

Appreciate support. With kind regards, Lenno Maris

Badge

Same problem here. Random interuptions on Spotify. I only have a Play 5 1st gen directly connected with a ethernet cable with the modem.

Diagnostic: 1931085873

Badge

My system (Play5, Move, One) just started doing this constantly since the last update.  Getting so tired of Spotify tracks skipping part way through the song.  

diagnostics: 

1301968846

Same issue with my Sonos and Spotify setup.

Skips from song 4 to 6, and so on.

 

Diag id: 1628964520

@storebatfar @Nuff Bass @Boncholio @LMaris @Jamanda @LukasOnTheRun @Gwenddoleu @kevinyim @aaronnicholl @seb.a.james99 Thank you for reaching out us here in the Sonos Community. If you are still having the issues with the Spotify music service with your Sonos system then please confirm for us if anything changed after doing the steps provided in the Best Answer for this post thread? I ask as the diagnostic reports that most of you have submitted show you are being hit with wifi interference and network equipment performance issues for Sonos.

If you have not followed the Best Answer steps then please do and follow up with a new diagnostic report number here along with those testing results. If you have followed those steps and are still having the issues with Spotify then we will need your full network topology with the model names and numbers of the products that are wired or wirelessly connected on your network for any modem, router(s), extenders, access points or switches (managed or unmanaged). The reason for this is some of your diagnostic reports indicate that you are using more than one network router from your Internet Service Provider and have added another router like a mesh system to your network adding to network interference, as well as some of you are using Enterprise grade network equipment and may need the settings corrected for them.

Before I would ask you to call in for live agent phone support I would strongly recommend that you at the very least you please power re-boot off your wifi equipment for 30 seconds with no lights on it, meaning no battery backup, then power it back up. While this equipment is powering back on then power re-boot off your Sonos units for the same time with no lights and plug them back in to power, no button pressing is needed. While Sonos products are powering on then re-boot the device(s) running the Sonos app. When you are re-connected then test your Spotify playback for 30+ minutes. You can follow up here with the testing results and a new diagnostic report number for us to compare.

Lastly, if after you have gathered your network topology, adjusted any network settings, completed a full wifi network and Sonos product(s) re-boot and are still having the audio issues then I would recommend you call in to our agents for further troubleshooting as they will have more tools available to them.

Badge

@storebatfar @Nuff Bass @Boncholio @LMaris @Jamanda @LukasOnTheRun @Gwenddoleu @kevinyim @aaronnicholl @seb.a.james99 Thank you for reaching out us here in the Sonos Community. If you are still having the issues with the Spotify music service with your Sonos system then please confirm for us if anything changed after doing the steps provided in the Best Answer for this post thread? I ask as the diagnostic reports that most of you have submitted show you are being hit with wifi interference and network equipment performance issues for Sonos.

If you have not followed the Best Answer steps then please do and follow up with a new diagnostic report number here along with those testing results. If you have followed those steps and are still having the issues with Spotify then we will need your full network topology with the model names and numbers of the products that are wired or wirelessly connected on your network for any modem, router(s), extenders, access points or switches (managed or unmanaged). The reason for this is some of your diagnostic reports indicate that you are using more than one network router from your Internet Service Provider and have added another router like a mesh system to your network adding to network interference, as well as some of you are using Enterprise grade network equipment and may need the settings corrected for them.

Before I would ask you to call in for live agent phone support I would strongly recommend that you at the very least you please power re-boot off your wifi equipment for 30 seconds with no lights on it, meaning no battery backup, then power it back up. While this equipment is powering back on then power re-boot off your Sonos units for the same time with no lights and plug them back in to power, no button pressing is needed. While Sonos products are powering on then re-boot the device(s) running the Sonos app. When you are re-connected then test your Spotify playback for 30+ minutes. You can follow up here with the testing results and a new diagnostic report number for us to compare.

Lastly, if after you have gathered your network topology, adjusted any network settings, completed a full wifi network and Sonos product(s) re-boot and are still having the audio issues then I would recommend you call in to our agents for further troubleshooting as they will have more tools available to them.

Mine is hardwired but I’ll do as you suggest and report back. Thanks. 

@storebatfar @Nuff Bass @Boncholio @LMaris @Jamanda @LukasOnTheRun @Gwenddoleu @kevinyim @aaronnicholl @seb.a.james99 Thank you for reaching out us here in the Sonos Community. If you are still having the issues with the Spotify music service with your Sonos system then please confirm for us if anything changed after doing the steps provided in the Best Answer for this post thread? I ask as the diagnostic reports that most of you have submitted show you are being hit with wifi interference and network equipment performance issues for Sonos.

If you have not followed the Best Answer steps then please do and follow up with a new diagnostic report number here along with those testing results. If you have followed those steps and are still having the issues with Spotify then we will need your full network topology with the model names and numbers of the products that are wired or wirelessly connected on your network for any modem, router(s), extenders, access points or switches (managed or unmanaged). The reason for this is some of your diagnostic reports indicate that you are using more than one network router from your Internet Service Provider and have added another router like a mesh system to your network adding to network interference, as well as some of you are using Enterprise grade network equipment and may need the settings corrected for them.

Before I would ask you to call in for live agent phone support I would strongly recommend that you at the very least you please power re-boot off your wifi equipment for 30 seconds with no lights on it, meaning no battery backup, then power it back up. While this equipment is powering back on then power re-boot off your Sonos units for the same time with no lights and plug them back in to power, no button pressing is needed. While Sonos products are powering on then re-boot the device(s) running the Sonos app. When you are re-connected then test your Spotify playback for 30+ minutes. You can follow up here with the testing results and a new diagnostic report number for us to compare.

Lastly, if after you have gathered your network topology, adjusted any network settings, completed a full wifi network and Sonos product(s) re-boot and are still having the audio issues then I would recommend you call in to our agents for further troubleshooting as they will have more tools available to them.

Hi John G,

I will do these steps, however I can tell you, that if I start playback from the Spotify app and set to play through my Sonos devices, everything works perfectly. If I start the exact same playlist through the Sonos app, the skipping issue starts.

 

Something must be wrong in the Sonos app, when playing Spotify. 

 

Reply