Sonos will no longer play music from Google Play app.


Badge
Phone finds Sonos and connects but when trying to play from Google Play the app glitches between play and pause with no sound then advances to the next song. This is a new issue and I have changed nothing about the system other than software updates as suggested. Please help.

38 replies

Userlevel 1
Badge +1
Hi grey2175,

Thanks for reaching out. Please submit a diagnostic of your Sonos system and reply with the confirmation number.

Does this also occur with other music services like Radio by TuneIn?
Hi, I have the same problem, and submitted diagnostics: 7292923
From Sonos App, all works well, but from Google Play App same as described above
Userlevel 7
Badge +17
GPM casts to sonos ok for me using Samsung galaxy tab 10.1
Maybe it's something to do with using the phone to cast ?
What phone are you using?
I am using Samsung s7 edge, there was another thread a couple months with several devices which was solved by an update. It was working fine for me until a couple weeks ago or so.
Userlevel 7
Badge +17
Wonder if an android phone update has goosed it.
Possibly, it may have coincided with downloading nougat OS, but I am not sure
Has anyone had any feedback from Sonos on this yet? I've submitted a diagnostic report for the same fault and heard nothing from them yet. Similar to their product at the moment!
If you submit a diagnostic, it would behoove you to post the number here, so that they can pull it up and know what they're looking for here. I suspect they get thousands a day, and probably don't get much of a chance to look at them all unless someone calls in or posts the number here and tells them what the issue is.
Has anyone had any feedback from Sonos on this yet? I've submitted a diagnostic report for the same fault and heard nothing from them yet. Similar to their product at the moment!
Diagnostic number is 7292320
Userlevel 7
Badge +20
Hi folks,

We're looking into an issue causing some folks to be unable to cast from the Google Play app to Sonos if they're using free accounts. Is anyone having trouble casting from a premium account? If so, please submit a diagnostic report then reply with the confirmation number.

We'll update this thread when the issue is resolved.
Diagnostic report number 7302978.
Exactly the same problem as discribed: unable to cast from the google play app to the sonos Play 1. when you push play, it looks likes it wants to start, goes pauze en then jumps to the next number to do exactly the same again. No problem to cast from the sonos controller app and choose my google play library there.

Hopefully a quick solution. I will also submit a ticket with goolge play itself.

Many thanks
Diagnostic report number 7305669.
I am unable to cast Google Play Music from my phone (Google Pixel) or my tablet (Google Pixel C). Both were recently updated to Android 7.1.2 and I only recently noticed this problem.
As described by other users, I try to play a playlist and it just keeps skipping to the next song. Occasionally it will stop and actually play a song but I'm certain what differentiates those that are not played versus those that are. My Google Play Music library comprises mostly MP3s that I uploaded but there are some songs that I have added from Google Play's library as well - possibly the app is casting the songs from Google Play but not the ones that I added as MP3s? That's just speculation and I have no indication that it is true.
I am a Google Play Music premium subscriber (YouTube Red family plan).
When I play the same playlist WITHOUT casting, all songs play fine in the Google Play Music app so something seems to be broken specifically with GPM casting to Sonos.
Badge
Update...My issue was fixed by subscribing to Google Play Premium. I thought I had premium already but apparently not. After upgrading it now works fine.
Unfortunately that doesn't fix my issue as I am already premium. Are you premium individual or premium family plan? Are you premium just for GPM or through YouTube Red? I wonder if the type of premium subscription matters. Again, though, my suspicion is that it has something to do with the type of content being played given my above experience.
Badge
Individual. Subscribed from a PC. Thought I was already subscribed but apparently not. Make sure your credit card info is up to date.
Yes, card and account are both current. Given that it plays some songs for me and skips over others, I think there's something funkier at play (No pun intended.) here. It works fine when I'm not casting to Sonos too. Very strange.
Hi Guido23

Could you post a Diagnostic shortly after the issue occurs.

Many thanks
Hi, Matt R, I did so previously:

"Diagnostic report number 7305669.
I am unable to cast Google Play Music from my phone (Google Pixel) or my tablet (Google Pixel C). Both were recently updated to Android 7.1.2 and I only recently noticed this problem.
As described by other users, I try to play a playlist and it just keeps skipping to the next song. Occasionally it will stop and actually play a song but I'm certain what differentiates those that are not played versus those that are. My Google Play Music library comprises mostly MP3s that I uploaded but there are some songs that I have added from Google Play's library as well - possibly the app is casting the songs from Google Play but not the ones that I added as MP3s? That's just speculation and I have no indication that it is true.
I am a Google Play Music premium subscriber (YouTube Red family plan).
When I play the same playlist WITHOUT casting, all songs play fine in the Google Play Music app so something seems to be broken specifically with GPM casting to Sonos."

Is that helpful or do you need another one?
Im having the same issue, don't want to upgrade to Premium account though, any fix yet Sonos??
me too, it's so bad
Please note Ryan S' response on page 3 of this thread:

https://en.community.sonos.com/music-services-and-sources-228994/google-play-wont-cast-6765001/index3.html
Phone finds Sonos and connects but when trying to play from Google Play the app glitches between play and pause with no sound then advances to the next song. This is a new issue and I have changed nothing about the system other than software updates as suggested. Please help.

I am facing same exact issue.
I have latest version of Google play music (with Play subscription) and Sonos app on my android phone. I am unable to cast the music to sonos from the play music app, previously I was able to do it without any issues. I am able to play fine from within the sonos apps.

Diagnostics #: 7655122
Userlevel 4
Badge +3
Phone finds Sonos and connects but when trying to play from Google Play the app glitches between play and pause with no sound then advances to the next song. This is a new issue and I have changed nothing about the system other than software updates as suggested. Please help.

I am facing same exact issue.
I have latest version of Google play music (with Play subscription) and Sonos app on my android phone. I am unable to cast the music to sonos from the play music app, previously I was able to do it without any issues. I am able to play fine from within the sonos apps.

Diagnostics #: 7655122


Hi Anvesh03, thanks for posting your diagnostic. We are currently investigating an issue with the same symptoms as you report. I've sent you an email to the same address you registered your community account at, to request some more information we need to gather from you.
Phone finds Sonos and connects but when trying to play from Google Play the app glitches between play and pause with no sound then advances to the next song. This is a new issue and I have changed nothing about the system other than software updates as suggested. Please help.

I am facing same exact issue.
I have latest version of Google play music (with Play subscription) and Sonos app on my android phone. I am unable to cast the music to sonos from the play music app, previously I was able to do it without any issues. I am able to play fine from within the sonos apps.

Diagnostics #: 7655122


Hi Anvesh03, thanks for posting your diagnostic. We are currently investigating an issue with the same symptoms as you report. I've sent you an email to the same address you registered your community account at, to request some more information we need to gather from you.


Hi Tom,

I have responded to your email with the requested details. Please let me know if you need any more information on this issue.
I have the same problem. Plays fine from the sonos app but not from the google music app. I even factory reset my speakers and reinstalled the sonos and Google music app and it didn't help.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings