Sonos stops playing randomly

  • 9 October 2018
  • 9 replies
  • 1928 views

My Sonos randomly stops playing podcasts after a few minutes. It will then skip to the next podcast in the playlist or stop playing altogether

I'm playing on an iPhone X with a strong connection to my router. There is also an Apple TV connected wirelessly to the network.

My confirmation number is 566134823.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7
Badge +19
Hi there, alexjp3. Thanks for posting and welcome to the Community. Does this seem to happen when the screen goes dark? Are there any other apps, even in the background, open that also use audio (Spotify, Apple Music, etc.)? Currently, the team is looking at an issue of audio cutouts when content from "On this iPhone" is streamed to Sonos.

Thanks!
I’ve tried closing all my apps and this did not resolve the issue. It’s also not caused by when the screen goes dark as I’ve tried to reproduce watching my iPhone screen.

This is incredibly frustrating. I would not have purchased this device if I knew this was an issue. It basically makes listening to anything on your phone unlistenable. At this point, I’d like to just return it.
Can you please look into the confirmation number I provided you?
Note that the folks who work the forum are M-F folks, and aren't here 24/7. For 24/7 support, you'd need to reach out on either Twitter or Facebook. Click on the "Contact Us" link at the bottom of this page.
This has to stop. I purchased these speakers to listen to podcasts, and it's completely unacceptable that you don't have an option to keep them streaming for an hour. You either need to have an app for apple podcasts or fix the problem with the wifi cutting out on the phone. It would also be great to have a 15 seconds forward and back option for podcasts. Podcasts have exploded in popularity over the past several years, and you all need to catch up.
Badge
I too have this issue and it is very frustrating. What happens also is that just before it stops a message flashes that says “Unable to play ... WHATEVER PODCAST... because the connection to Tunein was lost.” The podcast will stop playing shortly thereafter and reset to the beginn8ng of the podcast. If I pause the podcast at the moment of seeing the error message and wait for a few seconds I can then hit play again and the podcast resumes playing for a few more minutes. The cycle repeats. Obviously very frustrating to the point of not even being useful. I did notice that this doesn’t happen with NPR podcast but does happen with CBC Radio podcasts. A fix is definitely needed.
Badge
One other point... this is an issue with streaming only. When I download the podcast and play it from “On this iPad” there is no issue.
If if it's happening while you're streaming, it's a pretty good indication that your speaker is losing connection to the stream. You may want to review the data here: wifi interference

Or, it's also possible that your speakers might be hitting a duplicate IP address, even if they're wired. Easily checked/rectifiied by unplugging your Sonos devices, then rebooting your router. Once the router comes back up, plug in one Sonos device at a time, giving a couple of minutes between each one. Then try the test. If it fixes the problem, it's still a temporary fix, but is a good indicator that you need to look in to how to reserve IP addresses in your router's DHCP table. My experience was if it happened once on my router, it would happen again. Maybe not soon, but eventually.
Oh, one more note. Each company that maintains a stream has differing tolerances for how much interruption they can handle, which is why stream X might be fine, but stream Y might not.