Sonos Setup in the Office - Shuffle Songs


Hi All,

I love the SONOS setup I have setup in my workplace. I have 4 placed around a medium sized office, and it provides great music at low volumes around the office. I have curated some Spotify playlists to play throughout the day too, which added to the experience. I attached my Spotify account to my SONOS account and it’s seamless.

 

Here’s my question. I have each playlist set as an alarm on the SONOS system to change throughout the day and stop at closing. There are plenty of songs on each playlist to take up the amount of time each playlist runs + more to give some variety each day. But, the same songs end up playing at the same time each day. I have the Shuffle Music setting ON for each of the alarms and it still does it. 

 

Is there a better way to set this up than using alarms or am I missing a step in getting it to actually shuffle the music?


2 replies

If you use an Apple iOS controller device, there is an App that can sort all these things, but it needs a little understanding of how iOS Shortcuts work. I’m not affiliated to the App, other than I do use it myself and it’s called Soro, if you perhaps want to explore that 3rd-party software option?

Please note this is only a suggestion and not an endorsement of the App.

Note that the “shuffle” order should change each time you click on/off/on  “shuffle”.

I’ve noticed that when I, or more specifically, when the power reboots the speaker, or a software update does, rather than “pausing” a playlist, it restarts playing the playlist with the same song. But if I pause the playlist, rather then stopping it, it just picks up from where it was paused. 

However, I’m not sure either of those particularly help you when using an alarm to start/stop playback. I suppose if you were to go in daily and re-randomize the playlist? 

I’d actually be tempted to infinitely repeat the playlist, rather than starting/stopping it with the alarms, and just use the alarm function to set the volume to zero for the time period it should be “off”, and then set it to X>0 when you want to hear it. But that’s kludgy….but should work. 

Reply