Answered

Sonos not updating Mac Music library hosted on WD MyCloud

  • 5 September 2021
  • 6 replies
  • 43 views

I have my Music Library saved on my MacBook Pro and recently when I’ve updated my playlists and exported my library to sync to my WD MyCloud Home, it’s still showing playlists I have deleted and is missing new ones I have added. I’ve even tried deleting the original .xml file and exporting a brand new library but no luck.
Any help would be greatly appreciated.

icon

Best answer by Airgetlam 5 September 2021, 17:02

If I recall correctly, deleting a role on a WD NAS is actually a two step process. First, you have to ‘delete’ the file, then you have to remove it from the ‘trash’ folder that WD maintains. My guess is that Sonos is still picking up the data in the ‘trash’ folder, that you think of as ‘deleted’. 

View original

6 replies

After updating your library, did you manually run the ‘Music Library Index’ feature in "Settings/System/Music Library” in the App?

You could also perhaps try deleting the library connection in the App and re-linking it again, but I would opt to power-cycle all the speakers too, in-between removing and reconnecting the library back again.

Thanks. I’ve tried deleting the library link and reading. Also removed speakers, powered them down and rebuilt my whole system from scratch but it’s still dragging in my old list of library playlists from somewhere. 

If I recall correctly, deleting a role on a WD NAS is actually a two step process. First, you have to ‘delete’ the file, then you have to remove it from the ‘trash’ folder that WD maintains. My guess is that Sonos is still picking up the data in the ‘trash’ folder, that you think of as ‘deleted’. 

Best practice is to disable the NAS trash folder.

Certainly agree. When I had initially set up the ‘pointer’ in Sons, I wasn’t as specific as I could have been. And there’s no guaranty that this is the specific issue, either, as I wasn’t using the ‘MyCloud’ service, either, just offering something up as worth looking at. 

Reply