Answered

Sonos has only 9, 692 songs but my Itunes Library has 12, 472?

  • 24 September 2021
  • 10 replies
  • 141 views

Hi

I’m just baffled - I update my Sonos regularly but there are over 2500 songs missing from it.

My Itunes library is on the C Drive on my laptop, I’ve checked the tags on my compilations and none show ‘Various Artists’ so it’s not that, I have absolutely no idea what the issue is, does anyone have any ideas where I might start?  Any help will be very gratefully received.

icon

Best answer by Airgetlam 24 September 2021, 20:54

View original

10 replies

It’s possible that you have DRM on some songs, and the Sonos system can’t read them. If you purchased them from Apple, you can delete the local copy, and download a “new” copy, which shouldn’t have DRM on it. That changed quite a few years ago, but since iTunes didn’t care one way or the other, most people weren’t aware. Sonos, not having access to the Apple server for authorization of that particular flag, does care. 

Is it possible that some of these “files” are in places that Apple knows about, but not Sonos? You may want to confirm the “library” settings in your Sonos controller, to ensure it’s being pointed at the correct folder(s). 

There was a similar post this morning in which someone (John B, maybe?) also suggested something I hadn’t thought of, but is completely valid, in the fact that you may want to check that those individual files actually have metadata. If they don’t, they won’t show up in Sonos, since Sonos reads metadata, and not anything inside the file (except playing the music). 

Hi

Thanks for your replies.  I’m pretty much at the end of my tether now, I’m still not getting anywhere even after spending nearly 3 hours on the phone to Sonos today.  I have 12716 songs in my Itunes library - according to the Sonos people I spoke to today it shows that I only have 11183, however only 9893 will show or play through Sonos. 

Up until last week everythiing played fine, yet no changes have been made, no settings have been touched.  The missing music is a mix of downloaded music from Itunes, which until last week played fine through Sonos so I don’t see who it can be anything to to with protection, and music imported from CD’s, which also until last week played fine.

Everything shows and plays fine on Itunes, but on Sonos Artists are missing completely (eg I have all 3 Wolf Alice albums, and 4 Undertones albums all of which are now missing).  The other weird thing is that under Artists on Sonos it covers A-Z, albeit with some Artists missing, yet when I go to the actual music folder on Sonos even more stuff is missing - it only goes from A-T! 

Apparently Sonos will contact me again as they reached a ‘technical impasse’ today.  Music library was uninstalled and reinstalled, as was Sonos app.  Library was updated twice today and I’ve done it 5 or 6 times already this week. 

If anyone has any ideas I would really really appreciate it as I’m beginning to feel like Sonos is more trouble than it’s worth...

Maybe corrupt data on a single track is causing the process to crash. You  could try removing tracks by Artists beginning with "T and see if the process then gets as far as Wolf Alice.

I wouldn't say I was confident about this working!

Have you looked at one of the Wolf Alice tracks to make sure the Artist and AlbumArtist tags are present and correct?

Had you added any new music just before the problems started?

You also may learn something if you put the Wolf Alice and Undertones folders in another folder and made that folder your music folder. As ane

Are they indexed in Artists view? What about in Folders view?

Update! I just imported a new cd, updated the music index for the 4th time today and am somehow miraculously up to 12705 tracks which is not far off my iTunes library???  How can stuff disappear for 3 days then somehow turn up again - clearly nothing to do with protection or metadata - utterly bizarre. Just hope they stay where they should from now on! Thanks again for suggestions,  really appreciate it.

Could be a time out in the process that was running, perhaps due to some sort of wifi interference while the speaker is accessing the data in order to process it? 

This is a bit messy, but you’ll be able to determine where the indexer stopped -- if it stopped before finishing.

Go to About My System, get the IP address of a player, then open a browser and go to http://[IP address]:1400/support/review. This will display a list of rooms. Click on a room, then click on Zone Player Info and look for IdxTrk. Normally this field is blank. If there is an entry, this is where the indexer stalled. Unfortunately, one player takes charge of running the indexer and you will not know which player ran the index. You’ll need to pick through all of the players, looking for a non blank entry. Of course, all entries might be blank -- indicating that the indexer did not terminate early.

If you have a Windows desktop SONOS controller, go to Manage → Update Music Index Now, then go to Help → Error Log…. Something may show here. I don’t have a Mac computer and don’t know if this log is available on a Mac.

As I said, this is messy and it may not provide any insight.

Looking at my Mac client now, that error log isn’t in that location. However, there is an “error log” available under “help” which may have that information in it. Never looked at it before today, that I can recall…..lots of errors finding KNBR (which I listen to the SF Giants baseball on, using iHeart Radio plugin)

A bunch of “unable to connect to the NAS” style errors, when I’ve been playing music and rebooted my router, too. 

Hi

So another update - all was well, then I added a new CD on Wednesday, updated the library and hey presto, nearly 3000 songs disappeared again.  I’ve uninstalled the controller numerous times, removed and readded my library, and updated my library what feels like hundreds of times and nothing.  Suffice to say I’ve not heard back from Sonos despite my 3 hours on the phone to them last Friday and their assurances that they’d contact me back.

So, and I apologise as I don’t know if I can link to Buzz’s advice above somehow, I tried what Buzz suggested - as he advised under IdxTrk my 3 Play 1’s are fine and show nothing but on my Connect Amp there was an entry when it should be blank - so I turned off my Amp, updated my library and it worked, so it seems to be the amp that’s the issue.  I guess form now on don’t update the library when the Amp is on - bit annoying but if it works it works.  All I can say is thank you Buzz, I really appreciate you taking the time to answer my distress call, you’re a gent.

Reply