Sonos & Apple Music challenges

  • 13 January 2017
  • 3 replies

So I have a Sonos system (2 x play 1 & 1 x play 3 + bridge) which I use with my own library and Apple music.
Since going with Apple Music I am experiencing some odd problems and am yet to resolve them so any advice / guidance would be appreciated. I am not certain all the issues are Apple Music related but it behaves differently to my own library.

Issue 1 - My bridge crashes my network on my new Asus router. I've seen this is a known issue and the advice is a firmware upgrade however my firmware on the router is up to date. So I am currently unable to use the bridge and am running using the sonos-net

Issue 2 - Apple music will only play to one play 1 in one room. If I try to play to the other two devices i get "unable to add to queue". However (it get's weird) if I then group the other rooms i get apple music in all rooms. If I ungroup the original room everything stops. I can however play my library (from an iphone or ipad) in all rooms as I choose.

Issue 3 - Apple music will play around 90 seconds to 2 minutes of a track before skipping to the next track and it does this for the whole album / playlist.

I've tried resets, shutting everything down and rebooting the network from the router up 1 device at a time and I can not solve this.

Any thoughts from anyone?

Thank you!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 4
Badge +3
Hi Shanghai-Nicki, welcome to the community! I'll try to help out as best I can with these problems.

For Issue 1: Your Asus router issues will depend on the exact model of the router, but I do know for the Asus RT-AC87R you also need to set the 'NAT Acceleration' function to be disabled, as well as being on the latest firmware. This is found under LAN → Switch Control on the router's interface page.

Issue 2: This sounds like a device certification issue. Apple requires us to store a security certificate on each of the players licensed to play Apple Music, and occasionally this does not come down properly. I would start by removing the Apple Music service and adding it back in again. If this doesn't help, then please try the secure registration procedure for your players, which we actually use at the moment for Spotify Connect - but it has the same effect of placing a secure certificate on the player.

Issue 3: This sounds like some kind of network or wireless problem. Please send us a diagnostic and reply with the number you get. Can you also describe your network? What kind of router do you have, are there any extenders/boosters/powerline adapters or secondary routers in use?
Many thanks Tom,

Since writing i have switched to Spotify which is working like a dream but if you can see what the issue is with Apple Music i would like to get that working too. The diagnostics number is 7071782.

I have also tried again to set up a Sonos mesh network by connecting my play 3 directly to the router but just like the bridge this also crashed the network with the router log file showing net_ratelimit: xx callbacks suppressed every 5 seconds. So it's back to wi-fi until I can get this solved.

The router I have is an Asia RT-AC87U with Asuswrt-Merlin firmware 380.62_1.

i have a China Telecom modem which my Asus router connects to.

Thanks again!
Userlevel 4
Badge +3
Hey Shanghai-Nicki, if you're on the Merlin firmware, I think this is part of the problem regarding the mesh network. Try getting the router on to the latest firmware from Asus.

Regarding your Apple Music, I can't see anything obvious on the local network which could cause a problem - but it also looks like it's mostly been Spotify playback recently so I can't see any Apple Music errors. Can you try Apple Music some more and send another diagnostic? Do you know if your account is a member account for a family plan?