SiriusXM Encoding Error

I added SiriusXM to Sonus I can see the stations but whenever i try to play a station I get the message "unable to play '(station number station name) -the song is not encoded correctly" I deleted and again added the account same results.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

63 replies

Having the same issue this morning, have never had an issue with my system up until this point. Same with Apple Music, gives me a slightly different error message but nonetheless, the service doesn't stream.
I also have this problem, just started today. Has anyone tried contacting Sirius about this?
I am also having the same issue this morning. Waiting for Sonos to open to talk wth someone.
I am having the exact same issue this morning. Never had it before today.
Badge +1
Same problem here too. Never had this problem before. Deleted add on then re-established. same problem
Same here too ... reset EVERYTHING but still no joy.
Badge +1
Just chatted with Sirius support. Their tech people are aware of the problem. They are not sure it's on their end but they are aware of the problem and researching the issue.
I have the same thing happening to me. I try to play a Sirius channel, and Sonos tells me the "song is not encoded correctly". I'm not trying to play a song, I am trying to play a Sirius channel Kind of frustrating. That's why I bought super-expensive Sonos Gear: to listed to Sirius music!
Same here. Removed Sirius and then added it back. Rebooted iPad. Nothing is working.
Same issue. Started this morning.
+1 started this morning
Same issue. No issue playing SiriusXM directly from their webpage, so the issue is between Sonos and Sirius.
Looks like it's working again.

Never mind. Stopped working again.
Userlevel 5
Badge +3
Hello Everyone,

We definitely want to look into this further since there seems to be a few of you who are experiencing the same issue. We see that some of you have also reached out to SiriusXM too and they are exploring this as well.

Steps to try in the meantime if you haven't:

Try removing/re-adding the music service
Rebooting the router- unplug the router for about 30 seconds, plug it back in and allow it to boot. Then test SiriusXM again and see if you experience the same issues.
Test other services such as Radio- to make sure you're able to play music on Sonos

If issues persist, please submit a diagnostic and we'll be able to take a closer look at your systems. Let us also know the steps you've tried and include the diagnostic number as well.

If possible, please include your location and ISP providers as well.

getting the message 'the song is not encoded correctly' when trying to play from the Sirius/xm playlist. This has worked without problem for over a year/. Just started acting up today. Deleted S/XM and reinstalled.. to no avail... anyone?
Thank you Dominique. I have tried all of the steps you recommend and still have the issue only on XM. Everything else works well... Pandora, internet radio etc... . I have submitted a diagnostic. Number is 7369829
Ditto here. All other services work, and sirius xm on the internet via pc works as well.
Dominique, I have tried every step you listed. Nothing works, tv will do direct feed, but no music will play through Sonos app. The bar usually has a green light on top, but it is no longer lit. It seems siriusxm, stored music on both my iPad and iPhone can't be sent to bar at all. But the tv through optical will play on all my speakers, and the true sound check will play. The sound bar isn't accepting any signal from the source except tv. I will send my diagnosis now 7371080.
Userlevel 2
Ditto here, will not try deleting service and reinstalling it as suggested above because others have tried that to no avail and looks like I would just be wasting my time. All music services work but Sirius XM.
I am having the same issue. All other streaming sources work but Sirius XM
The issue may be on the Sirius XM side. Their proprietary online player has also been behaving oddly today--mainly not playing some on-demand content and channel icons not loading.
Same problem also!
Userlevel 5
Badge +3
We're getting reports that playback has returned to normal.

Please test the system again and let us know if issues persist. We'll be happy to take another look.
No. Still the same.
Nope same error message.