Rhapsody UPnP Problems with Sonos (again)


Userlevel 2
After I installed the most recent Sonos update I have not been able to "see" my PC Rhapsody libraries on the Sonos system via UPnP. The very odd problem I seem to be having - the UPnP server status within Rhapsody switches to "stopped" as soon as I connect a Sonos ZP to the local network. When I disconnect the ethernet cable or power down the tethered Sonos ZP, the Rhaspody server status switches back to "started". In no case can I see the Sonos ZP's as compatible devices within Rhapsody. Prior to the upgrade, all was working fine. Note that Sonos can access my library from my NAS with no problems and it can stream Rhapsody music. But I miss having my complete combined library show up as Rhapsody (PC NAME) under music services.

I have a D-Link DIR-655 Router with UPnP turned OFF. UPnP has alwasy worked fine with this setup and I have not made any changes. I have a Vista desktop and XP laptop and previously both computers would show a Rhapsody library on Sonos via UPnP, now both do not work. I run Microsoft Live OneCare and I have disabled the firewall - still have the problem. Have attempted full reinstall of Sonos controller and Rhapsody on the desktop and laptop.

I'm caught in the void of Rhapsody and Sonos pointing fingers at each other... though Sonos support has been much more supportive they have not found a solution. Rhapsody support has been entirely useless.

Any suggestions / tests appreciated. I am at my wits end here.

10 replies

Userlevel 2
I noticed no one has responded to this and I am having the same frustrating issue. Has any resolution been found?????

THANKS!
Userlevel 2
Hello McFly? Can some at least acknowlege that you know it exists? I am having a similar problem with sirius since the upgrade, intermitant disconnects
bwaters,

This is a users forum, not a Sonos Support forum. Although Sonos employees do read the forum, they rarely dignose or treat an individual's particular problem here. You would do best to contact Sonos Support directly via e-mail, phone or chat.
Rhapsody released a fix for this on Friday 9/25. Update your Rhapsody Client / UPNP server and you should be all set (I believe there is a check for updates under the Help Menu) .

Regards, Todd
Userlevel 2
Rhapsody does not have an update. Their latest was over a month ago.
After discussing this issue with Real Networks / Rhapsody, I was told that they were releasing a fix for this on Thursday 9/24. Friday morning I did a check for updates and download their client version v4.0 build 5.189. With this new version, the Rhapsody UPnP server ran and I was able to playback from the Rhapsody UPnP server through Sonos.

What version of the Rhapsody client are your running?
Userlevel 2
v4.0 build 4.723..... When I go to check updates it tells me I am running the most recent version.
I spoke with Rhapsody. They pulled their client update that fixed the UPnP server problem on Friday afternoon, 9/25 due to a non UPnP related technical issue. They plan on releasing a new update that will contain the UPnP fix in about two weeks, but I do not have a confirmed date.

Apologies for any confusion or inconvience.

Regards, Todd
Userlevel 2
I will wait 2 weeks and check for updates. I will check back if nothing changes.
Userlevel 2
It worked. Update Rhapsody and you are back in biz. Thanks for your help!!! You guys are good.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings