Answered

Problem Youtube on i-pad over Airplay to Sonos


Hello,

I recently bought an i-pad. Eagerly I installed sonos, youtube, spotify and netflix. Sending the sound from netflix and spotify to my sonos runs smoothly. However, with youtube it doesn't... The sound is transmitted through the sonos. But the image on the i-pad freezes in a way. The text 'connected to airplay' remains visible. The video appears, but the 'openingsscreen' remains visible throught the video (see picture attached).

Anyone any idea on how to solve this? Anyone ele having this issue?

Many thanks!
icon

Best answer by Keith N 23 October 2018, 19:48

Hey, noki. Thanks for the post and welcome to the Community. This seems to be part of an update to the YouTube app, as I tested this using AirPlay to an Apple Homepod we have set up and got the same result. It might be best to reach out to YouTube for further insight.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7
Badge +19
Hey, noki. Thanks for the post and welcome to the Community. This seems to be part of an update to the YouTube app, as I tested this using AirPlay to an Apple Homepod we have set up and got the same result. It might be best to reach out to YouTube for further insight.
Wish me good luck 😉
Just to say I have already reported this matter to the YouTube developers too, via their App feedback link in iOS. The problem has been in the last two updates. I’m wondering if they are moving this feature over to their paid-for services? We may have to wait and see.
Just to say I have already reported this matter to the YouTube developers too, via their App feedback link in iOS. The problem has been in the last two updates. I’m wondering if they are moving this feature over to their paid-for services? We may have to wait and see.
They already did, I have a YT premium subscription. That's deliberate action on Google's part in order to protect their assets. Their TOS says that it is not allowed to separate the soundtrack from the video source, and that is exactly what Airplay does.
Badge
Hi everyone!
The free version of YouTube 13.45.7 released today SOLVED the problem!
Cheers! ?
Yes, does seem so for the moment. But Google is updating the YT app on iOS once a week now; so wait and see how they'll proceed further.
The free version of YouTube 13.45.7 has not solved the problem for me, and using AirPlay audio to any device including Sonos continues to display the same problem. Google claim that the problem is with IOS 12, but like others, the problem for me stemmed from a YouTube update. It’s the YouTube app as using YouTube via the internet does not give the same problem.
I have a YT premium subscription, may be that Google enabled streaming via Airplay to premium users only.
Badge
The free version of YouTube 13.45.7 has not solved the problem for me, and using AirPlay audio to any device including Sonos continues to display the same problem. Google claim that the problem is with IOS 12, but like others, the problem for me stemmed from a YouTube update. It’s the YouTube app as using YouTube via the internet does not give the same problem.
Please, try the following: ensure AirPlay is disabled on your device, close the YouTube app (double click on home button and swipe YouTube away), restart your device and try YouTube with AirPlay again. I use the free version of YouTube and AirPlay works OK with all devices. And also works OK if I start AirPlay before opening YouTube or activating AirPlay from within YouTube with YouTube’s own icon (screen with WiFi symbol). Free YouTube 13.45.7
The YT app is free, the premium subscription is an in-app purchase.
Not quite sure how to disable airplay on Sonos Play5 or other devices. I did it by disconnecting from the network then following yayarod’s procedure. This did not work and the problem persists. YouTube are blaming IOS12.