Problem with ID3 tags


Badge
I have just got a new album, put it into itunes as normal, reindexed in Sonos. However, it does not pick up the artist or album tags and so does not appear correctly. I can search for the individual songs. They appear, albeit as '01 Minotaur Forgiving Pasiphae.mp3' rather than the actual song name alone. I have tried editing the tags in itunes and in a dedicated tag editor, and then reindexing, but cannot effect any change!! Any clues?

16 replies

Open the track in a tag editor and provide a screenshot please.
Badge
Here you go! Thanks for taking a look:
When I have this problem I clear the tags using MP3Tag and then add them back in through Discogs and that fixes it. File/Delete tag in MP3Tag clears the entire table for the album.
You need to fill in the Genre and Album Artist tags.
Userlevel 4
Badge +18
I use a program called MP3tag to tidy all my tags and correct artwork issues. Well worth getting.
Badge
Well, plenty of my albums do not have album artist field completed - I find it causes problems. I added a genre, but no joy.
Album artist is more important than the genre tag.
Badge
Unfortunately it has not made a difference.
Under "Manage Music Library", is "Compilation Albums" set to 'Use Album Artists'? Also, what are the folders sorted by: song number, song name or file name?
Badge
Cant see anything about compilation albums.

Under Manage / Music Library Settings / Advance I have Group Albums Using - it is set to Album Artists. Folders are sorted by Song Number. Both check boxes are unchecked (Update content, and show contributing artists).
NathanEmmerich wrote:

Cant see anything about compilation albums.


The desktop controller differs from the Android/iOS app.


NathanEmmerich wrote:

Under Manage / Music Library Settings / Advance I have Group Albums Using - it is set to Album Artists. Folders are sorted by Song Number. Both check boxes are unchecked (Update content, and show contributing artists).


Try 'song name' or/and 'file name' instead.
NathanEmmerich wrote:

Cant see anything about compilation albums.

Under Manage / Music Library Settings / Advance I have Group Albums Using - it is set to Album Artists. Folders are sorted by Song Number. Both check boxes are unchecked (Update content, and show contributing artists).


These are my chosen Music Library Settings, if that helps you. Don't forget to re-index if you change any settings.
Badge
If I use song names will it play albums in alphabetical order?

Reindexing now.
Badge
Well, nothing has changed...
I would perhaps toggle the 'Group Albums Using...' option to something else, re-index and then toggle it back to 'Album Artists' and re-index again to see if that gets it working correctly.
In fact looking back at your earlier screenshot, you have nothing showing in your Album Artist tag so perhaps try one of the other options, like 'iTunes compilations' instead.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings