Podcasts have quit playing

  • 6 January 2022
  • 2 replies
  • 26 views

I have used Sonos with Spotify to play podcasts for the last few months.  After the first of the year, I have not been able to do so.

At first, I thought it was another Sonos glitch (I do not use the alarm function because it regularly forgets certain rooms or speakers and has to be manually reset…which is not feasible when I am asleep).  But nothing seems to be working.  I see on the forum that this was a problem a year or so ago, but I have been able to play podcasts just last month. 

Can anyone provide any guidance?  This is extremely annoying as I purchased a pair of Roams specifically to be able to play podcasts in the morning.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

Try removing Spotify from the Sonos app and re-adding it. Also reboot the Roams by following the steps below and reboot your router.

  1. Disconnect Roam from charging cables and remove it from wireless chargers.
  2. Hold the button on the back of Roam for at least five seconds until you hear the power-off tone and the light above the Sonos logo turns off.
  3. Wait 10 seconds.
  4. Press the button on the back of Roam to turn it back on.

Thanks for the suggestions.  I tried the removing and re-adding this morning...no dice.  I will try working with the speakers this evening, but since the app won’t connect to any of the speakers, I am not particularly hopeful.