Podcast won't play on Sonos - connection was lost

  • 27 August 2018
  • 8 replies
  • 659 views

Hello,

I have a Podcast called the Home Assistant Podcast. We've been contacted by a couple of our listeners informing us that they can't play our Podcast through their Sonos systems. I also now am unable to play my Podcast through my Sonos speakers.

Our Podcast is listed via all the main Podcast services, including TuneIn, Plex and Pocketcasts.

This seems to have stopped working since a couple of months ago, as I have always been able to play the Podcast through my Sonos speakers.

Now, when I attempt to play an episode through a Sonos controller, I get the following error

"Unable to play {{episode title}} the connection to Plex was lost"
"Unable to play {{episode title}} the connection to TuneIn was lost"

What's weird is that I can play these episodes on my Amazon Echo, or via the TuneIn/Plex web interface without trouble. I can also download the MP3, and play it from my local network fine, so there are no file encoding issues that I can see.

There seems to be a network error somewhere. Probably a misconfiguration on the podcast server side. However as the Podcast works everywhere else, there is something Sonos isn't liking. I have tried to take a look the error logs from Sonos, but there's no information I can see from this end to help me. I'm guessing there's a HTTP header or something that needs to be fixed on the Podcast server, but can't see what it needs to be.

If it helps, here's a diagnostic number: 1465556397

8 replies

Userlevel 7
Badge +19
Hello there, philhawthorne. Thanks for posting and welcome to the Community. After taking a quick look at the diagnostic report, it seems that every time your podcast is called (via hasspod.io) to Sonos, we run into an SSL connection error. It seems that an error is returned when asking for the podcast from the server.

While I'm not sure what this means for your podcast, but I do hope you find this to be helpful.
Thanks Keith,

Sonos support have escalated this to the higher ups for a bug fix. Our podcast is hosted on a subdomain (which has its own SSL cert), but Sonos is using the root domains SSL certificate, which is failing.
Just to answer this, incase anyone else comes along.

Our Podcast is hosted on a server, which uses SSL certificates generated from Cloudflare. The free tier (universal SSL) at Cloudflare only generate SSL certificates using the newer ECDSA ciphers. These aren't supported by Sonos players (see here: https://musicpartners.sonos.com/node/339 )

Hopefully Sonos can implement the new Ciphers in a future update. For the time being, the only options for Podcasts that want to be played on Sonos is to use a paid/pro SSL certificate, or business plan from Cloudflare. Or remove Cloudflare from your domain (which is what I may be forced to do).
Will this get fixed? My favorite podcast also isn't working, because of this.
Badge
My podcasts will also not play on sonos 1 with current software it says "the connection to tunein was lost
I'd recommend that you submit a system diagnostic within 10 minutes of replicating this issue, and either post the number here, or contact Sonos to discuss it. There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
Same problem with "The Professional Left with driftglass and Blue Gal." Streaming worked fine up until four weeks ago. Now "the connection to TuneIn was lost" message appears instantly. There are a few related threads on this site, but no fix. I'm using a Connect with an iPad. App version 10.1.2 build 49264120.
Interesting. I'm getting a similar issue when I try to play ESPN radio on TuneIn. I've submitted a diagnostic, so that they can see more information, that might be something worth doing on your side, within 10 minutes of getting that error coming up, so they can see what's going on.

Reply