Play 5 gen2 stereo pair + Airplay 2 + Mac sound output device

  • 28 August 2018
  • 2 replies
  • 364 views

Hello. I made a quick search for a place to file a bug issue, couldn't find any link, so I'm posting this here.

I have a Play 5 gen2 stereo pair setup. Nosing around the Mac sound settings, I noticed it is possible to select the speaker pair (the name appears nicely on the menu) as the audio output. As I understand, this is a nice feature recently added through the Airplay 2 update to the speakers.



So I tried out this feature and found the following issues:
1) The sound was only reproduced on one speaker
2) After deselecting the stereo pair as the computer's audio output, I had to disconnect the speakers and restart the controller to get the stereo sound back.

Steps to reproduce the issue:
1) select your stereo pair as your computer's audio output from a Mac.
2) Wait for the computer to connect to the speakers (the sound icon will animate and stop when finished)
3) Open Spotify, play something.
You'll get the _mono_ playback (only one speaker)
4) Select your internal speakers as the computer's audio output
5) Use the Sonos controller to play something, one speaker won't reproduce sound

Solution: close the Sonos controller (you might need to force quit), unplug your speakers. Then plug again, open Sonos controller, stereo sound is back.

OS: macOS High Sierra v10.13.6
Sonos controller for mac: v9.0 Build 44255050
Spotify: v1.0.88.353.g15c26ea1

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +19
Hi there, guapolo. Thanks for posting and welcome to the Community. Would you mind replicating the problem and shortly after, submit a diagnostic report. Be sure to reply here with the confirmation number it gives at the end.

Much appreciated.
Hello @Keith. Thanks for the reply.

I'm happy to say I can't reproduce it anymore. I just applied a recent update (~September 4th, 2018), probably that solved it (build number 45156150).

It's great to see the product improve and have better integrations through time. Keep up the good work!