Answered

Pandora not activating on Sonos


I recently updated my Pandora account. On Sonos when I try to activate it, it just keeps saying Safari cannot open the page because the address is not valid. Therefore I cannot activate my Pandora account. What is going on with it? It's not a Wi-Fi issue, and everything else is working fine. The Google Plus account works fine. But Pandora will not allow me to activate. Any advice? Thanks.
icon

Best answer by Keith N 20 April 2018, 21:36

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

43 replies

The Pandora activation works as of this AM. Didn’t do anything different compared to last night - but the activation code loop is no longer an issue (went directly to Step 2 in the process). Success!

Sonos doesn’t give activation codes, YouTube does. 

Your Sonos is a TV set, HBO went out. Is it the TV’s fault, or is it HBO’s fault? While it might be the TV breaking, it’s much more likely for it to be something upstream from the TV. The cable service to your home, or HBO. Neither your TV set, nor Sonos has any control over the data being sent to it. All they do is present it to you. 

Just sayin’

Glad to see that the problem is resolved; sort of.  Although, I do find it difficult to accept that this was a Pandora issue since my YouTube service was also asking for an activation code at precisely the same time as the Pandora service stopped working.  I called Pandora and they said they were aware of the issue, but the problem was not on their side.  Pandora worked on every other platform I have, so… that seems to confirm this confined to Sonos.  Perhaps Pandora has a Sonos-specific server, but how does that explain the unrelated YouTube outage at the exact same time?

Anyway, I also deleted Pandora and re-added, but when I did that, Sonos once again presented me with a BLANK authorization code window.  I closed that window and POOF, Sonos then gave me the prompts to install Pandora as a new service.  It’s working now.

Oh, and when YouTube went out at the same time, Sonos immediately gave me an activation code.  Just sayin’ 

Mine is not working also. I did not end up having to uninstall the app or delete the pandora account although I was just about to do that. Glad it was short-lived.

I can confirm too...my Pandora is working now. Regular login without reactivation code 

Ah, you’re referring to the name, not the poster’s handle. 

As far as I can tell, that just suggests when s/he originally tried, the Pandora server was down, after the procedure, it was back up. 

Has anyone confirmed Ant’s post?  

hi all, 

 

just had the exact same problem….and fixed it like this:

I went into my Sonos app (iOS) deleted all the pandora accounts off that.

Closed out the Sonos app as well as my pandora app. 

reopened the Sonos app and re-added my pandora info into the music and content in the services section of settings - the same place you would have removed them from. 

Hope this works for you guys, worked for me 5 mins ago. 

Thanks

Ant

Same issue here.

https://status.sonos.com/

Found this on service portion of Sonos site...at least it seams Sonos is aware of the Pandora issue and hopefully working on it.

https://status.sonos.com/

 

 

Thanks for this link.  At least I know I am not crazy!

Userlevel 2

Just did a full upgrade .. new sonos hardware and I had to add my services back. Including Pandora.

It goes to https://www.pandora.com/sonosactivation?activation_code=XXXXXXXX&need_account=false

But there is no activation in the window.  I see the activation in the code and I try that but it says invalid. 

I can login to Pandora direct and play bluetooth and through the pandora app. Just can't get it to register with Sonos. 

This is such BS.  Sonos needs to fix it ASAP!

https://status.sonos.com/?utm_source=ENsonoscommunity

I someone else in the community there is a major outage on Pandora for Sonos   I’ll put a link to website 

Yo, me too! For me it coincided with upgrading to 11.0 Sonos, but not sure of that was coincidence...

Seems like a recurrence of an issue from a year ago, based on on the threads on this website?

HELP!

 

Found this on service portion of Sonos site...at least it seams Sonos is aware of the Pandora issue and hopefully working on it.

https://status.sonos.com/

 

 

Im having the same issue. I can airplay from my iPhone’s IOS Pandora app to my play5 speaker, then group to the others but still no ability to change pandora while using sonos app.

IF ...IF … IF i had not spent a small fortune on SONOS speakers, I would chuck this system. Problems! Problems! Same issue with Pandora as above folks. In addition have spent hours trying to get my downloaded playlist from my iphone to play.  IF you can’t play any music with these speakers what is the point!

Userlevel 1

Weird thing - I can play amazon music and Spotify on Sonos...

Same issue here.  Hope they fix it soon...

Same. Doom loop. Hopefully someone finds a resolution and updates this thread. 

Same problem. So maddening.

Okay, thought it was just me.  Tried calling Sonos but they are closed now.  Hopefully they respond or know what is going on when we all call on Monday.

Having exactly the same issue. Sonos app forced me to upgrade to 11.0, then it asks me to authorize Pandora by clicking a button, which takes me to a Pandora’s website which then says authorization code not valid….as Roediger House said, circle of hell. Anyone from Sonos monitoring this board??