Pandora

  • 14 June 2010
  • 21 replies
  • 20450 views

Badge +4
i've been unable to connect to Pandora over Sonos for a couple of weeks now after it working flawlessly for years.

I always get the "unable to play... the connection to Pandora was lost" message.

On the CR100 it comes up when I select Pandora as a source. On my iTouch it logs in and I can see my Stations but when I select one I get the "Pandora was lost " message.

On my PC with the Desktop Controller s/w I get the same - I can see my stations but they all fail to play.

If I fire up my browser and go to www.pandora.com I can connect, see all my stations andplay them perfectly all day long.

Anyone any thoughts on what's going on, I'm missing my Pandora??

Malcolm

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

21 replies

There's isn't a Sonos zone paused somewhere is there? I don't know how many simultaneous non-PC connections you're allowed. If not, perhaps you might try removing the Pandora service, and re-adding it back in? Maybe something got a little out of whack somewhere.

There's certainly nothing wrong with Pandora, since it works on your PC and here on my Sonos setup.
Badge +4
no other zone paused so removed the service. Now when I try to add it back in Pandora is no longer listed to under music services. I can't add it!
MalcolmS,

Go to More Music.
Badge +4
More Music displays a page that says "+ More music choices" which if you follow that displays a page that points at www.sonos.com/getmusic. Nothing else
Did you change your location? Pandora is only offered when the location in your Sonos registration says USA. When you take Sonos with Pandora abroad, it will still display, but Pandora will refuse to work, they filter by IP address.
Badge +4
No I'm in the same location. I've a paid Pandora One subscription that I can still listen to via my browser from www.pandora.com or from Pandora Mini or the Desktop app and have been for several years...

In my first post in this thread I said that I could still login to Pandora and it would retrieve my stations but I could not play them on Sonos. Now of course I can't get that far since removing the service to try re-installing...

Those are the facts - but not the whole truth. I'm currently listening to Pandora behind WiTopia's PPTP VPN.
Badge +9
so you can play pandora through their web browser option? just not through the sonos native selection?
Badge +4
so you can play pandora through their web browser option? just not through the sonos native selection?

yes...

Through the web browser on my PC it works.

Through their desktop app on my PC it works (in fact i'm listening to it now).

Through Sonos (from any controller including the Desktop) I could browse to my stations but when I select a station, it said my connection to Pandora was lost...
So you're not in the USA and you're tunneling in to use Pandora on the desktop?
Badge +4
yes and yes

and I was using the same route to successfully listen to Pandora on my Sonos until a few days ago...
Badge +4
can anyone help? I'm really missing my Pandora.

Someone suggested factory resetting all my units and re-registering - would that at least allow me to get my Pandora account back under Music Services??
I have the feeling there is something wrong with your VPN, Sonos seems to be functioning as designed. In case you are outside the USA, your symptoms might mean Sonos is not using the VPN to connect to Pandora but goes directly through the internet.

I don't know how your service works exactly, in case there is a company on the other end, you might try to find out whether they changed something to their IP Addresses or whether Pandora started blocking them.
Badge +4
Thanks Avee, that's helpful... I'll pursue that once I can get Pandora listed as one of my music services again.

Anyone any ideas how I can get it to appear in my list of services again after NoBoB helpfully suggested I remove it. 🙂
Badge +4
can anyone confirm if I factory reset all of my Sonos units and controllers I will be able to re-register them and get back Pandora in Music Services or is that just a myth??
Userlevel 2
Malcolm:

Have you had any luck running Pandora on Sonos. I am running it on my PC and IPAD and there is no problem but getting the same problem on Sonons. I am using VPN program but dont know how to use it for Sonos? Please let me know if you have had success?
Badge +4
I managed to get it back as an Music Services option on all my Sonos controllers (my CR100s; the PC Desktop Controller and the Sonos app on my iPod Touch).

So I can go to Music, select Pandora Radio as an option and it gives me all my Pandora radio stations - which means it's logging into my Pandora account okay I guess - but then when I select any station it never plays. I get the error message "Unable to play xxxxxxxx Radio - the connection to Pandora was lost".

I too am using a VPN and can report that this did work some months back... and I can still listen to Pandora on my PC via Pandora.com in a browser or via their own app.

I'm was using this http://tinyurl.com/34httxz to config the VPN and I suspect what's happened is that Pandora has started using different IP addresses.
Userlevel 2
I guess in a PC or IPAd you can use VPN. The problem is that with Sonos you have to configue the VPN directly in the router which i am sure is not that easy.
Badge +4
which is what I did Navira and it was working great until a few months back... I was lucky in that I have the same router as the one in the link so it was easy to setup.

At some I did have a tool that showed you what IP addresses Sonos was using and was able to add those when they changed before but I can't find that anymore. 😞
Badge +4
I finally got Pandora working tonight again! :-)

I deleted my old VPN setup, rebooted my router and reset it up using the instructions here http://tinyurl.com/34httxz
Userlevel 2
Badge
Hi Malcolm S.

I have the exact same problem! Using Witopia aswell, and deleted and re-added. But get the same error message. I couldn't find the instructions using the link provided above.
i am having the exact same problem using UNBLOCKUS.

I finally got Pandora working tonight again! :-)

I deleted my old VPN setup, rebooted my router and reset it up using the instructions here http://tinyurl.com/34httxz


did you re-set up your Sono's too or just the network?