MusicBee, how play directly from MusicBee to Sonos

  • 26 August 2016
  • 14 replies
  • 3527 views

Is there a way to stream music from MusicBee to the Sonossystem?

14 replies

Userlevel 7
Badge +18
Hi, John. No plans to introduce this at this time, nor is it currently available. I will forward the suggestion and we will notify you of any updates as they become available. Thanks for the feedback, always appreciated.
I would also find this useful. Musicbee is excellent for managing very VERY large music libraries.
Big fan of MusicBee because of my specific love of genres which are not mainly supported by the moneymaking apps. I also manage a big library by myself and hope there will be a connection between Sonos and MusicBee. I'm not formiliar with uPNP/DLNA but is that the best option?
Badge
MusicBee is brilliant. It's my hub for ripped music, using it to syndicate to different locations. PC based though.. Can use real uPNP devices like Devialet to stream (incl. HighRes)
MusicBee is brilliant. It's my hub for ripped music, using it to syndicate to different locations. PC based though.. Can use real uPNP devices like Devialet to stream (incl. HighRes) Do you mean the Spark app? How do you use it to your Sonos?
Badge
bypasses SONOS...
Found a great plugin for MusicBee and it works directly. I can select output and find all my Sonos devices #happy http://getmusicbee.com/forum/index.php?topic=14277.0
Sonos is very cool, but really excludes people with their own music library. My wife likes cloud services but I have 70K songs in my library. The player on the computer is pretty bare bones.
Found a great plugin for MusicBee and it works directly. I can select output and find all my Sonos devices #happy http://getmusicbee.com/forum/index.php?topic=14277.0

Just found your comment after Googling Musicbee and Sonos. Can you give a bit more information on how to set up the Plugin to send music to Sonos. My Sonos system keeps giving me error messages, saying the song can't be played as its not encoded correctly. I'm a bit of a novice when it comes to encoding digital music.
Userlevel 4
Badge +2
I think that Sonos broke DLNA/upnp with one of their recent updates. It doesnt work with any of the servers I have tried recently (Foobar2000, Musicbee, MediaMonkey) though Foobar used to work.
My two Play5 speakers still appear in the Windows 10 "cast to device" right-click list, but that doesnt support stereo pairs and trying to cast anything just seems to crash my speakers.
Needless to say I can cast from my PC to my Yamaha amp using the same right-click menu without any trouble at all. The Yamaha amp can also see all upnp media servers I have tried and all of them work just fine.

Sonos support for other devices just goes from bad to worse. I wish they would stop introducing pointless new gimmicks to please Apple owners, and concentrate instead on making basic functionality and compatibility work. I own three Play 5 speakers but will never buy another Sonos product as long as they continue the way they are going. But I doubt that they care.
Sad to hear Sonos doesn't work well with MusicBee. I have bought and ripped a lot of music and want to be able to play easily from my own library via a PC that's on all the time, controlled remotely from my phone. Coughing up for Sonos speakers doesn't seem that attractive when there's a good chance they won't work.

It's a shame because I was looking to buy myself a Christmas present and a pair of speakers seemed like a good idea! 🙂
Hi all - I got MusicBee to stream to my SONOS Play 1 using MusicBee's UPnP plugin. Just wanted to share my settings that worked: https://imgur.com/XObJe0Q
I haven’t tried it out yet, but if that UPnP plug-in works, that’s huge! Thank you for pointing it out - and for the kindness of sharing your settings. It’s always nice to have a known working state to start from. Thanks again!
I haven’t tried it out yet, but if that UPnP plug-in works, that’s huge! Thank you for pointing it out - and for the kindness of sharing your settings. It’s always nice to have a known working state to start from. Thanks again!

It works for me - be warned, however, that the plugin is basically abandoned now and not being developed/updated. I was given the Play:1 as a gift, so thought I’d try to get it working with my music library. I was receiving the “encoded in wrong format” error at first, and got it working flawlessly with the settings in the above screenshot. That was my first attempt at trying non-default settings, so it might work with different settings (eg increased quality) as well. I just don’t want to change anything now, as it’s working - and sounds unbelievable (for a speaker of this size).

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings