Answered

Music keeps stopping and starting

  • 7 February 2017
  • 50 replies
  • 14702 views

Userlevel 1
Badge
Hi all, suddenly my music when played through Spotify to any room will just stop then 30 seconds or so later start again with the next song in the playlist.
Anyone got any remedies ?
Thanks.
icon

Best answer by djmudflap 9 May 2017, 03:57

For everyone.... I was troubleshooting and was getting no where. I moved my boost still directly attached to my router to a room with one speaker. I had powered off all the others. I was still having my issues with the boost in the same room as that one speaker no matter the channel. I was messing around and unchecked the android Sonosnet button in advanced settungs and everything worked perfectly the way it had for years. Plugged all my other speakers in and found that I had to re add all of them. No matter what channel I'm on everything works great now (For the last 8 hours)

Hope this helps......
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

50 replies

Userlevel 5
Badge +3
Hey bizarreknives,

If you're still having an issue playing from Spotify, can you please submit a diagnostic and let us know the confirmation number? Are you having playback issues with any other music services?
I'm having the same problem. The queue is set from a Spotify playlist of 430 songs. I use both random and loop settings. Music will be playing and a song will stop early another will start and stop almost immediately then music is stopped. Seems like once it happens it starts to occur more frequently.
Userlevel 6
Badge +3
I'm having the same problem. The queue is set from a Spotify playlist of 430 songs. I use both random and loop settings. Music will be playing and a song will stop early another will start and stop almost immediately then music is stopped. Seems like once it happens it starts to occur more frequently.

Hi str8aro, can you send us a diagnostic and reply with the confirmation number? Here's an article explaining how: How to Submit Diagnostic
Will try, it's intermittent so might take a while
Just sent a diagnostic. Not sure if it's exactly the same problem but music did bounce around
the queue and finally stop. Diag # 7363953
Ok, just sent another diagnostic where music as playing, one song ended early then music stopped.
Diag # 7364181
I'm having the same problem. we have a playlist that plays while the kids sleep on a loop. Its been working fine for sometime but in the last month it stops and starts all the time

Your confirmation number is: 7364652
Userlevel 6
Badge +3
Ok, just sent another diagnostic where music as playing, one song ended early then music stopped.
Diag # 7364181


I've reviewed both of your diagnostics and found peaks of WiFi interference on both. This will lead to the issue your system is experiencing.
Make sure your Sonos BRIDGE isn't right next to your router nor any another wireless device. Also, at the moment your Sonos is communicating on WiFi channel 6. Would it be possible for your to test the other two channels 1 and 11 for about 20mins each? Here's an article explaining; How to change Sonos WiFi channel

I'm having the same problem. we have a playlist that plays while the kids sleep on a loop. Its been working fine for some time but in the last month it stops and starts all the time

Your confirmation number is: 7364652


Hi djmudflap, your system is experiencing the same issues as the member: str8aro. At the moment your system is running on channel 1. Would you mind testing the other two WiFi channels for 20 mins each? Here's How to change Sonos WiFi channel
I've changed channels as suggested. I'd like to add in your troubleshooting this many people didn't just all a sudden just start having this problem due to wireless interference. I like this problem to be fixed
7371632
djmudflap I've looked at your most recent diagnostic, you're currently on wireless channel 6 and every room is showing wireless interference higher than we'd like to see. It's particularly high in the Master Bedroom, Living Room, and Kolton's Room.

This interference will manifest with poor audio quality and interruptions. This link outlines common sources of interference.

Would you mind changing the channel to 1 and 11, letting the audio play for 15-20 minutes, and submitting additional diagnostics while you're on each channel? We can then compare those reports to your first.
Manny sure thing just switched to channel 1 and it played for 2 seconds started bouncing through the play list and then stopped displayed error connection to spotify lost.

7376693
On channel 11 I get the error nothing plays for spotify.

7376720
For everyone.... I was troubleshooting and was getting no where. I moved my boost still directly attached to my router to a room with one speaker. I had powered off all the others. I was still having my issues with the boost in the same room as that one speaker no matter the channel. I was messing around and unchecked the android Sonosnet button in advanced settungs and everything worked perfectly the way it had for years. Plugged all my other speakers in and found that I had to re add all of them. No matter what channel I'm on everything works great now (For the last 8 hours)

Hope this helps......
Badge
I've changed channels as suggested. I'd like to add in your troubleshooting this many people didn't just all a sudden just start having this problem due to wireless interference. I like this problem to be fixed

This started happening beginning of the year. It also happens when wiring up the SONOS connects. SONOS was super reliable prior. A new update must have wreaked havoc 😞
PanamaDodo, the diagnostic is reporting that one of the Ethernet cables for the Living Room might be malfunctioning. Would you mind swapping both of them out and then sending over another diagnostic?
Badge
PanamaDodo, the diagnostic is reporting that one of the Ethernet cables for the Living Room might be malfunctioning. Would you mind swapping both of them out and then sending over another diagnostic?

I. Changed the cable from the router to the Sonos connect. I disconnected the second cable used to feed another device.
App disconnected after trying a search 7426232
After several tries I managed 5 seconds of play and then it. Dropped. Again 7426296
Plug the Sonos into a different port on the router. There were 2 Ethernet cables attached to the Sonos before; disconnect the second one so there is only a single Ethernet cable going between the Sonos player and the router.
I've been having the same problem and now i'm mad because i just reset everything lost all my playlists, etc. and it's still happening, have been experiencing this ridiculous issue since the last software update - how on earth have you not released a software update to fix this? Wireless interference is now an issue after the system has been working fine for years, you've got to be kidding me.
Userlevel 5
Badge +3
I've been having the same problem and now i'm mad because i just reset everything lost all my playlists, etc. and it's still happening, have been experiencing this ridiculous issue since the last software update - how on earth have you not released a software update to fix this? Wireless interference is now an issue after the system has been working fine for years, you've got to be kidding me.

It's best to take a look at your system via diagnostics. Then we'll be able to see if there are other issues that may contributing to your streaming hiccups.

Do you by chance have a Sonos device plugged directly into your router? If so, try replacing that ethernet cable with a new one and testing again. Sometimes we see that the cables can go bad over time.

As mentioned, please submit a diagnostic, reply with the number here and we'll be happy to investigate.
Hi - Since I submitted this I've removed the bridge from my system. I do not have an ethernet cable connected to anything at this time, but used the Playbar in order to re-orient my Sonos speakers with my home network. The issue seems to have been reduced so far. I've submitted diagnostics just now for your review, confirmation number is: 7512240. (I see there is an update to the controller now which I am yet to install, will give it a shot tomorrow, thanks!)
Userlevel 5
Badge +3
Hi - Since I submitted this I've removed the bridge from my system. I do not have an ethernet cable connected to anything at this time, but used the Playbar in order to re-orient my Sonos speakers with my home network. The issue seems to have been reduced so far. I've submitted diagnostics just now for your review, confirmation number is: 7512240. (I see there is an update to the controller now which I am yet to install, will give it a shot tomorrow, thanks!)

Thanks for including the diagnostics. We're seeing some error messages that could indicate that some of your Sonos devices are having problems reaching out to your main router.
Can we have you perform a full system reboot in this order: unplug the router and ALL Sonos speakers. Plug in the router and allow it to boot fully. Once rebooted, plug in the Sonos devices and allow those to fully boot, then test the system again. Please submit another diagnostic and we'll take another look.
Hi Dominique - thanks for your response, resubmitting the diagnostics after completing all of the steps outlined above, confirmation number: 7528313. Have not installed the s/w update yet, may do it this weekend.
My Sonos keeps stopping.

Just sent a diagnostic while it was happening

7818887
This deflecting by Sonos Tech support is honestly insulting. It's not the Wifi interference, it's not a bad ethernet cable, nor router port (and you know it). It is JUST SPOTIFY; all other streaming services work fine, even when stressed. I've installed many dozens of Sonos systems and all have worked totally fine with Spotify until one landmark system update last year. Since then, the service has become far too intermittent to recommend or sell, and we get frustrated calls from customers left and right now. It would be TRULY GREAT if the software engineers rolled up their sleeves and figured out how to remedy this, instead of this 'wifi interference' farce. I would pay several hundred dollars to have this issue resolved. Typical experience is that it'll play a song for 5 seconds and then say the connection has been lost.