Music cuts out/jumps to next track


Userlevel 1
Worked fine for a month, suddenly it begins skipping tracks or skipping to the next song early when using songs on my iPhone library.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

136 replies

In July Sonos sped into an alliance with Apple to support airplay 2. This was a business move to better align with the future of Apple, and to boost the value of the Sonos company. In so doing they inadvertently left me behind.

I have Sonos 3’s that I play through the Sonos app. And while I do play Pandora, it is my personal music that I cherish. My iPhone and iPad sleeps/locks after a certain time because I also have Microsoft work emails on the devices, and that email is secured. As a result my stored music skips because I have other airplay devices in the home (TiVo box, Onkyo receiver and Apple TV) which now conflict with the Sonos setup. Many people don’t suffer with this problem because they don’t have this combination of playing stored music, they don’t have airplay in the home or because they don’t have work email on their devices which forces a lock.

Sonos promotes the fact that they don’t create obsolescence, but in my case they have. I hope this is temporary, and do feel they answer my ongoing phone calls and diagnostics to solve. For now I fell through the cracks and my expensive speakers with their stunning sound and winning aesthetics are obsolete, dead to me.

I have read that by buying a new One I can link the One to my pair of Three’s (set up as stereo) and move the Three’s to airplay 2, which might eliminate the problem. My questions are: 1). Is this true, 2) can I silence the 1, use it just as a link for my awesome 3’s, or 3) can I buy a new pair of Fives for the living room, and thereby get airplay 2 on my Three’s in the bedroom (still allowing each room to run separate)?
Userlevel 3
Badge +1
Hi everyone,

I wanted to update this thread to let you know we're looking into an issue with streaming from iOS device's storage when the device goes into auto-lock. We will update this thread when we have more to share, but for now you can disable the auto-lock feature in the iOS settings app under Display & Brightness. Also, it may help to disable AirPlay on any non-Sonos devices you may have.


This was the update from last month saying they will look into issues streaming from iOS device's. The latest response from Jeff S "The update we released was to address a very specific issue that has happened since we added AirPlay 2 support to Sonos. When you have non-Sonos AirPlay devices on your network, and try to stream from the storage on an iOS device, there can be audio interruptions. This specific issue is rather new as we just added AirPlay 2 support this year. If you've been having issues for 2 years, there's something else going on. It can be hard to troubleshoot 2 different issues with similar symptoms."

So they have not addressed the issue streaming from iOS devices that has been known for more than 2 years judging from the date of the first post of this thread. Sonos only fixed a "specific issue for AirPlay 2". Skipping music streaming from an iOS device is not an isolated issue and it has been known by Sonos for more than two years and they have not attempted to address the issue.
Userlevel 7
Badge +22
That is not what he meant in those comments. He means if the original poster has issues for years it’s not related to the issue with airplay 2. It doesn’t mean it’s an ongoing issue across user base but an issue for that person that needs resolved personally with Sonos troubleshooting.
Userlevel 7
Badge +20
Hi folks,

We released an update which was meant to address the issue of playback from iOS device's storage while you have non-Sonos AirPlay devices on the network and your iOS device goes into auto lock. The update helped for some folks, but not for all. If you are still having this issue, please reach out to our phone team so they can continue to investigate the issue. You can find our phone number and hours here.

In the meantime, you can still stream from your iOS device's storage if you disable AirPlay on non-Sonos devices, or if you disable auto lock on your iOS device. Another option is to sync your iOS library with the iTunes on a computer, then set up a music share.
Userlevel 3
Badge +1
Hi folks,

We released version 9.1 today which should help out with issues streaming from iOS devices. Please update your systems and test things out. You can read more here.


This was the original post from Jeff S saying 9.1 should help with issues streaming from iOS devices. This statement is misleading as 9.1 does not fix songs skipping when iOS device auto-locks and the auto-lock issuewas the original one from years ago before AirPlay. Confirmed this with Dave at phone support today. Dave at phone support says they are aware of this issue and are still working on a fix along with Apple (since it may be an issue with iOS as well). So for those still having the same auto-lock skipping issue, we’re still waiting.

So for Jeff S. and the others directing me to call phone support, thank you. Now I know and can relay to the community that there’s a huge disconnect of information between forum moderators and Sonos phone support.
Userlevel 3
Badge +1
Hi folks,

We released version 9.1 today which should help out with issues streaming from iOS devices. Please update your systems and test things out. You can read more here.


This was the original post from Jeff S saying 9.1 should help with issues streaming from iOS devices. This statement is misleading as 9.1 does not fix songs skipping when iOS device auto-locks and the auto-lock issuewas the original one from years ago before AirPlay. Confirmed this with Dave at phone support today. Dave at phone support says they are aware of this issue and are still working on a fix along with Apple (since it may be an issue with iOS as well). So for those still having the same auto-lock skipping issue, we’re still waiting.

So for Jeff S. and the others directing me to call phone support, thank you. Now I know and can relay to the community that there’s a huge disconnect of information between forum moderators and Sonos phone support.


Correction, phone support is actually David not Dave.
Note: the fix in 9.1 didn’t fix the issue you are having. You (and I) don’t know if it fixed another issue that other people were having.
I may have found a fix for this! 🆒

I'm running 9.2 of the Sonos App on iOS 12.1. When playing songs from "My iPhone", the song will cut off before the end and play the next song in queue. It will continue this until the iPhone is unlocked, then do it once the iPhone sleeps and locks again.

I've been a Sonos user for some time, so I'm not sure if this is because I had previous apps or what...I ended up fixing the issue with an iOS setting. Go to Settings > Sonos > Siri & Search, Then I enabled (turned on) "Siri & Suggestions". This was off. I also ensured I have "Allow on Lock Screen" enabled. This alone seemed to fix my issue. Just for confirmation, my other settings are:
Microphone = Enabled
Media & Apple Music = Enabled
Background App Refresh = Enabled
Cellular Data = Disabled
Hardware Volume Control = Enabled
Lock Screen Controls = Enabled

I can replicate the issue when I disable the "Siri & Suggestions" setting, the skipping of songs returns. I'm positive this fixed my issue. I hope this helps someone else. The skip issue doesn't seem to affect streaming services, just "my iPhone" media.
Userlevel 7
Badge +20
Hi folks,

We released version 9.1 today which should help out with issues streaming from iOS devices. Please update your systems and test things out. You can read more here.


This was the original post from Jeff S saying 9.1 should help with issues streaming from iOS devices. This statement is misleading as 9.1 does not fix songs skipping when iOS device auto-locks and the auto-lock issuewas the original one from years ago before AirPlay. Confirmed this with Dave at phone support today. Dave at phone support says they are aware of this issue and are still working on a fix along with Apple (since it may be an issue with iOS as well). So for those still having the same auto-lock skipping issue, we’re still waiting.

So for Jeff S. and the others directing me to call phone support, thank you. Now I know and can relay to the community that there’s a huge disconnect of information between forum moderators and Sonos phone support.


Hi there,

The patch released was helpful for some folks but not all. We're still looking into this issue but for the meantime you can get streaming working again by disabling AirPlay on non-Sonos devices on your network, or by syncing your iOS library with iTunes on a computer, and setting up a music share.
I still have the issue even with the new updates.
What I dont understand is if it’s on a radio station there are no interruptions it’s just any streaming from Spotify or Apple...
Diagnostic-1849416913
Userlevel 7
Badge +20
I still have the issue even with the new updates.
What I dont understand is if it’s on a radio station there are no interruptions it’s just any streaming from Spotify or Apple...
Diagnostic-1849416913


Different streaming sources use different amounts of bandwidth coming from different servers. There are some wireless communication errors between your Bridge and other speakers, changing the wireless channel your Sonos system is using should help.

Most of the errors I see in your report show connection problems with your iOS device's library. There's currently an issue affecting playback from the storage on iOS devices when you have non-Sonos AirPlay devices active on your network. You can get streaming from your iOS device working again by disabling AirPlay on non-Sonos devices in your home, or by syncing the library up to a computer and setting up a music share.