Library sorted by folder not album/artist

  • 19 August 2018
  • 2 replies
  • 172 views

  • Contributor I
  • 0 replies
Hi, since recent update, I relinked my music library on the Sonos controller. However after indexing, the 'album', 'artist', 'genre' (etc.) folders are blank, and there is a new "Folders" option. Clicking this through takes me down through sub-folders, to a list of folders for each artist i.e. as I would see it on Windows Explorer

Question : why has Sonos stopped recognising my music as artists/albums, and only recognises it as folders. Help please

My Sonos speakers continue to work, and the music files work when accessed via the folders. I haven't changed anything in iTunes, or the location of the music folders
Using Sonos controller for Windows 10 Home and iTunes 12.8.0.150 to manage my music
Music is in D:/Music/iTunes. The individual artist folders are in D:/Music/iTunes/iTunes media/Music
From iTunes I have removed, and then recreated the iTunes Music Library.xml file in the iTunes folder
I have tried removing and adding the Sonos Music Library, including selecting the "My Music" option, as well as selecting various sub-folders
I have uninstalled Sonos and re-downloaded from Sonos.com

thanks for your assistance

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +19
Hello there, J11. Thanks for posting and welcome to the Community. Sounds like there are some problems with how your music library is being sorted in Sonos. In most cases, problems like this point to problems with metadata and can usually be resolved with a call to our support technicians over the phone. They can set up a remote session and get a real-time look at what is going on and get this sorted.
Hi. I have the same problem and have also tried re-connecting to the music file, ensuring Sonos is up-to-date etc. Was this issue resolved and can Sonos share the solution here? Thanks!