Issues with Google Play Library on Sonos


I've signed up for Google Play Music - testing the waters as I usually do with a new music service. One odd thing I've found is that on the Sonos app, under the Google Music , My Library, a bunch of random artists pop up yet they are not mine. Clicking on the artist comes up empty. My library on the Google Play Music website shows it's empty (as it should). However, I can't seem to get rid of this list of artists on Sonos. I've tried removing and re-adding the service. Re-authorizing the service etc. Anyone else having these issues?

11 replies

Userlevel 2
Hi!

Problems here too, similars but not the same..... After adding to sonos my google play account, The uploaded music doesn´t appear (but when I log to my account in the PC or directly in the google play app , everything is ok) neither in my iphone nor in the desktop controller...I´ve checked the configuration of my account and my PC and the IOs appear as "authorized".
I've tried removing and re-adding the service, re-authorizing the service etc. too and same problem. Help!!!!:rolleyes:
Userlevel 3
Badge +2
Double check the songs on your local hard drive with a metadata editor. Get rid of any "non standard" character in the file name and the metadata information - stuff like umlauts, accent marks, etc.
Double check the songs on your local hard drive with a metadata editor. Get rid of any "non standard" character in the file name and the metadata information - stuff like umlauts, accent marks, etc.
Where do you think that "non standard" characters are not handled properly?

I have several artists and tracks with these in my library, and everything is OK. They display OK, they feature in the indices OK, and I can search for them using the nearest English replacement character.

eg: Communiqué by Dire Straits, or Björk
Userlevel 1
Badge
There's definitely an issue with how often the library gets updated. When I first started with Google Music it also had an artist I never added. After a while it worked itself out though. Also if you have an artist and delete everything by that artist, it also takes a while for that to disappear.

I think I read somewhere on ask.sonos.com that they're aware and working on a solution.
Userlevel 3
Badge +2
Where do you think that "non standard" characters are not handled properly?

I have several artists and tracks with these in my library, and everything is OK. They display OK, they feature in the indices OK, and I can search for them using the nearest English replacement character.

eg: Communiqué by Dire Straits, or Björk


I don't know. When I was experimenting with the service, I noticed I couldn't see all of my songs in Sonos. When I removed the characters and reuploaded, the songs showed up. So, I can't say for sure it was due to the file name or that the process of reuploading refreshed the song list.
Double check the songs on your local hard drive with a metadata editor. Get rid of any "non standard" character in the file name and the metadata information - stuff like umlauts, accent marks, etc.

My issue is not related to my library on my PC - it is not being shared with Google Play Music. I actually don't have any music currently shared with this service which is why I find this strange. On the Sonos app, under Google Play Music, My Library, a bunch of artists show up - none of which are mine. The music is fairly random - quite a bit of Electronica and Latin. It appears as though it is indeed someone's library as there are random songs which appear to be bootlegged MP3's as there is a website as part of the metadata. However, none of the music plays.

Logging onto the Google Play Music website, I don't see anything in my library as it should be.
My issue is not related to my library on my PC - it is not being shared with Google Play Music. I actually don't have any music currently shared with this service which is why I find this strange. On the Sonos app, under Google Play Music, My Library, a bunch of artists show up - none of which are mine. The music is fairly random - quite a bit of Electronica and Latin. It appears as though it is indeed someone's library as there are random songs which appear to be bootlegged MP3's as there is a website as part of the metadata. However, none of the music plays.

Logging onto the Google Play Music website, I don't see anything in my library as it should be.

I started uploading a few tracks to Google from my own library then ran out of patience. After deleting them from Google, phantom artist/album/genre items remained for those tracks.

Some days later these they were replaced with different phantom artist/album/genre items for music I've never even listened to, still without any tracks to go with them.

Someone noted somewhere that Sonos Support are aware of this issue.
Userlevel 1
Badge
Did you delete them from the trash as well? When you do that they seem to disappear quicker. There's definitely a pretty big delay regardless though.
Did you delete them from the trash as well?
Yep. Straight after deleting from the library. It made no difference to the ghosts in artists/albums/genres in Sonos.

In any case the issue is probably all tied up with the unsolicited appearance of other items in those sections.

https://ask.sonos.com/sonos/topics/deleted_albums_still_exist_in_google_play_music
Userlevel 1
Badge
They'll probably disappear in a week at most. It is definitely annoying! Probably the best way to use Google Play Music is through the actual app on Android (although casting from that isn't rock solid either... sometimes it just stops).
The old entries disappeared eventually ... to be replaced by a whole bunch of stuff that's never been part of the library.

Casting is all very well, but you may need to stop your Android going to sleep. The Sonos player streams independently, but under track-by-track command from the Google Play app, which needs to interface with the Sonos controller app each time.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings