Answered

Imported Playlists Won't Work When Mac is Off/Closed

  • 11 October 2017
  • 7 replies
  • 251 views

Badge +1
I have imported my iTunes playlists into Sonos. I'm getting duplicate playlists but I'm already trying to fix that on another post. What I've found is that when I try to play songs from those playlists on my iPhone (Music Library/Imported Playlists) Sonos won't play the music unless my Mac is on or open. If it's closed or off it'll say it can't find the file. Now I know that I can go direct in my iPhone to (On This iPhone/Playlists) but I don't have all my playlists on my iPhone. Is there a way to access all of my playlists from iTunes on my phone without having to sync all of them to my phone? I'm also wondering if i I imported the music incorrectly? The "Music Library" folder is correct when I go to "Preferences".

I'm hoping I'm explaining this clear enough. I just want to be able to access ALL of my music on my phone that's on my MacBook without having to physically import all of my music to my iPhone.
icon

Best answer by Airgetlam 11 October 2017, 19:05

I'm guessing that you have your music stored on the hard drive of the mac?

Basically, you've told Sonos to "play music located in this location" and then removed the location from the network.

You should go in to the system preferences for energy settings, and tell you hard drives not to sleep. This can be done by clearing the check box next to "Put Hard Drives to Sleep When Possible" You may potentially need to do that on both tabs, if you think necessary. The tabs are labeled "Battery" and "Power Adapter", however I would generally recommend not doing it on "Battery", especially if your Mac doesn't have an SSD, as the power consumption of a spinning drive is much more than a SSD.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

I'm guessing that you have your music stored on the hard drive of the mac?

Basically, you've told Sonos to "play music located in this location" and then removed the location from the network.

You should go in to the system preferences for energy settings, and tell you hard drives not to sleep. This can be done by clearing the check box next to "Put Hard Drives to Sleep When Possible" You may potentially need to do that on both tabs, if you think necessary. The tabs are labeled "Battery" and "Power Adapter", however I would generally recommend not doing it on "Battery", especially if your Mac doesn't have an SSD, as the power consumption of a spinning drive is much more than a SSD.
Badge +1
Yeah I think you're correct. It's looking at the source of the music as the MacBook HD so when it sleeps it can't find the source files. I've made the adjustment on the "Power Adapter" so I'll see if that helps. Thanks for the feedback.
Happy to be of assistance. I had the same problem, until I finally bit the bullet and bought an NAS, which is "on" no matter the state of my Mac. Made life a tad easier, and was only around $100 for a TB or two.
Badge +1
But when you hook up a NAS and you take your laptop outside your network you can't play your music anymore right? Because the files are not locally stored on your laptop anymore correct?
Yes, good point. But I play my music on my Sonos, and actually have copies on my phone for use in my car and at work.

No requirement to get an NAS, if you're willing to keep the hard drive running. It can make things slightly easier, but it's just an option.
Userlevel 2
Badge
You should be able to "copy" your music over to the NAS. Keep the music on your laptop for the laptops use, and then copy over the music to the NAS for Sonos' use. However, when you update the laptop, you'll have to be sure you have it set correctly to then update the NAS, so that the music updates/changes/etc match across both. The NAS can be setup to backuip the laptop every once in a while.

Otherwise if you don't really care much about that, you could essentially just keep one version of your music on the laptop and one version of the music on the NAS.
Had same problem. Got free app InsomniaX and prevented idle sleep and lid sleep. Now its working great.