Question

I can't play music from youtube music

  • 29 October 2019
  • 73 replies
  • 3039 views


Show first post

73 replies

Since Sonos doesn’t make any money from you playing YouTube music, it’s hard to think they’d be able to compensate you. That would be for the company that you’re paying a subscription to, YouTube Music to do. Although I’d bet there’s something in their terms of service about temporary interruptions. Might be worth re-reading that user agreement with Google.

Got the same problem. YTM Family. 
my work around is to play using Airplay from the YouTube music app. Though, I want to use the Sonos app for better controls. 

https://youtu.be/-k2QLoRSAAQ

Some times i can play some music, maybe interesting error.

Same problem here… it’s quite annoying… someone found a fix?

 

Userlevel 1

Piling on to this thread as I am also having the issue of playing YouTube Music through Sonos app.  I’d be happy to help troubleshoot if any technicians from Google or Sonos need someone in the field to better track down the problem.

Badge

Piling on to this thread as I am also having the issue of playing YouTube Music through Sonos app.  I’d be happy to help troubleshoot if any technicians from Google or Sonos need someone in the field to better track down the problem.

I think they have tons of diagnostic logs already from all the other posters in this thread. REALLY disappointing they’re not getting this solved. It’s been so long now that I’ve given up. Maybe some day it’ll start working again but my bet is no one will know why. Just some setting somewhere that no one knows has any effect on YTM on Sonos… I’m so tired of this. Anyone know of any other (non Apple) streaming devices where YTM works? I guess Google Home Max but any others?

Userlevel 1
Badge

I just reverted back to GPM for the time being rather than going through the hassle of finding a new service for now.  GPM is working fine.

 

Same scenario though: GPM Early Adopter on a personal account with a G-Suite Account also installed, moved to YTM when Google was migrating everyone over.  Was working fine until a couple weeks ago.  Now it gets worse everyday, to the point where it’s unusable for more than 3-4 songs.

Badge

I just reverted back to GPM for the time being

The thing is: GPM doesn’t have the “Your Mixtape” that YTM has. I use that almost exclusively along with shuffling a single artist.

Got an email from Sonos Support earlier today where they requested a diagnostic session online sometime during the week. I’ll post any findings here.

Userlevel 1
Badge

I’ve got a hunch this is a Google problem as the errors coincided with the release of a ton of new Google Hardware, but hopefully this will spur Google and Sonos to work together on the issue. 

Badge

I’ve got a hunch this is a Google problem

I totally agree! But only Sonos reacted to my tweets. So hat’s off to them for doing that.

Google gave me 2 weeks free even though I didn’t ask for anything yet since the issue is still unresolved. But there are so many changes in youtube these days I’m pretty sure they are to blame and know it.

Badge

YouTube music has not worked for three weeks now... When will this be fixed???

I will cancel my Youtube Premium Account and go back to spotify now. 

I’ve stopped my Youtube Premium account (up to six month and you keep your data) and used my Amazon Music account (included with premium) hoping Youtube or Sonos will care one day...

Sad it still hasn't been fixed and no word from Sonos. I just found YouTube Premium also gives Google Play Music access which is working for me in the Sonos app, so I'll run with that for now. 

Badge

hoping Youtube or Sonos will care one day...

I actually think Sonos DO care. I’ve had them on the phone twice running diagnostics on my system. I really think the problem is with YouTube. And the question is if THEY care which I’m inclined to think they don’t. I was told the “access denied” is also served if Sonos logs into YouTube Music and cannot find the track in question. Someone else in this thread wrote something about YTM consolidating the tracks from an artist from multiple channels into one (what ever a channel is?). This sounds more likely to be the root cause than Sonos relaying out account info to YTM.

This morning it was working again for me. 
 

Badge

YouTube Music is working again for me too.

I’m glad that YouTube fixed their issue!

Badge

Woohoo!!! Works for me too :-)

Badge

 

Anyone find out what the problem was?   Still not working for me . :-(

You may want to try a reboot of your router, followed by a reboot of your speakers. 

Daaamn my Youtube service is BACK!!

Reply