Question

I can't play music from youtube music

  • 29 October 2019
  • 73 replies
  • 3028 views

Userlevel 1

I am a premium member of YouTube Music and I have successfully added the service to my Sonos app in Android.

However, when I try to play music from YouTube Music it is showing a message that access is denied. Please help. Thank you.


73 replies

I'm having the exact same problem. I've removed and reinstated my account and re authorized it but still persists.

 

I have the same issue, is it related to the update to the app and speakers that happened earlier today?

Same issue here.  Started last night.  Tried two different devices (one Andriod one Apple) with the Sonos app installed and both had the access denied issue.  Removed YouTube music from within Sonos and re-added/authorised but still access denied.

Moments ago my speakers updated and the problem persists.

Have no problem with the other streaming services in the Sonos App.

Same issue. Beginning to get frustrated with these bugs. Wasted 15 minutes of my morning checking subscription and reinstalling the apps. 

Badge

Same here… come on...

Same issue here since today. 

Access denied to YouTube music. 

Run diagnostic with number 657963407

Please help. 

Badge

Just had a very polite Sonos supporter on the phone. They’re looking into the issue.

A couple of things I thought of while talking to him:

  1. I’m a Google Play Music early adopter. Got YouTube Music thrown in at some point.
  2. I have a GSuite account (also early adopter from when it was a Google Apps account).

Any of you guys recognize this?

Same issues here, started maybe 3 days ago. Some songs will play, but most won't. 

CJ66 - I also started with GPM. YTM thrown in for free, started using it when learned that GPM is going away. I also have GSuite account, but it is my work account. YTM/GPM uses my personal account, so probably unrelated to GSuite. 

I've seen this behavior a couple of times in the past, many months or a year ago, but it seemed to resolve itself within a day or so.

 

Badge

YTM/GPM uses my personal account, so probably unrelated to GSuite.

Good to know!

Weird behavior: I was asked by Sonos Support to try to play something other than “Your Mixtape” from YTM. Everything failed. Then after the call (I must say they were very serious about it) I tried playing some other playlists and from time to time a track would actually begin to play. It would skip 5-10 tracks and then suddenly start playing. Really weird. But was reproducible in the sense that it would happen with different playlists. The really weird thing however, was that trying manually to play one of the tracks that had just played, failed. So it’s not related to the specific track.

I have the same problem. Spotify is working perfect , but with youtube Premium I get an error message when I start a track ‚Access denied‘. I made the authorization for the sonos-app and reinstalled everything again and again, not working. I have an Iphone XR. 
Very disappointing.

Mazo

Same probleem here, I contacted Sonos support but they couldn't find anythis wrong on Sonos and advised me to contact Google but how to contact Google on this specifiek item....?

The said I getting blacklisted on google when starting YT Music via Sonos.

YT Music via the app on my phone works without any problem.

Very enoying indeed 

Anyone whi found/resolved this issue on Sonos?

Hey. I contact both Sonos and Google about Youtube music service. Unable to play ‚track name’ access is denied. This seems to be Google and Youtube Music issue. They got all info about issue also gave them link to this forum and Google team promise to contact me back whitin 24-48 hours. Other services like Spotify Amazon Tidal work without problems.

Getting pretty annoying now, submitted multiple diagnosdiag to online chat and all they say is I need to call up. 

Nothing from Sonos recognising there is an actual fault.

 

Badge

Same problem here.   Also a YouTube premium member..   I tried to do an Artist Shuffle on Leonard Cohen.    It seemed to play everything from 2 albums but not any of the others..  it almost seems like a licensing issue from YouTube for 3rd party streamers but what do I know?    I hope they can resolve it soon.

 

Badge

I take it back..  Doesn’t seem like a licensing issue anymore.   What tracks will play when seems totally random.   It will play tracks it was just unable to play and then not play other tracks that it was just playing..    Seems pretty sure to be a Sonos bug now.

Badge

Hey. I contact both Sonos and Google about Youtube music service. Unable to play ‚track name’ access is denied. This seems to be Google and Youtube Music issue. They got all info about issue also gave them link to this forum and Google team promise to contact me back whitin 24-48 hours. Other services like Spotify Amazon Tidal work without problems.

 

It may be a Google/YouTube issue but it still seems like something Sonos should be figuring out with them directly instead of users having to do it.   It must be affecting everyone isn’t it?

Any other similarities?   I’m in Canada..  it’s happening to USA customers as well?

 

Badge

Any other similarities?   I’m in Canada..  it’s happening to USA customers as well?

 

I’m in Denmark… just got an update in my twitter dialog with Sonos support. They want to know if the supporter I spoke to on the phone tried setting up one of their test accounts on my system. He did but was prompted to provide info from the iPhone attached to the account(!). No one knew anything about that :-)

Same on my side. I also tried to get a reply from Google.

I’ve also raised this with both Sonos and google (YouTube Music), Sonos seem to want to test everything local to my home network, they don’t like to deviate from the troubleshooting script!

Google we’re pretty responsive and have taken some details away to look into.

Seems to me to be an integration issue with the Sonos app now not having the correct permissions, I don’t know anyone else with Sonos and a YouTube music subscription so hard to judge if it’s effecting everyone or if we are just unlucky.

Badge

It’s definitely affecting me and I haven’t done anything new except upgrade Sonos when it asks me to.

Hi all!

 

Not sure if your account configuration is the same, but the account I was having issues on was managed by my school (meaning still G-Suite but under the purview of the institution).

 

When I switched my premium to a regular gmail/google-managed account, it worked!

 

Let me know if you all have success with this.

I am using a personal YouTube Premium account, Sonos support is pretty poor, basically saying they’ll only now work on this over the phone, problem is I’m not at home this week during their support hours.

Badge

Hi all!

 

Not sure if you’re account configuration is the same, but the account I was having issues on was managed by my school (meaning still G-Suite but under the purview of the institution).

 

When I switched my premium to a regular gmail/google-managed account, it worked!

 

Let me know if you all have success with this.

 

I’ve only ever had a regular gmail/youtube account and have had nothing to do with g-suite so I don’t think this applies to me.   Not to mention that it was working without problems for months and then only just started having trouble this last week.

 

Well, I just got off an hour-long phone call with support and they couldn’t figure it out. They tried their Google test account and it worked perfectly fine. Not so sure calling them is going to help your case :/

Badge

 

I put some proof of the issue up on YouTube.  

 

 

Reply