Grouping Play:1’s to AirPlay Speakers - Issue


Userlevel 1
Badge
I have already contacted support about this and they are looking into it, but thought I’d ask in case anyone had a solution:

My Setup - I have a 5.1 system in my lounge (PlayBase, Sub, 2 x Play:1’s), 4 x Play:1’s spread around the house, and a newly purchased Sonos One.

What I Want - I want to use AirPlay 2 to stream Apple Music without using the Sonos app. My idea was to link my 4 Play:1’s to the Sonos One, giving me one AirPlay volume slider to control all of those speakers, and a separate AirPlay volume slider for my 5.1 setup (as this is louder than my Play:1’s).

My Issue - My issue is that the Sonos app seems to link my 4 Play:1’s to the PlayBase rather than the Sonos One, meaning one AirPlay slider changes my 5.1 system and my 4 Play:1’s, and the other AirPlay slider changes my Sonos One.

Does anyone have any idea how I can change this?

Many thanks.

36 replies

Firstly go into 'Settings/AirPlay' in the Sonos App and enable the toggle button that says “Group non-Airplay Speakers”.

Then goto the “Rooms Tab” in the Sonos App and group your 'Sonos One' Room with all 4 Play:1’s ... I assume that all four are standalone in different rooms, so you will end up with all 5 rooms grouped together.

Then just leave your PlayBase, Sub and bonded speakers as another separate room.

You will then end up with the two rooms showing in your AirPlay list. One is the PlayBase Room and the Other is the Sonos One Room.

When you play to the Sonos One Room the AirPlay Audio will now come out al, your Play: 1 Speakers grouped with the Sonos One... Each individual speakers volume, can be controlled by the Sonos App, including muting etc; but the group volume can be controlled via the AirPlay volume slider bar.

Let me know if that achieves what you were trying to do.
Userlevel 1
Badge
Many thanks for your detailed response. I really appreciate it.

This is exactly how I have set it up and how I expected/wanted it to behave, unfortunately, this doesn’t seem to be the case.

I group all the Play:1’s to the Sonos One using the Sonos app, and then control the volume using the AirPlay slider. All good so far. However, when I then use AirPlay to send the audio to my PlayBase as well, it then adds this to the same group in the Sonos app, and then the Sonos One AirPlay volume only controls the Sonos One, and the PlayBase AirPlay volume controls my 5.1 setup and all my other Play:1’s.

It’s very frustrating. It seems that the Sonos app decides that the PlayBase is the default speaker to pair with all the non AirPlay devices, and doesn’t give me the option to make the Sonos One the default device.
Right I think it’s the way AirPlay might be working... or it could of course be a bug. See below for a possible workaround.

Try this ... set things up as stated in my post above and play just to the Sonos One and it’s grouped speakers.

Before you next go onto play to the PlayBase by checking the other box in the AirPlay list, first begin the AirPlay audio by just reverting back and playing to your iOS device (iPad/iPhone/Apple TV/PC), whatever device you are using to play the AirPlay audio, then switch it over to the PlayBase. See if that fixes the grouping together issue.

I will also try the same thing here to see if I can replicate the problem and if so, I will perhaps try to file a bug report about the matter. By the way, which version of the Sonos App and which version of IOS are you currently using?
Userlevel 1
Badge
Will try that now and report back. Thank you! I’m on an iPhone X, iOS 11.4.1 and Sonos App 9.0. Averything is fully updated. Cheers
Okay here is what I have just tried... I’m using iOS 12 public beta on my iPad.

I first of all grouped a Sonos One Speaker, called 'AirPlay Hallway' with all my other Sonos Speakers about the house ... this was one group.
Next I omitted one room from the group called 'Dining Room' which is in fact a 5.0 setup consisting of a Sonos Beam and two bonded surrounds... so this forms the second group. See first screenshot (1) showing the two separate (grouped) rooms in the Sonos App.

The next screenshot (2) shows my AirPlay list in iOS 12.0 ... AirPlay Hallway and Dining Room. Obviously ignore the iPad and Apple TV, in the list they are not relevant for our purpose here.

I play Apple Music audio to the 'Airplay Hallway' Group and everything works fine I can adjust the audio either in the Sonos App or via the AirPlay slider bar for their group volume.

If I now go onto select the 'Dining Room' in the iOS AirPlay list ... so I have both selected, I have two volume sliders appear in the AirPlay list, presumably one for each group and at the bottom there is a further slider bar for the group overall.

Is that correct so far ... is that what you are doing? Can you tell me then what are the steps you next take that causes your problem, before I go any further.
Userlevel 1
Badge
That is correct so far. Thank you. My issue is that once I have selected both the AirPlay sliders, the one for my 5.1 system controls the volume of that plus all my Play:1’s around the house. I want the AirPlay slider for my Sonos One to control that and all the Play:1’s. Does that make sense?
Userlevel 1
Badge
I have recorded a screen shot video to try and explain what I mean but it won’t let me upload videos to this forum.
Userlevel 1
Badge
http://www.youtube.com/watch?v=iQU3VL6RbQU

Here’s the video showing how I set things up as separate groups, and how the Sonos app then groups it all into one. I then move the volume sliders at the end to show that they are controlling the wrong speakers.
If I AirPlay to both rooms (AirPlay Hallway & Dining Room) I can slide either volume bar in the AirPlay list itself. See screenshots 1 and 2 attached.

This will simply adjust the Beam 5.0 and it’s Bonded Surrounds in the Dining Room, or the other slider Adjusts the Sonos One (AirPlay Hallway) and all its grouped speakers.

The third screenshot is just showing the two rooms in the Sonos App playing the AirPlay stream.

So far, it all seems to be working fine so far, or at least, it’s how I had expected things to work. Both sonos groups are playing the same AirPlay Music in perfect sync (Lily Allen’s Air Ballon, in this example) and I can adjust the volume for either group using the slider bars in the AirPlay list.

That’s where I am at the moment with this test.
Userlevel 1
Badge
So for some reason when I try and AirPlay to both seperate groups the Sonos app links them all into one group (as seen in my video) whereas yours is keeping them separated (as I want). I have no idea what I am doing wrong?
What I don’t understand in your video is you have...

Hallway Sonos (obviously your Sonos One, grouped with your Play1’s)
Lounge Sonos (PlayBase 5,1 System)

Each were playing nicely and separately ..and then 'suddenly' the video shows them in the Sonos App all joined together as one complete single group.. did you do that yourself, or did the joining of the two just happen automatically?

I’m not so sure the two are meant to join together as one big group in that way (presuming you didn’t do it yourself) ... they should remain as two separate groups, but obviously with each playing the same audio in sync. As per my two attached screenshots.

So it looks like that might be the issue ... is that the point you have been trying to get across to Sonos here?
We just need to find what it is that’s making the two room groups join together as one BIG group in the Sonos App and then report that perhaps as a possible bug ... the problem is it could be an Apple AirPlay issue that’s causing the problem and the reason mine isn’t doing it, is maybe because I’m using the iOS 12.0 public beta on my iPad.

If you can find what you do that causes the rooms to group into one big group, that would be of help and I could then try to replicate it here.
Userlevel 1
Badge
That is correct. I did not choose to make them one group. They were seperate in the Sonos app until I selected both the AirPlay enabled speakers, and then the Sonos app grouped them. This is the point I have been trying to get across. I want it to work the way yours clearly is! I wonder if this is a problem with iOS11 and iOS12 fixes it?!?!
When the rooms join together by themselves next time, can you also submit a diagnostic ... here’s a link to show how to do that:

Submit System Diagnostics

And can you post the diagnostic reference number here too please... thanks very much !
Userlevel 1
Badge
This is the problem, I have no idea why it is forcing them into one group in the Sonos app. I could update to the iOS12 beta if it’s stable enough? Unless there are any app settings you can think of? My PlayBase is connected via Ethernet cable and the Sonos One is not?!?! Not sure if that’s a possible issue?
Userlevel 1
Badge
When the rooms join together by themselves next time, can you also submit a diagnostic ... here’s a link to show how to do that:

Submit System Diagnostics

And can you post the diagnostic reference number here too please... thanks very much !


Yes of course, I am out now though so will do it when I get home.
mattnunn1985,

Just to also let you know, I will try to highlight this matter for you too with Sonos, so they can maybe take a closer look at your grouping issue. Your diagnostic will help of course, when you get a chance later.

All the best ... hope the issue gets resolved for you soon.
Userlevel 1
Badge
144937802 - Here is a diagnostic as requested.

Thank you very much for the help, really appreciate it.
mattnunn1985,

Thanks for the diagnostic submission, that should help. The matter has been passed to Sonos. If you can you leave the video in place for a while, so they see your issue and then maybe take it down, when the matter is sorted.

Thanks...
Userlevel 1
Badge
Will do, thanks again!!!
Userlevel 7
Badge +26
Thanks for all the details you two, and some really great steps taken so far.

The expected behavior with AirPlay 2 and multiple streams is that they should get grouped together in the Sonos app. This is for what we call continuity of control, but it comes down to being able to control what's playing using all of the methods of doing so. For example, to start a stream using AirPlay 2 from your phone, turn the volume up with Alexa voice commands, and pause the stream by pushing the Play/Pause on any of the players. In order for this to work, they have to all be grouped together in the Sonos app.

Matt, your system is actually behaving properly (the way it's supposed to) and it's Ken's system that isn't doing the right stuff. If you're running on the iOS 12 beta, it could be due to that. I know there has been some trouble with that software and AirPlay 2 integrations, eventually, it'll get sorted out and should wind up working correctly, the way Matt is seeing it.

As to being able to control the volumes separately using the AirPlay sliders, the group volume control should affect both of the AirPlay 2 speakers volumes and the grouped Sonos players that aren't AirPlay 2 compatible all at once. Using the individual volume control sliders will affect just the single room you choose in the AirPlay 2 app (which can only select AirPlay 2 compatible players). There isn't a way to have two different groups for volume control, but you can adjust them all together at the same time, and then use the individual slider to turn down the volume of the AirPlay 2 compatible player you wanted to have at a different level.

I'll pass along a request for you to get more control of the volumes and grouping, but currently, this is behaving as it should.
Userlevel 1
Badge
Thanks for the response Ryan. For clarity, I have attached two photos showing my Sonos set up and the AirPlay screen on my iPhone. The first picture shows what is currently happening, and the second photo shows what I expected/want to happen, and the sole reason I purchased a Sonos One. The arrows show which speakers each AirPlay slider turns up/down. Is this really not possible?
Userlevel 7
Badge +26
Great pictures!

Once you have the same AirPlay 2 content playing on all of your Sonos devices, the way it should work is closest to the first one, but what should happen is this:

1. Volume slider for Lounge Sonos (Playbase) should adjust the volume of the Playbase and its surround speakers/Sub.
2. Volume slider for Hallway Sonos (Sonos One) should adjust the volume of just the Sonos One.
3. Volume slider at the bottom (unlabeled) should adjust the volume of all of the devices at once.

The same behavior should carry over if you were to press the volume up or down on any of your individual players (adjusting just the one room you've pressed) or use the volume sliders in the Sonos app.

Are you certain that what you're seeing in that first picture is what's happening? Adjusting the volume of just the Playbase with AirPlay 2 shouldn't affect the Play:1s that aren't bonded with it. Looking at the video, the only part that doesn't seem to match up with what's expected is the last few seconds, so I just want to confirm that you aren't pressing anything odd like the hard buttons too, those affect the overall volume, and would put the group at a different level.
Userlevel 1
Badge
I am 100% certain. Adjusting the volume of the PlayBase with AirPlay 2 adjusts the volume of all my speakers except for the Sonos One.
Userlevel 7
Badge +26
I am 100% certain. Adjusting the volume of the PlayBase with AirPlay 2 adjusts the volume of all my speakers except for the Sonos One.
I'll do some investigating on our side on that one, as it sounds like it could be an AirPlay 2 bug. It shouldn't work that way from what I know. The volume slider for either of your individual players shouldn't control the rest of the group. With that said, even though the Playbase is doing it, there isn't a way that's intended for the Sonos One to be the one that has this experience instead.

My guess is it could be because the Playbase is the only wired Sonos player. And it could be because it's set up at the group coordinator. Or it may be entirely unrelated to this. (Since it's not the intended functionality, it's a bit tricky to pin down right now.)

You could try this:
1. Wire the Sonos One into the network and disconnect the Playbase from the network.
2. Reboot all of your Sonos devices.
3. Try AirPlay 2 out again and see if it behaves differently.

Reply