Google Play won't cast

  • 4 February 2017
  • 69 replies
  • 8673 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

69 replies

Badge
Same issue here. Phone finds Sonos but when trying to play from Google Play app it just glitches between play and pause with no sound then advances to the next song.
Sonos diagnostic #7250609
Userlevel 7
Badge +26
Thanks for the details guys. We're taking a look at those diagnostics to compare if there are any similarities. As general troubleshooting steps the first things I'd suggest to start with are rebooting the wireless router and toggling your Wifi off and back on for the mobile controller. Then try the direct play again. If that fails, the next step is to remove and re-add Google Play Music within Sonos.

Let us know how it goes.
Badge
Rebooted everything, deleted and re-added Google Play from the Sonos list of services in that app. Music will stream from within the Sonos app but same symptom from Google Play app...connects to Sonos system but will not play. Flips between pause and play and advances to next song. I contacted Google Play app and tried all their remedies no results. They determined it's a Sonos issue.?
Userlevel 7
Badge +26
Thanks for the update Grey. Think you can send one more diagnostic for us? Also, just a few more questions:

  1. What model router are you working with?
  2. How is the Sonos connected to the network?
  3. Do you use any wireless access points?
Badge
Diagnostic #7253192
I have a Netgear router, will get model # to you.
The Sonos system is setup through a Sonos Playbar. No access points. Directly to router/modem.
grey2175,

Just a random thought, not that I think it may have an impact, but have you updated the firmware on your router recently? Might be helpful to the guys at Sonos if you were current on that. It's something I tend to ignore mostly, since I don't log in to my router very frequently to check if there are updates available.
Badge
I just purchased it new 3 months ago so I wouldn't think it should need an update.?
For the record I am having exactly the same issue.

Sonos app works fine. I can use the services I have added including Google Play Music.
Google play app works fine when listening through the phone or casting to my Chrome cast attached to the TV.

I am no longer able to cast to Sonos from the Google Play app. Once I select any of my Sonos devices, I hit play and it just stops a split second later. No sound comes out.

I have a Google Pixel phone and a Linksys XAC1200 router. Everything else works as expected.

@RyanS

1. What model router are you working with? Linksys XAC1200
2. How is the Sonos connected to the network? Wirelessly
3. Do you use any wireless access points? Not entirely sure what you mean by this. Everything is connected fine wirelessly across the apartment.
Hi

I have also started having issues with Google Play and Sonos. When I access my music via GP and attempt to cast it to the Sonos speakers nothing will play, it's almost like you can see it scrolling through the songs unable to play each one. When I attempt to play music via the Sonos app ('music on this device') it only shows partial albums and again won't play the songs.

I have submitted a diagnostics report: 7255803

Thanks
Same issue others have described. I've already submitted my diagnostic - 7251115. I received a response to change my router chanel to 6 or 11. I'll test it out and let you know if works.
Userlevel 7
Badge +26
Thanks for the details everyone. We're going to want to get a closer look here live so we can narrow down the cause of the issue. If you haven't had a chance to call our support team, we'd love to work with you. Feel free to give us a call on our support line.

I've created incidents for you to use when you call in, bjeg500, your number is 170405-002773, grey2175, you're under 170405-002791, and bbish007 you can use 170405-002797.

@bbish007, can you also submit a diagnostic from your Sonos system and reply back with your confirmation number?

Same issue others have described. I've already submitted my diagnostic - 7251115. I received a response to change my router chanel to 6 or 11. I'll test it out and let you know if works.

Sounds good, let us know how it goes. If you're still having trouble, we'll get a ticket opened up for you, unless you just want to give us a call which you're welcome to do.
Userlevel 7
Badge +17
Google play casts to sonos ok for me 🆒
Radio, individual albums, my stored music & playlists all ok.
It took 5 minutes for my Samsung tab 10.1 to settle down after start-up, but it is old, so not sure anything has changed there.
Are you all on 7.2?
I had both updates of beta (which had a known problem), before installing 7.2.
It's stopped working for me again. 😠
Restarted everything, re-added Google Play Music to the Sonos app, still doesn't work. Same issue as everyone else - the app flickers between play and pause but doesn't play. Diagnostic number: 7261498

Up until 7.2 my Sonos had been working absolutely fine with Google Play Music. 😞
I'm having the same issue too:
7238769

I can cast fine from the Sonos app, but not from Googleplay Music. In Googleplay Sonos shows up in the list of devices I can cast too but when I try nothing happens, the play button just flickers on and off. Googleplay will cast to the Chromecast attached to my TV no problem but not my Sonos speaker.


Hi, since I reported this fault (above) my phone took a swim so I've had to replace it.

My new phone is running Android 6.0.1 and still having the same issue. I've submitted a new diagnostics report - 7293158 the new phone is a Motorola G4, the previous phone was a Motorola G3.

I have also tried this using my tablet a Nexus 7 running 5.1.1 and have the same issue, diagnostics number - 7293175
Userlevel 7
Badge +17
Thanks for the detailed reply of your devices.
Still working ok for me.
Casting to GPM was broken during beta phase, and i would have hoped, supposedly fixed before 7.2 release. But I guess sonos cannot test every android device out there with every software version on it.
Upgrading sonos always causes a storm of failed threads on here due to duplicate IP addresses etc, but if sonos app works fine, I cannot see it is that......
Hopefully Ryan will keep us informed.
Userlevel 7
Badge +26
Thanks for the details and diagnostics guys. We're investigating with Google Music right now, there seems to be some trouble for some free Google Play Music accounts that are unable to stream to Sonos players through the Play Music app. We're working with them to get it sorted out, but I don't have any specifics on that timeline right now. I'll let you know as things develop and it gets resolved. It's not affecting all free accounts from what we've seen, and it shouldn't be trouble with any premium subscriptions.
Thanks for the details and diagnostics guys. We're investigating with Google Music right now, there seems to be some trouble for some free Google Play Music accounts that are unable to stream to Sonos players through the Play Music app. We're working with them to get it sorted out, but I don't have any specifics on that timeline right now. I'll let you know as things develop and it gets resolved. It's not affecting all free accounts from what we've seen, and it shouldn't be trouble with any premium subscriptions.

I've got GM premium and I'm getting the same issue. I have my Sonos system connected via LAN through my Playbar.

Diagnostic is 7300338.

Thanks
Badge
This whole time I assumed I had subscribed to Google Play but had not. Once I subscribed and updated my credit card info casting to Sonos works again.
We're currently investigating this issue, we have had reports from a few users being unable to cast from the Google Play Music App to Sonos, specifically with a free Google Play Music account, the current work-around is to play from the Sonos app.

We'll update this thread once we have an update.

Many thanks for your patience
Mine stopped working today. I have the paid version of Google music.
I am having a similar issue but notice that specifically I'm unable to listen to 1) music from my own collection (PC -> Google Play sync) or 2) Podcasts. I get the same behaviouor which is that it flips from play/pause a few times. I am however able to listen to Google Play stations no problem.
Hey Guys

At this moment it appears as though casting from the Google Play Music App from a free account isn't working, we are actively working with Google on this and will update this thread when we have some news.

In the mean time, could you post Diagnostic 's from the Sonos app shortly after you experience the issue specifically casting from the Google play App and let us know whether you have a free or premium account.

The workaround is to play from Google Play Music within the Sonos application, rather than casting to Sonos from the Google Play Music App.

Many thanks
Diagnostic 7318034

Free account
Any idea why it is taking so long to get a proper fix to this? Can we not downgrade to version 7.1 until there is a fix?
I have a free Google Play account and can't cast music since update to 7.2.

Rather annoyed!