Answered

Explicit songs from Spotify blocked

  • 4 December 2019
  • 21 replies
  • 1671 views

I recently set up a Sonos system, and Spotify is the only service I’ve connected. I want to be able to play songs marked as “explicit” through Sonos, but they’re grayed out.

It seems like this has to either be a Spotify thing or a Sonos thing, but…

  • I’ve never filtered explicit content in Spotify, but I checked my Spotify settings just in case, and “Allow explicit content” is indeed enabled
  • I found “Content Filters” in the Sonos settings, but “Filter Explicit Content” is grayed out and says “Not supported”

Any idea what might be going on? I haven’t found an answer on the forums yet. Thanks!

icon

Best answer by Anonymous 11 February 2020, 19:30

@jmschles Sorry for the slow response to your Sonos Community question. I understand that you want to play explicit content from your Spotify music service on Sonos. Please follow the steps in this link for confirming your parental controls with Sonos. You describe the option as being grayed out.  Is your Spotify account a premium or free account? Also, as per the provided link above, have you confirmed that your Spotify account does not have its own parental control filters that need to be updated? Lastly, please use this link to remove the Spotify account and re-add the service to Sonos and let us know of the testing results. We will also want to see an updated diagnostic report so please use this link for submitting the report and reply with that report number as well.

View original

21 replies

Badge +1

I recently set up a Sonos system, and Spotify is the only service I’ve connected. I want to be able to play songs marked as “explicit” through Sonos, but they’re grayed out.

It seems like this has to either be a Spotify thing or a Sonos thing, but…

  • I’ve never filtered explicit content in Spotify, but I checked my Spotify settings just in case, and “Allow explicit content” is indeed enabled
  • I found “Content Filters” in the Sonos settings, but “Filter Explicit Content” is grayed out and says “Not supported”

Any idea what might be going on? I haven’t found an answer on the forums yet. Thanks!

I have exactly the same problem. Have been using Sonos + Spotify for long time but haven’t experiences a problem liike this before.

Have you tried to contact Sonos Support directly to discuss it?

I usually suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.

Did you solve this?

The  only thing I am aware of is Settings,  System, Parental Controls.  Have you tried that?

Hi John,

 

Thanks for the reply. Yes, I’ve tried that in both the sonos and Spotify settings. Very frustrating. 

Assuming you have 'filter explicit content' set to 'disabled '  in the Sonos app then my only other suggestions are to delete your Spotify sccount from Sonos then re-add it as a service, and to reboot (power cycle) all your Sonos components. 

Bump.  Having the same issue.

@jmschles Sorry for the slow response to your Sonos Community question. I understand that you want to play explicit content from your Spotify music service on Sonos. Please follow the steps in this link for confirming your parental controls with Sonos. You describe the option as being grayed out.  Is your Spotify account a premium or free account? Also, as per the provided link above, have you confirmed that your Spotify account does not have its own parental control filters that need to be updated? Lastly, please use this link to remove the Spotify account and re-add the service to Sonos and let us know of the testing results. We will also want to see an updated diagnostic report so please use this link for submitting the report and reply with that report number as well.

Hi all, thanks for the replies. I back-burnered this for a good while, came back today, and lo and behold, I can play explicit songs now. The one thing I’m sure of is that it isn’t because of anything I did.

I’ll go ahead and respond to @John G ‘s suggestions anyhow in case they’re helpful to anyone:

  • As described in my initial post, Sonos content filters just look disabled. I’ll attach a screenshot below. (Ignore the tripled message, guessing that’s just a minor bug.) I’m wondering if this feature would enable if I went and turned on parental controls in Spotify, but now that things are working, I’m afraid to mess with it!
  • My Spotify account is premium
  • Also covered in my original post, but I did verify that parental controls weren’t on in Spotify (they never were)
  • It’s possible unlinking/relinking Spotify would’ve fixed this, but again, now that it’s working, I’d rather not touch anything. Worth a try for others.
Parental controls screenshot

 

 

@jmschles Thank you for the follow up and letting us know you are working now. I’ll mark the answer here. Please follow up if the issue arises again.

Having the same issue. Parental Controls in Sonos are disabled.  Have removed and re-added my Spotify account. 

Badge

Same issue here. Any fix??

Userlevel 6
Badge +16

Hi @hamsteronwheel

Welcome to the Sonos community and thanks for reaching out to us.

I would like to share with you the guide already provided above on how to fix the issue.

@jmschles Sorry for the slow response to your Sonos Community question. I understand that you want to play explicit content from your Spotify music service on Sonos. Please follow the steps in this link for confirming your parental controls with Sonos. You describe the option as being grayed out.  Is your Spotify account a premium or free account? Also, as per the provided link above, have you confirmed that your Spotify account does not have its own parental control filters that need to be updated? Lastly, please use this link to remove the Spotify account and re-add the service to Sonos and let us know of the testing results. We will also want to see an updated diagnostic report so please use this link for submitting the report and reply with that report number as well.

I hope this helps.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Userlevel 6
Badge +16

Hi @Finnabbie.

Welcome to the Sonos community and thanks for reaching out to us.

I would like to share with you the guide already provided above on how to fix the issue.

@jmschles Sorry for the slow response to your Sonos Community question. I understand that you want to play explicit content from your Spotify music service on Sonos. Please follow the steps in this link for confirming your parental controls with Sonos. You describe the option as being grayed out.  Is your Spotify account a premium or free account? Also, as per the provided link above, have you confirmed that your Spotify account does not have its own parental control filters that need to be updated? Lastly, please use this link to remove the Spotify account and re-add the service to Sonos and let us know of the testing results. We will also want to see an updated diagnostic report so please use this link for submitting the report and reply with that report number as well.

I hope this helps.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Userlevel 7
Badge +21

According to my iPhone S1 app, Spotify does not offer content filtering on Sonos. It says it is only available on Amazon, Apple, and YTM of my services.

My S2 app is the same.

Not sure how you managed to enable content filtering when it isn’t supposed to be supported. Maybe its a geo-thing? I am in the USA.

Userlevel 7
Badge +21

Can you give an example of a Spotify track that is blocked from playback?

I only use the free version of Spotify, so I’m not sure if this may assist, but Spotify itself has explicit content filtering that can be toggled off/on within the Spotify App. I’m not sure however if that option then filters through to sonos, as I can’t see the playlists with my free version of the software.


Attached is a screenshot from my Spotify App though FWIW ..and it needs to be ‘ON’ for explicit content to show in the Spotify App. It also may take a while after setting the option for it to feed through to sonos, that’s if it does have any bearing on the Sonos/Spotify content.

 

 

Badge

Same problem I just noticed. Trying to play Lana Del Rey’s Norman F***ing Rockwell via Spotify account and half of the songs that are marked as explicit don’t play in Sonos - they are greyed out. But If I play the album directly from Spotify app and choose to stream to my Sonos speakers it works. Please fix this very annoying issue Sonos support. 

Userlevel 6
Badge +16

Hi @PaddyPDX.

Welcome to the Sonos community and thanks for bringing this to our attention. I understand your situation where you’re coming from. Let me help you out.

I would like to recommend going through some of the provided recommendations above so we can check if it would help fix the issue.

@jmschles Sorry for the slow response to your Sonos Community question. I understand that you want to play explicit content from your Spotify music service on Sonos. Please follow the steps in this link for confirming your parental controls with Sonos. You describe the option as being grayed out.  Is your Spotify account a premium or free account? Also, as per the provided link above, have you confirmed that your Spotify account does not have its own parental control filters that need to be updated? Lastly, please use this link to remove the Spotify account and re-add the service to Sonos and let us know of the testing results. We will also want to see an updated diagnostic report so please use this link for submitting the report and reply with that report number as well.

I hope this helps.

Please let us know if you have further questions or concerns. We are always here to help.

Thanks,

Badge

No that was not the issue. My settings are not and were never set up to block explicit content in either Sonos or Spotify and it has always worked previously, the ability to play explicit songs as well as non explicit songs. The explicit songs just have an “E” in a grey box next to the song name.  Anway, long story short, must have been a problem at the  Sonos end, as today when I opened the same album the songs are all listed as normal again with the “E” next to the explicit songs and they are playing just fine.  

Userlevel 6
Badge +16

Hi @PaddyPDX.

Thanks for the update and immediate response.

You may have a point with that. It may have been a Sonos issue or just a glitch that was fixed with the recent update since updates do comes with feature releases, feature updates, and bug fixes. The good news is everything is up and running and re now playing. I do hope the issue ends here so that you’ll continue to love and enjoy your Sonos.

If you still have any further issues or concerns, please do not hesitate to reach out or create a topic. We’re always here to help out.

Thanks,

 

Reply