Answered

Connection to Amazon Music failing

  • 4 October 2016
  • 8 replies
  • 4717 views

I set up Amazon Music as a music service in the Sonos app yet I'm unable to play any songs.
When I follow the steps to authorize, it appears to complete successfully. I'm able to browse Amazon playlists and stations. I know the account is being accessed since I'm able to find my personalized playlists. However, when I attempt to play a song, I get the error "Unable to add songs to the Queue". When I attempt to play a station, I get the error "Unable to play '' - the connection to Amazon Music was lost."

Any ideas or suggestions?
icon

Best answer by chris_h 7 October 2017, 14:12

Hi @llm, thanks for the reply, I had been wanting to post an update. I simply called Sonos, and one of their support techs triaged my problem in about 15 min. Because the 'connection to Amazon Music failed' error can happen for many reasons, in my case, it had nothing to do with the wifi channel. My issue is that there are so many wifi networks in my area of the city, that Sonos was being bombarded with signals. The tech suggested that I plug a network cable into my Sonos base (previously the base was on wifi). Plugging in network cable not only solved the problems I was having on both my base and play:1.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +19
Welcome to the community. Rcollopy. We will have some advice for you as soon as we gain some additional insight into the problem. As such, please send us a diagnostic and respond here with the confirmation number. Thank you in advance.
Here you go, thanks - 6613626
Userlevel 7
Badge +19
It seems that there is an issue with the connection between your speaker and router. There's another router on the same channel as yours, though. This probably explains it. This router is called "Circle-30CA"

Can you try changing your router's channel to channel 6?
Hi,
Thanks, because I had the same problem as @rcollopy-7893507, so I changed my router channel (from "auto" to "6") after reading this thread, and today is the first time in the six months I have owned Sonos that I am able to stream Amazon Music without it failing. ??
Nevermind, see below to find it is failing again. It plays the first few seconds of a song, then it fails:

10/3/17, 2:22 PM
Unable to play 'Young Volcanoes' - unable to connect to Amazon Music.

10/3/17, 2:24 PM
Unable to play 'Where Did The Party Go' - unable to connect to Amazon Music.

10/3/17, 2:24 PM
Unable to play 'The Mighty Fall [feat. Big Sean]' - unable to connect to Amazon Music.

😠
After submitting the support system diagnostics a moment ago via the Mac thick client Application, my confirmation number is coming up as: 7909611.

Please help me to fix the failing, just like you did for the previous customer. I tried switching to channel 1, but it isn't helping.

Chris
I've had no problems until the upgrade. Now, i am getting the 'connection to Amazon Music failed' error message. Any suggestions?
Hi @llm, thanks for the reply, I had been wanting to post an update. I simply called Sonos, and one of their support techs triaged my problem in about 15 min. Because the 'connection to Amazon Music failed' error can happen for many reasons, in my case, it had nothing to do with the wifi channel. My issue is that there are so many wifi networks in my area of the city, that Sonos was being bombarded with signals. The tech suggested that I plug a network cable into my Sonos base (previously the base was on wifi). Plugging in network cable not only solved the problems I was having on both my base and play:1.