Answered

Cast Google Play Music to Sonos Unreliable


Badge +1
I see this has been a recurring issue for some months if not years. Google Play Music cast to Sonos from the app on controllers works but cannot be relied upon for me. It simply keeps stopping mid-way through albums/playlists, normally between tracks (hence taking a while to realise that the next track just isn't starting). When I realise I have a silent house I open the app to see the orange "Play" button (in other words, the controller knows that the music stopped), and the "cast" icon is still highlighted (so the controller knows it is still "casting"), but the pressing that "play" button does nothing. If I go to the playlist and press on the track that was supposed to be playing I see the screen updating in the controller and then it starts to play locally on the phone/controller. I have to then re-cast it, once again not knowing how long it's going to work for this next time.

Does anyone have any idea how to troubleshoot this please? No much point building or using a feature if it can't be relied upon. It never felt to have got out of "beta" to me...

Just to be clear, I am confident it is not any of the typical issues with wireless interference or poor Internet connectivity etc. Other sources stream fine. This is a problem that I have isolated to this feature.
icon

Best answer by Keith N 27 March 2018, 21:08

Understood. Thanks for the diagnostic report. If this only happens while casting, it will be a little more difficult to pin down. It may be best to give our support technicians a call to troubleshoot this in real time. Thanks for your patience.
View original

21 replies

Userlevel 7
Badge +19
Hey there, User935307. Thanks for the post. Does this only happen when casting, or does this happen when using the Sonos Controller as well? If so, please submit a diagnostic report and I'll be happy to take a closer look at what we can do to address the stops. Be sure to reply with the confirmation number it gives at the end. Thanks!
Badge +1
Hi. It only happens when casting. Using Sonos app works fine, but that gives me about a tenth of the functions of the service from GPM. It just stopped now again 3 tracks into an album. GPMb music showed the playlist as part way through, and the play button is there waiting to be pressed. However, pressing it just gets ignored. Only way to resume is to manually click on the next track in the playlist. Here is the diagnostic, submitted right after it happened: 1820939586. Tnx
Userlevel 7
Badge +19
Understood. Thanks for the diagnostic report. If this only happens while casting, it will be a little more difficult to pin down. It may be best to give our support technicians a call to troubleshoot this in real time. Thanks for your patience.
Badge +1
I have also had this exact issue raised to Sonos and was also told (after spending time sending diagnostics) to call their support. Unfortunately, the Sonos support is never open when I'm home to call them. Please can anyone tell me if a solution was found when calling Sonos Support? It is only when casting a playlist or album from the GPM app that it happens. It works fine otherwise. If it stopped mid-track then I could see how it could be something that Sonos Support might be able to fix locally (e.g. network timeout etc), but it always stops at the end of a track, mid-way through a playlist. I can't see how this cannot be a problem owned entirely by either Google or Sonos (on their end of the service). If anyone can share whatever fault-finding routine was used I would appreciate it please. @Sonos - any chance you can give us in Europe access to your US call centre so that we are not restricted to only being able to call you when we are all at work?
There's no reason why you couldn't call the US call center, I'm relatively sure that the data set is shared across all locations.

You also have the option of using their 24/7 twitter support, or I believe they also have 24/7 Facebook support, although it doesn't seem to be listed here: call Sonos
Badge +1
Thanks Bruce. I'll give it a try and see if they will support via US number (I did ask before and was told I had to call the European/German number)
Userlevel 7
Badge +19
User935307: Let me know if you run into any snags getting a hold of support. I will be happy to reach out to the team and get this addressed.

What type of playlists are you playing?

This reminds me of a situation I ran into with Spotify and Sonos. If you have a Spotify account set up on Sonos, you'll see that certain types of playlists are not available such as "Daily Mix". These playlists are infinite, in that after a while the service will pull more content, so the music never stops. When you use the Spotify app to control Sonos, you can access those playlists and "cast" the music to your Sonos speakers. The catch is that Sonos does not pull data from Spotify as the living playlist gets updated.

Let's say I were to start a Daily Mix (infinite playlist) on the Spotify app and cast that to Sonos. I let the music play and close the app on my phone to do other things. A little while later, the music cuts out. If I were to pull up the Sonos app, it would look like the music just stopped. In the Spotify app, it will seem like there is music to be played since opening the app refreshes the playlist. In order to keep the infinite playlist going, the application needs to be open in order to continually send the new content updates from the playlist to Sonos.

Does that sound familiar at all?
Badge +1
Thanks Keith. Appreciated.
It happens when I just press "play" on a simple album (to play the whole album). I am under the impression that GPM does a full "handoff" to Sonos (probably by sending it something like a custom URL) and that URL points at the full "playlist" (e.g. all the tracks in the album). If you say that a continuous handshake still needs to be maintained to the commanding app (GPM) then it might explain it. It still seems strange that the Cast function would be coded this way. When I cast an album from GPM and then open the Sonos controller app and look at the playlist I see the full album tracks listed. However it just stops playing within that list, and always at a track boundary. If I press play again in the GPM app (the cast function is still active) then nothing happens. I have to turn off the cast and re-initiate it.
I have the exact same problem. GPM is completely unreliable while casting to Sonos - otherwise plays fine. Playback is always interrupted at end of a track.
Userlevel 1
I have had problems casting to sonos from google play music. In my situation, it would stop because the google app would say that I am playing it somewhere else, so it is stopping play. I had a family plan, so I had one gmail account assigned to the google play app and another account assigned to the Sonos app. I have not had a problem casting since.
Badge +1
Thanks. This sound interesting though I'm not sure I've understood you. I'm not sure how it could be set up any other way. The Google Play account used for the GPM service will always be a different one to the one used for the Sonos app, no?
Neil
Userlevel 1
Yes. That is my personal experience. Others in this thread could be having a separate issue, but that is the only way I could get it to work properly.
Badge +1
Thanks. Please tell us what you had in place before this though. It's not possible to configure it another way. What's missing for me is what situation you had in place before you resolved it. If you agree that it's not possible to configure it any other way, what did you change in order to resolve the problem?
Userlevel 1
I had it configured the same way that everybody else had it configured: The same account for Google play music on my phone and in Sonos. At varying times the Sonos music playing would cut off after I start "casting" it from my phone to Sonos. To deal with it in the short term, I only initiated music for Google Play from the Sonos app. Once I saw a message that I was using the same account in two places on the Sonos, so I then got Google Play Family plan and put a different account on the Sonos. I never had the problem again. I realize that this is not practical for most people and it is only my experience.
Badge +1
Thanks Sonos Person. Now I understand. You might have used the same credentials for both accounts in the past, but to my knowledge it has never been possible to a Google account to authenticate directly with Sonos (I may be wrong).
I'm wondering if your input isn't actually a crucial part of this puzzle though. I have never seen the error message that you mention, but the symptom is what interests me. Maybe this is the only valid reason for playback stopping always at the end of a track. It could also be a bug indicating that this symptom only hits "free" accounts. When you moved to a paid GPM account, perhaps that's what caused the symptom to go away. I am on a free account, but it wouldn't be the only bug that hits only free users. Using the assistant to voice command the app is another. Thanks again
Userlevel 1
To be clear, I started out with a single paid Google Play Music account on both my Google Play Music App on my phone and Google Play Music on the Sonos device. I had problems with the music stopping randomly when I "cast" from the Google Play Music app on my phone to my Sonos speaker. I observed a few times where the Google Play music app on Android stopped the music because it said I was playing it somewhere else. I got a different Google Play Music account and put it on my Sonos app and it never happened again.
Userlevel 1
Badge
I'm having this exact same issue. When casting from qpm to my playbase the music stops after EVERY song. It does this if I'm playing an album from my library or a gpm station.
I've tried deleting my qpm settings in the Sonos app and reconfigure but that hasn't helped.
I can cast to my TV but I have having an extra appliance turn on when it isn't needed.
Has there been a resolution?
I'm having the same issue. GPM stops after every track. Between not being able to resolve this or add sonos to Google speaker groups I'm done. Replacing Sonos stuff with Google speakers. Doesn't sound quite as good but at least it works.
Userlevel 1
Badge +3
Hey there, User935307. Thanks for the post. Does this only happen when casting, or does this happen when using the Sonos Controller as well? If so, please submit a diagnostic report and I'll be happy to take a closer look at what we can do to address the stops. Be sure to reply with the confirmation number it gives at the end. Thanks!
HI Keith
Who will be the right contact to help with this in Australia? I am having the same issue for sometime now when using Google play music app. I can connect using the cast button then the playlist won't autoplay after the song.
Thanks in advance.
contact Sonos Support

Assuming your region for the website is set to Australia, that should bring up the proper contact data.
Userlevel 1
Badge +3
contact Sonos Support
Assuming your region for the website is set to Australia, that should bring up the proper contact data.contact Sonos Support

Thanks, managed to send the diagnostic number via email.

Reply