Answered

Cant Login

  • 26 December 2019
  • 8 replies
  • 146 views

I have a Pixel 4 and multiple Sonos machines.  I tried to log in to Pandora from the Sonos app and it wouldn't let me so I tried to log in to Amazon which also wouldn't let me so I tried Sonos itself through the app and that also wont let me log in. However, my app is connected to my Sonos system fine, it just won't let me log in from the app. It sees all of my machines and let's me control them, just won't let me connect to any music service or to my Sonos account. Everytime I try to log in through the Sonos app it just spins the circle for a long while then returns me to the home screen to try again, with the same result. I've uninstalled and reinstalled my Sonos app. I checked that I am able to log in fine through the website (even on my phone) and have confirmed that my email is "verified" in my profile. I also checked for updates after my reinstall.

 

So at this point I can't see any of my music. I'm at a loss but think I have to start with figuring out why Sonos won't let me log in. 

 

 

icon

Best answer by CassidyNY 17 February 2020, 19:37

Jean C,

Rebooting the Sonos hardware itself resolved my issue! I am now able to login to the app and music providers. I can't believe it was that simple, after all this time being frustrated! Thank you for your help.

View original

8 replies

Same issue! @sonos help! 

Please fix this!

What OS is running on the Pixel 4? Have you rebooted your router? Have you checked your Sonos account to ensure your location is set properly?

Userlevel 4
Badge +10

Hello @CassidyNY are you able to access the Sonos app in full and submit a diagnostic report from your system?

Please follow these steps to  submit a diagnostic and respond here with the confirmation number. 

Have you previously been able to add and use these music services in Sonos or are you adding them for the first time?

The same for @kk276604 and @fcsphoto also if you are still having trouble. 

Hello @CassidyNY are you able to access the Sonos app in full and submit a diagnostic report from your system?

Please follow these steps to  submit a diagnostic and respond here with the confirmation number. 

Have you previously been able to add and use these music services in Sonos or are you adding them for the first time?

The same for @kk276604 and @fcsphoto also if you are still having trouble. 

 

Jean C,

 

I just submitted a diagnostic report. The ID is 2008323706. Yes, I was previously able to use these services and they all still work fine on my husband's phone. He is also an Android Pixel user. We checked our settings and we have the same system version of Sonos and we're on the same home network. More info:  when clicking around in the app, Sonos implys it can't connect to my network but that doesn't make sense because it shows me to control the volume on our Sonos. I just can't connect to the music services or login to Sonos. But if it wasn't connected to the network I wouldn't be able to control the volume, so clearly it's connected.

Userlevel 4
Badge +10

Hi @CassidyNY thank you for submitting a diagnostic report for us.

You can access the Sonos app but not log in or start playback from any of the linked music services, correct?

Are you starting playback though the Sonos app directly or are you using direct control to play from the Pandora or Amazon Music app?

I do see some communication errors that may be resolved by rebooting your router and your Sonos players.

Since this issue is occurring only on your phone, please reboot your phone also.

If this does not resolve the errors, can you include the exact wording of the error message when you try to log into the Sonos account?

Is there an error code number with the playback message when you try to play a music source in the Sonos app?     

 

Jean C,

Rebooting the Sonos hardware itself resolved my issue! I am now able to login to the app and music providers. I can't believe it was that simple, after all this time being frustrated! Thank you for your help.

Userlevel 4
Badge +10

Hi @CassidyNY I’m glad that the reboot resolved your issue. 

Honestly, rebooting the speakers & router resolves a good many playback problems but not all. 

Please don’t hesitate to reach back out to us if you need any further assistance! 

Reply