Answered

Beam: Return to TV Sound


Userlevel 1
Got my Beam today. Got it hooked up to the TV via the provided optical to HDMI cable. Sounds great. Also got it linked to services like Spotify, and I tested playing via AirPlay from my phone, and registered it as a device with our Amazon Echo. Everything works and sounds great. And switching between AirPlay, a built-in service, or Alexa control is as easy as simply pressing play on that method or using the voice control. What I can’t figure out is how you switch back to the TV as the sound source gracefully without using the app, and also while maintaining the previous volume level. If you’re playing Spotify then you go to the Sonos app and return the source to “TV”, the volume control is no longer accurately linked to what the level on the TV thinks it is. So I used the tv remote to turn the volume down all the way but the Beam still had sound coming out. So then I had to use the Sonos app to turn the volume down the rest of the way, at which point the Beam was actually playing the level that the TV THOUGHT it was playing at (zero). Then you could control the Beam volume accurately again with the TV. Strange and annoying. How can I more gracefully deal with this?
icon

Best answer by Ryan S 17 July 2018, 19:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Userlevel 1
Badge +3
Update to above Alexa is now informing me she does not know how to do what I ask and I am asking 'Alexa switch to TV in (living room)'
I then turn the volume up on the TV remote (which is set up to Sonos) and lo and behold I have my TV sound,
But it seems that when I ask Alexa to switch of music first and then ask to switch on TV it does it but reduces the sound to nil and I have to manually adjust the volume to what it was when playing music.
Userlevel 1
Badge +3
I have the same issue and have tried all the recommendations and still Alexa just says ok and continues with the radio station its playing, this is ridiculous I'm having to reboot the whole system just to get the TV sound back on
Anybody help please:@:@
I’m still having this same issue. The solution given by other users is not working for me here in Spain.
If I’m listening tu Tunein radio and ask Alexa to switch to the she will either not reply and do nothing while keep playing the radio, or she will say she can’t do it.
Very frustrating, specially because I don’t know if it’s Sono’s fault or Amazon’s or even mine.

BTW, the apps (Alexa and Sono’s), not very user friendly. The settings menu is just a nightmare for new users.
"Alexa, switch to TV" does not seem to work on my Beam... this is incredibly frustrating. I don't want to enable TV Autoplay - I want to be able to choose different audio sources even if the TV is on.

Update: Got it working w/ "Alexa, switch to TV in [name of room]". Just saying "Switch to TV" doesn't work.
Badge +1
With Beam, just ask: "Alexa, switch to TV." We're looking into if we can get this working on a Playbar or Playbase, but for now it's just on the Beam. You may need to target the device by room name: "Alexa, switch to TV on [room name]."

I live in Denmark and it looks like I cannot use Alexa at all here? If that’s really the case, then how do I switch the sound back to TV?
Hi Leslie M. Glad my fix worked for you as well. Frustrating when things don’t work but great when they do. I’m loving my Beam at the moment. It does everything I want it to. Great product from Sonos.
The solution proposed by Chris Moy worked for me on my TCL 6 Roku TV. I had to turn the AutoPlay off and then on again and pair my Roku remote again. Thank you Chris as I was about to return my Sonus Beam to Best Buy.
I should also mention I used the “Remote control setup” option as well. Good luck.
I had the same problem. I came up with a solution that worked for me. I use the Beam with a LG B6 OLED tv so May not work with other TVs. If you go into settings using the Sonos app then room settings, tap on the name you have given to room settings then select “TV” then make sure tv auto play is on. Or if it is already try turning off then on again. Now if I need to return to tv sound I stop playing music on the Beam just by asking Alexa to stop music. Then I tap on my tv remote volume button and tv sound is restored. Hope this helps.
I have the same issues as you all. Here are the things i've done :

1) Check that the HDMI is on the ARC HDMI on the TV.
2) Sounds has difficulty coming back to TV sound. Then no other option that to Open the Sonos app and click on TV sound like mentioned above. Second option is to leave the TV on with no sound ( Menu of the TV or any other place where no sound is going in the HDMI ) Wait for a few minutes and once you put back a Channel the HDMI arc will sync and recognize you did put sound on.

this is really frustrating and I hope sonos has a plan of fixing that. Indeed, on the PLAYBAR never had this issue ( perhaps the Optical output ? )

Any help ?
Userlevel 2
Badge +1
Eventually I got the Beam back on TV sound. I don't actually think it was anything I did or said though!
After watching for I while I put the TV on standby and the asked Alexa to play the radio. After that I stopped the radio with Alexa and put the TV on with the remote. Again no Beam connection / sound, nothing I say it do will induce the sound to come through the Beam!
Going back into standby and asking Alexa to turn on the TV worked but still no Beam sound!
So, it's repeatable!
This is using the latest Panasonic 50" TV
Userlevel 2
Badge +1
The weird thing is all has been working normally for a few days, then this!
Alexa is infuriating. The app is infuriating!
Before getting the Beam, the Sonos Ones I have were okay on just music.
Perhaps trying the Optical out from TV would fix it? Or can the Beam not switch from music to that?
ARC / voice, another piece of functionally I've paid for I can't use?
I'm having the exact same issue! Infuriating! There's nothing voice command wise or in the app I can do to get the TV to play through our beam.
This is when the TV has been on standby and Alexa has been asked to and successfully played music.
Putting the TV on standby, and asking Alexa to turn the TV on, just gives ok, but nothing happens!

Major mess up this..


I managed to "fix" mine by disconnecting my uhd player from the other hdmi. Not ideal but at least it works. Hopefully be a fix update soon.
Userlevel 2
Badge +1
I'm having the exact same issue! Infuriating! There's nothing voice command wise or in the app I can do to get the TV to play through our beam.
This is when the TV has been on standby and Alexa has been asked to and successfully played music.
Putting the TV on standby, and asking Alexa to turn the TV on, just gives ok, but nothing happens!

Major mess up this..
I've tried all the voice commands suggested and switching the source on the app, none of these seem to work. Then without touching anything after about 5 minutes the tv sound suddenly kicks in. Shouldn't be this delay to switch sources surely?
Try "Alexa, Switch {room name} to TV". I found that this command works almost all of the times.
I’m having the same issue where I can’t switch from music to tv sound using Alexa. I say “Alexa, switch to TV” and also “Alexa, switch to living room TV” but get the same response of “Living room TV doesn’t support that.” I can see the tv in my Alexa app so not sure what’s wrong.
I also played music from my iPhone music using airplay and now I have no way to switch back to the tv sound. There isn’t a way to even switch audio source on the sonos app as the only thing that shows up is the song I just played on airplay
I’m having the same issue where I can’t switch from music to tv sound using Alexa. I say “Alexa, switch to TV” and also “Alexa, switch to living room TV” but get the same response of “Living room TV doesn’t support that.” I can see the tv in my Alexa app so not sure what’s wrong.
Can you try changing the room name Sehrmude? It doesn't too much what you use, but I've found that sometimes that helps a lot. It's a new Alexa feature, so the more it gets used, the better.

I can certainly try that - it is the only room I have configured so it won't be difficult. 😉
Userlevel 7
Badge +26
Can you try changing the room name Sehrmude? It doesn't too much what you use, but I've found that sometimes that helps a lot. It's a new Alexa feature, so the more it gets used, the better.
Using Alexa worked the first time for me BUT, every time since, Alexa responds with: Living Room TV does not support this function. I always have to go to the app and change back to TV using the 'Browse' button (why didn't Sonos didn't use 'Input' or 'Source' as a more universally common control). This is moderately inconvenient when I don't have the phone around and have used Alexa to get to music and expected to be able to use Alexa to get back to TV. TV is SONY XBR65X900F. I have the TV, Beam and Sub connected.. This is my first venture into a 'connected' home and have no other streaming/smart devices that can control the TV. I can turn the TV on/off with Alexa and, as I said, switching back using Alexa worked the first time - so it is confusing why it became unsupported an hour afterwards (when I was trying to teach the wife how to use it).
Userlevel 7
Badge +21
And What to do if you do NOT have Alexa? (From Denmark)
You would need to use the Sonos controller app or desktop software to switch Beam back to TV audio (select the room for your Beam, then go to the Browse list and TV should be one of the choices)... or turn off the TV and turn it back on.
And What to do if you do NOT have Alexa? (From Denmark)
This is a complete shot in the dark, but other devices in your network that may have the ability to perform the function of 'switch to tv'? A Fire TV Cube or Logitech Harmony remote perhaps?