Answered

Beam: Return to TV Sound


Userlevel 1
Got my Beam today. Got it hooked up to the TV via the provided optical to HDMI cable. Sounds great. Also got it linked to services like Spotify, and I tested playing via AirPlay from my phone, and registered it as a device with our Amazon Echo. Everything works and sounds great. And switching between AirPlay, a built-in service, or Alexa control is as easy as simply pressing play on that method or using the voice control. What I can’t figure out is how you switch back to the TV as the sound source gracefully without using the app, and also while maintaining the previous volume level. If you’re playing Spotify then you go to the Sonos app and return the source to “TV”, the volume control is no longer accurately linked to what the level on the TV thinks it is. So I used the tv remote to turn the volume down all the way but the Beam still had sound coming out. So then I had to use the Sonos app to turn the volume down the rest of the way, at which point the Beam was actually playing the level that the TV THOUGHT it was playing at (zero). Then you could control the Beam volume accurately again with the TV. Strange and annoying. How can I more gracefully deal with this?
icon

Best answer by Ryan S 17 July 2018, 19:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Badge +1
With Beam, just ask: "Alexa, switch to TV." We're looking into if we can get this working on a Playbar or Playbase, but for now it's just on the Beam. You may need to target the device by room name: "Alexa, switch to TV on [room name]."

I live in Denmark and it looks like I cannot use Alexa at all here? If that’s really the case, then how do I switch the sound back to TV?
"Alexa, switch to TV" does not seem to work on my Beam... this is incredibly frustrating. I don't want to enable TV Autoplay - I want to be able to choose different audio sources even if the TV is on.

Update: Got it working w/ "Alexa, switch to TV in [name of room]". Just saying "Switch to TV" doesn't work.
I’m still having this same issue. The solution given by other users is not working for me here in Spain.
If I’m listening tu Tunein radio and ask Alexa to switch to the she will either not reply and do nothing while keep playing the radio, or she will say she can’t do it.
Very frustrating, specially because I don’t know if it’s Sono’s fault or Amazon’s or even mine.

BTW, the apps (Alexa and Sono’s), not very user friendly. The settings menu is just a nightmare for new users.
Userlevel 1
Badge +3
I have the same issue and have tried all the recommendations and still Alexa just says ok and continues with the radio station its playing, this is ridiculous I'm having to reboot the whole system just to get the TV sound back on
Anybody help please:@:@
Userlevel 1
Badge +3
Update to above Alexa is now informing me she does not know how to do what I ask and I am asking 'Alexa switch to TV in (living room)'
I then turn the volume up on the TV remote (which is set up to Sonos) and lo and behold I have my TV sound,
But it seems that when I ask Alexa to switch of music first and then ask to switch on TV it does it but reduces the sound to nil and I have to manually adjust the volume to what it was when playing music.