Answered

Audio Technica AT-LP120X Turntable connected to Sonos Five Line-In sounds tinny


I have a Sonos 5 connected to an Audio Technica AT-LP120X turntable with built-in pre-amp.  The sound quality is horrible, what can I try to do to improve it?

icon

Best answer by ratty 7 January 2021, 11:42

I have to say I think you’re rather clutching at straws. Tinkering with tracking weight and cables is a distraction. If a cable was faulty it's highly unlikely the fault would hit both channels.

A tinny, weak sound is characteristic of a phono preamp not doing its job to apply boost and RIAA equalization. 

Find another source and test the Five’s Line-In to make sure that’s okay. A headphone outlet from a phone would do.

View original

16 replies

Userlevel 6
Badge +17

Have you done Trueplay tuning with your Sonos Five? Have you changed the Source Level setting in the Sonos app or adjusted the EQ settings of the Five? Also be sure that the switch on the back of the turntable is switched to “LINE”.

I did the Truepaly tuning.  Source Level is set to Level 2 (A/V Component).  I tried raising the bass n the EQ settings but it didn’t make any difference.  The Loudness is On.

Setting the source level higher to level 10 in ‘Settings/System/[Sonos Five Room Name]’ is a good first option to try as GuitarSuperstar mentions.

Userlevel 6
Badge +17

Is the switch on the back of the turntable switched to “LINE”? 
 

Try setting your Source Level to Level 5.

Yes it is. I get sound but it is like a transistor radio or a tin can and volume is very low. Do you think I should buy a high end cable? The run from speaker to turntable is 25’. 

I turned Source Level up to 10 and the volume is good now but still so much distortion and muffled sound.

Perhaps see the following things to check (in no particular order)...

  1. Check/replace the RCA cable etc.
  2. Damage/worn stylus or bent cantilever etc?
  3. Cartridge alignment?... https://audio-technica.com.au/how-to/align-turntable-cartridge/
  4. Tone arm balance (weight too low perhaps?) See this link... https://thevinylfactory.com/features/how-to-balance-your-tonearm-a-step-by-step-guide/

However I would maybe try a portable player, in place of the turntable, to rule out things and then look towards the turntable itself (if necessary).

Or you can go the other route and try the turntable with another Amp/Receiver, that’s  if you do have access to one.

Are you sure you have followed the advice from @GuitarSuperstar   to make sure the pre-amp is operating by selecting 'LINE' output? This still sounds like the sort of problem you would expect in the absence of a pre-amp.

I agree with John’s line of thought. And have seen cases in the past where it has taken several toggles back and forth of the switch for it to ‘take’ properly. I assume that’s due to a small amount of corrosion on the terminals, but it’s at least worth a shot.

I’ll give it a try back and forth a few times.  It is brand new so I wouldn’t expect that to be the problem.  I am going to try adjusting the weight of the arm too.

 

Tried redoing the tonearm weight and cartridge alignment and no improvement. Still sounds like a tin can. Waiting for a new cable to see if that improves things. 

I have to say I think you’re rather clutching at straws. Tinkering with tracking weight and cables is a distraction. If a cable was faulty it's highly unlikely the fault would hit both channels.

A tinny, weak sound is characteristic of a phono preamp not doing its job to apply boost and RIAA equalization. 

Find another source and test the Five’s Line-In to make sure that’s okay. A headphone outlet from a phone would do.

It has to be the pre-amp.  The OP has still not confirmed that the switch on the turntable is set to provide a line level input to the Five’s line in.

It has to be the pre-amp. 

My thoughts too. I was just encouraging a bit of Troubleshooting 101.

It has to be the pre-amp. 

My thoughts too. I was just encouraging a bit of Troubleshooting 101.

I wouldn’t disagree at all - definitely a worthwhile check

Just realized I left this open. I ended up getting another speaker (different brand) with same turntable and it works perfectly. I had hoped to have the turntable in my Sonos system so it could play throughout the house, but this solution is better than none. Thanks for all the help troubleshooting. 

Reply