Audible Playback Stopping Continually

  • 5 November 2021
  • 7 replies
  • 129 views

When listening to Audible on Sonos Roam, my playback stops randomly. I’ve checked that there’s no sleep timer, and the amount of playback time varies. There are also times when the boom will skip ahead several chapters. I’ll be listening to chapter 1, then suddenly I’m listening to chapter 3. No explanation. 


7 replies

As a guess, I’d suggest it’s a form of wifi interference , but there’s so little information here, it’s hard to be sure. 

I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem the next time, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

It sounds like a wireless interference issue - maybe just try these suggested things to see if it improves the audible playback…

Set the local router to use the least-used non-overlapping fixed 2.4Ghz WiFi channel, try either channel 1, 6 or 11. Ensure the channel-width is also set to 20MHz only. You may have to scan the locality to establish the least-used WiFi channel using such Apps similar to WiFiInfoView.

Check that the routers 2.4Ghz Band and 5Ghz band have different SSID’s/Credentials and just ensure the 2.4Ghz band shows in the Sonos App network settings, so that the more penetrating band is then used by the Roam. 

If you have any other Sonos Products wired to the Router, then set that wired device so it is at least one metre away from the router and also set the SonosNet channel in the Sonos App network settings, ensuring that it is at least 5 channels away from your chosen router channel.

If you are using other wireless access points to the LAN, around the Home, I would suggest that their WiFi is set to mirror your router settings, they ideally need to use the same SSID, subnet, channels and channel width.

See if that then improves the audible playback.

I’m having this issue but it’s only with Audible. I have no problems streaming Audible from my phone when it’s positioned next to the speaker. Or streaming any other service on this speaker or on any other device in the house. I’m using Eero mesh WiFi. 

I’m having this issue but it’s only with Audible. I have no problems streaming Audible from my phone when it’s positioned next to the speaker. Or streaming any other service on this speaker or on any other device in the house. I’m using Eero mesh WiFi. 

Perhaps see if the information in this thread-link assists you to resolve any issues you have with your mesh system…

Sonos on WiFi Mesh

I’m having this issue but it’s only with Audible. I have no problems streaming Audible from my phone when it’s positioned next to the speaker. Or streaming any other service on this speaker or on any other device in the house. I’m using Eero mesh WiFi. 

Perhaps see if the information in this thread-link assists you to resolve any issues you have with your mesh system…

Sonos on WiFi Mesh

This article doesn't tell me anything I don't already know I’m afraid.

Interestingly, this problem only occurs when I use the voice command “Alexa, play my audiobook”. If I play a title from my phone and the then switch it to the Sonos Roam from the Audible app it works fine.

Userlevel 2

I am having exactly the same problem, only when listening to an audio book through Alexa on Sonos. It happens with my Sonos Roam, but also with my other Sonos speakers. Most times I can ask Alexa to "resume the book" and it will restart, though usually it restarts a few minutes back from where it stopped. Usually plays about 5 to 10 minutes, then stops again. If I connect my phone to the Roam with Bluetooth and play the book from the app on my phone, this does not happen, but that only works on the Roam , and I can't do that with my other speakers. 

I am having exactly the same problem, only when listening to an audio book through Alexa on Sonos. It happens with my Sonos Roam, but also with my other Sonos speakers. Most times I can ask Alexa to "resume the book" and it will restart, though usually it restarts a few minutes back from where it stopped. Usually plays about 5 to 10 minutes, then stops again. If I connect my phone to the Roam with Bluetooth and play the book from the app on my phone, this does not happen, but that only works on the Roam , and I can't do that with my other speakers. 

Perhaps try a different WiFi channel on your router. I would go for either channel 1, 6 or 11 and then move your Roam onto that 2.4Ghz band (if necessary) via ‘update networks’ in the Sonos App Settings/System/Network/Manage Networks’. Also remove the 5Ghz network SSID settings (if in the list of Networks) and see if that improves the connection.

Reply