Apple Music - we've run into a problem

  • 17 February 2021
  • 57 replies
  • 2340 views


Show first post

57 replies

I have the same problem, but weirdly Sonos can find my playlists and compilations in my music, but it cannot find artists or albums- I just get the same message “we’ve run into a problem. Please try again” 

it’s really frustrating, as I want to be able to access albums ive saved/downloaded. But Sonos cannot seem to find them. I’ve tried getting tech support from both Sonos and Apple- they both just advised reinstalling both apps, which has not helped. Really hoping someone can come up with a fix for this!

Same problem here. “We’ve run into a problem...” Who’s “we”? I’ve been able to access Apple Music radio and my Apple Music Library for years but suddenly “We’ve run into a problem...” pops up and I can’t connect to the Apple Music Radio stations.

It’s likely some sort of  wifi interference peculiar to your network. I would recommend that you submit a system diagnostic within 10 minutes of experiencing this popup, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Much appreciated. But nothing has changed in my homewifi set up, and no new wifi devices have been added to the home whatsoever.

Sure. What about your neighbors? Other sources outside the home? Do you control all of them as well? 

Wifi interference is not just inside your network, it can be caused by all sorts of things, including those outside your control. And it’s not just wifi devices. I’ve had issues with a microwave causing my signal to drop before, and that link talks about several other things that are not wifi related, such as certain types of phones, etc. 

But even if it isn’t wifi interference, the data in that diagnostic would be likely to help Sonos help you track down the true cause, and hopefully resolve the situation. 

Nope, no homes nearby, but point taken, I’ll check it out. It’s working just now, btw, after  I...touched the play button on my iPhone just like I did the 10x before when it didn’t work!

 

That’s certainly a fair indication of some sort of ‘random’ WiFi interference, whatever the source may be. It can come and go, for sure. The next time you experience it,  I would highly recommend submitting that diagnostic I spoke of, and contacting Sonos directly. As I said, there would likely be data in it that might help. 

Badge

This is 100% a Sonos issue. When picking specific playlists from Apple Music, some generate a we’ve run into a problem message, but not others.

So for example New Music Daily, gives the message, but Future Hits, doesn’t. Yet both playlists work on Apple Music app no problem.

I’m having this same issue and nothing has changed on my network.  
move had nothing but dumb issues like this with Sonos. I have two of their speakers and for me it’s probably going to stop there.  It seems like issue after issue and it’s always someone else’s fault. Kind of a bummer deal for a premium product. 

I’ve suffered with the same issue for about a month. I’ve tried all of the suggestions put forward by the sonos team, but none of them has succeeded in solving the problem. I am a Sonos customer of long standing, this is by far the worst supported issue in 15 years. Sort it out Sonos team.

I’m also one of many with the same issue. Worked spotlessly for years (regardless changes to my network) until a few months ago and now I can only access my playlists through MySonos menu, but nothing through My Music. This poor excuse of network interference, if that was the case then surely it wouldn’t work via the MySonos menu either. 
Needless to say, all works like a charm with the Apple Music app. 
 

Come on Sonos, step up and fix this!

With the lack of any meaningful help from Sonos. Has anyone else found a solution that worked? Thank you in advance of a positive response.

Same issue just started for me this morning after working fine for years. One thing to note is that my Eero Router updated last night , so that might be a bread crumb to follow. Have been reinstalling, rebooting, re-signing in to Apple music apps etc to no avail. But all indications are that something funky is happening because of that router update. Are other people here having issue using Eero as well?

Badge

Obviously still a problem. It’s probably been a year since I first encountered it. Everything was working fine this morning and now after returning home, I’m having this problem with the “For You” section of Apple Music. No problems with “Recently Played” or “Recently Added”.

The Sonos app is generally just flaky and I’ve (tried to) learn to accept it. One minute, Sonos Playlists are missing but Apple Music works great. A few hours later, Sonos Playlists are back but parts of Apple Music are broken. I guess you can’t have both, you just have to be happy with whatever the app serves up! Wireless interference and Internet issues are often cited as potential causes (and indeed they were, in the first few posts in this thread!) but maybe it’s time for the Sonos app to be rewritten from the ground up to fix these kinds of random issues and stop being so flaky. Super frustrating.

 

Same problem for me too. Can’t get anywhere with Sonos support - one person dropped me after trying lots of different options then the next told me I needed to phone up (as I don’t think she knew anything else to try). I’ve spent all afternoon trying to sort this and I’m not getting anywhere. PLEASE SORT IT OUT SONOS! I was about to upgrade, but looking at other options now…. :( 

I have had the same issue for more than a year. Same problem using S1 and S2. Same problem in 4 different apartments in two countries. NL ans US. 

@ryancarpenter27 No, the problem still exists and Sonos support has not been able to help me. Sonos is blaming the problem on Apple and Apple has insisted there is nothing wrong with my account (and I believe them). There is something wrong with the Sonos software and it is not authenticating correctly. Maybe it will break for enough people and they will have to address it at some point. 

Sonos is worthless. Worked for less than a year and they made all kinds of excuses why my speaker wouldn’t work.

same issue here, ever since we started using apple music. “we’ve run into a problem, try again”. all iOS devices and the Windows app controller as well. All apple music can be searched, but My Music does not work. 

One question I would raise is if all theones with the same issue are having a family account as well? i.e. I am the “owner” or parent in our setup, but the apple music subcription is a family sub. and we had issues prior with apps to port the former Spotify playlists. But what happened there was that the “child” apple music accounts work on iOS devices without a hitch, but any other apps cant properly use them. 

So my gut feeling is that is has maybe to do with that...

Same issue for me. Im on a family plan too (owner). I logged in to my sonos app with my wife’s apple id and all her music showed up. 
 

i do have some of my friends music ripped from youtube and added to apple music manually. These are foreign songs and not available on apple music. I do have quite a few of them. Iv tried every other suggestion mentioned in this forum but nothing has worked. Just wondering if anyone else with the issue has music ripped and added to apple music? Maybe its a copyright issue? 

I’ve had this issue for around 6 months now too, started as soon as I switched back to Apple Music from Tidal.

The problem: For me, the issue is isolated to “Apple Music → My Music → Artists” and “Apple Music → My Music → Albums”. The precise error message is “We’ve run into a problem. Try again.”

SONOS TEAM: this is NOT a wifi issue. This is a software bug that needs to be raised with the appropriate product manager. The fact that Playlists and the Songs are both working perfectly fine makes this glaringly clear to anyone familiar with the Apple Music API that there is bug in the code specific to the Artists and Album routes. This is not an account issue or a broad authentication issue, since every Song in the account can be returned perfectly fine under “Apple Music → My Music → Songs”. Happy to get into more detail with the PM if you want to have them reach out to me.

There’s a few recurring themes and my guess is that they are affecting something in the code for these routes — for example, many of us have changed the country associated with our account. This could be stored incorrectly somewhere and causing an issue.

Really hoping the team at Sonos can step up to the plate and raise this issue to the product manager. It’s really frustrating that this is simply being ignored, as it’s ruining a large part of the Sonos experience for many of us.

Hi everyone. I Just wanted to say that I too am having the exact same issue as described above. Browsing Artists and Albums does not work, but everything else seems to.

One thought that popped up: Could this be related to my Apple Music Account being part of my Apple One account (The one that includes TV+ and Arcade as well)? Just trying to narrow it down a bit.

Do you all have just an Apple Music subscription or do you have an Apple One subscription?

Hi All,

Thus has just started happening to me after years of fine performance. FIX IT SONOS!

Userlevel 5
Badge +8

“WiFi issue” seems to be the Sonos support answer to everything.

There are clearly problems between Apple Music and Sonos. Sonos needs to get a clue and implement a proper Problem Reporting and Tracking system that’s available to support agents. Then they could do the right thing and say “yes, that’s a known problem, and our crack development team will get around to working on it any year now”, instead of wasting everyone’s time with pointless diagnostics.

I have this issue with the ‘For You’ section in Apple Music.

I can categorically state this is NOT a WiFi issue, because all my speakers are hardwired in via Ethernet. @Sonos get your act together and fix this issue.

Same error here. Have reported twice to support, and also tried all suggested wifi fixes. Most speakers connected via ethernet cable, no change.

Reply