Apple Music Service no longer working after Sonos update 14.12


Have been using Apple Music Service thru the SONOS app (S2) on my Android phone without issues (for many years). Yesterday my Sonos updated to latest software (14.12) and now I am unable to browse any content in Apple Music. Removing and resinstalling the service fails to resolve the issue - It gets stuck in a cycle of continuously requesting the service be reauthorized. Called Sonos and had 2 very frustrating calls. First support agent told me it was an Apple problem and to call Apple. I think everyone could predict how that would turn out! Apple verified my account and confirmed I could access their service thru the Apple Music App. There was nothing on their end they could address. Called Sonos back and went thru the same painful process only to eventually be told it is a known issue on Android devices - Really it took an hour and a half of my time for Sonos to then admit that! No solution. No ability to roll back the update. I was provided a case ID, but when I asked for a Ticket number for my unresolved issue, I might as well have been speaking Martian! Very disappointed with Sonos support.



13 replies

Since there’s not thousands upon thousands of similar complaints here, I’m going to hazard a guess it’s a local network issue, of which we’ve little information on from your post.

One of initial things that you may have tried, but is unclear, is a simple reboot and network refresh. Unplug all your Sonos devices from power, and then reboot your router. Once the router comes back up should you plug back in the Sonos devices.

Frankly, after that I’d probably try another round of removing the service from Sonos, and waiting five minutes before adding it back in.  The first process will have reloaded the software for both Sonos and your router, and the extra step may potentially clear the issue.

As to the “android issue” you speak of, I’ve seen a few comments about needing to reset up the Apple application on the android operating system, but honestly have seen that in months. 

For more help, you’ll probably need to give us a bunch more information about your system, your network, and the device you’re using the controller on, and which Android version it is running. 


To just add to what Bruce mentions here... 

When I had a similar issue with the Apple Music Service on Sonos, albeit a while ago now, Apple (not Sonos) Customer Support had me sign-out of their media services (Apple music) and remove their Native Music App from all my devices and remove everything else where I was signed in with my AppleID.

I also removed the Apple Service from the Sonos App and rebooted all (router/speakers etc.) .. before reinstalling the Music App and the AM service in the Sonos App. It didn’t work at first and Apple Support escalated my issue for an engineer to call me back.

Whilst waiting for that call-back, the next day it suddenly started working, but not sure if what I did fixed it, or if it was something Apple did to my account behind the scenes.

Anyhow I let them know it was fixed and it’s been working okay on Sonos (and everywhere else) ever since.

So perhaps see if the same thing might work for you… nothing ventured etc.


I run Sonos using the Sonos Boost plugged directly into my Router. I have several other music services (Amazon, Deezer, iHeart etc ) and they all work perfectly. There is a similar thread in this section, but apparently for those expereincing the issue (which is identical to mine) the problem eventually resolved itself.


I have an Samsung S21 phone using Android version 12



same issue as phmkingston - have an android phone, just updated to sonos v 14.12 yesterday and can’t browse music on apple music in sonos now. i’ve tried removing & reloading, refreshing the router, etc, no success. talked to sonos tech support this am; they are aware of it but he had no info on timeline for a fix. pretty frustrating. 

Userlevel 4
Badge +6

I have exactly the same issue as the OP. Apple music has to be reauthorised but it's just an endless loop and nothing changes. Uninstalling the apple music app from the phone didn't help. I'm also on an android phone. 

Have you contacted Sonos Support? 


Well I take some comfort in knowing I am not the only one!. Never the less it is no less frustrating.


Seems really odd to have so few posts about this issue. I’d certainly recommend to each of you that you submit a system diagnostic within 10 minutes of getting this error show up, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Frankly, the more hard data that Sonos has, the better their ability to track down what’s going on, if it isn’t just something local. 


Read from the top of the post. That has been done! More than once.....


The variables in play are small


1. S2 on Android

2. No problem before 14.12 update

3. For me I use Apple family plan

4. Identical problem reported by many about 1 month ago when the Apple interface within Sonos changed.


Sonos apparently admits they are aware of the problem


I am hoping for a quick fix



Yes, you have. But there is no indication that any of the ‘me too’ folks have done so, other than @lc22. And anyone who has read this thread, but not posted should be encouraged to contact Sonos as well, even if they prefer not to post on this community forum. 


There is a fix. You need to login using an IOS device. My issue was that I have a family plan. My wife has an IOS device but when I would use her device to log on, by default it would use her Apple account. There was no way to bypass this unless she logout out of her IOS apple account and I signed in with mine. Then when I added the Sonos Apple Music Service it would use my Apple Music account. Aceessing thru my Windows PC or my Android now works! Hope this helps others.