Question

Apple Music content is missing from Albums


Userlevel 2

A couple of days ago I went to play an album from my Apple Music library though my Sonos Connect, and could not find it. Looking more closely, I noticed that the “Albums” menu item only contains a tiny fraction of my music library - almost everything is missing. “Recently Added” and “Playlists” both look OK, but “Albums” is bad. I see the same on several controllers: Windows, Mac, iPhone, iPad are all the same.

Moreover, in the Windows application, when I visit “Albums”, I can browse it for a short time, and then the application terminates (the window just closes with no error message).

My library looks perfectly fine in iTunes and the native Apple Music app.

I left it a few days in case it was a transient effect but it persists.

I have tried removing the Apple Music service from my system and reconnecting it afresh, but this does not help.

I probably need a Sonos support case for this but the web site suggests that I try the forum first. I generated diagnostics 641008197 in case it helps anybody.


45 replies

Userlevel 4
Badge +13

Hi @m1maj.

Welcome to the Sonos community and thanks for reaching out to us.

I would like to thank you for doing the extra mile on submitting the diagnostic.

Based on the submitted diagnostic, It shows some playback failure and audio playback stopped issue due to not enough bandwidth provided from the router via internet connection.

I would recommend the following basic troubleshooting steps:

  1. Reboot the router by unplugging it from power and plugging it back after 10-15 seconds to refresh network connectivity and delete temporary data stored on the router.
  2. Reboot your Sonos Connect.
  3. Force close and re-open the Sonos app
  4. Test if the issue persist.

After doing the basic steps above, if the issue stops then we’re good. If not I would like to recommend the following steps.

  • Open iTunes on the computer.
  • Select Songs from the left side option on iTunes.
  • Beside the song title, there is a cloud icon. click on cloud icon and then click on the cloud figure icon on all songs with cloud icon beside their corresponding title. This is to download the songs to the computer since that indicates that the songs are not on the computer but is on iTunes Cloud.
  • Once all cloud icons have been clicked and removed, Remove music library from the Sonos app.
  • Re-add music library from the Sonos app.
  • Test to see if everything works.

Please let me know how it goes. We are always here to help out.

Thanks,

 

Userlevel 2

Thanks for your suggestions. I’ll go through your points:

 

It shows some playback failure and audio playback stopped issue due to not enough bandwidth provided from the router via internet connection.

 

That is interesting. I think this must have been a transient effect. My internet connection is in general very good (Virgin Media cable at around 350Mbit/s) and I don’t normally have a problem streaming audio and video streams. There have been a few short-lived problems recently, but at the moment it is working very well.

 

Reboot the router

As it happens, my router rebooted the other day for unrelated reasons, and it didn’t have any effect on this problem.

 

Reboot your Sonos Connect.

I’ve done that just now, to no effect.

 

Force close and re-open the Sonos app

The problem isn’t related to any particular instance of the Sonos app. At various times I run the controller on my iPhone, my iPad, a Macbook and a Windows PC. They all show exactly the same problem with the view of Apple Music, notwithstanding app restarts, machine reboots etc. The problem remains.

 

Regarding your “further steps”, I think you might have misunderstood what my problem is. My problem does not relate to the music library on any particular computer on my network. In fact the Sonos access to my local music library is working perfectly and shows all of the music that is stored locally.

The problem relates to the Sonos view of my Apple Music library as served over the internet from Apple, i.e. choosing “Apple Music” as the service I wish to use, and then navigating to “Albums”. My Apple library has 3 kinds of item in it:

  • Music purchased through the iTunes store
  • Imported music which is available by virtue of iTunes Match (either “matched” or “uploaded”)
  • Items from Apple Music added to my library under my Apple Music subscription

My entire library is visible from Apple’s native Music app. But from the Sonos interface, although I can see examples of all three categories, only a tiny fraction of what should be there is visible. Moreover, the alphabetic splitting is mixed up. Let me show you a screenshot:

 

 

You will have to take my word for it that the list is incomplete, but you can see at a glance that this listing is anomalous. The first item begins with “A” but is categorised under “#”. Then everything else (all the way to the end in fact) comes under “A”. This looks essentially the same on all devices.

I should say, by the way, that it used to work properly. I only bought my Sonos Connect when you started supporting Apple Music, and it was my main reason for buying it, as an interface to play my Apple Music library through my legacy analogue sound system. It was all working very well. Until a few days before my posting, I could see my entire library. I sometimes had issues with searching for what I wanted, but it was all there. Sometimes I would see an occasional track “greyed out” for no obvious reason - I intended to report that at some point but for the time being was living with it. But this incomplete Albums listing makes the facility nearly unusable.

Does this clarify my problem?

 

I have the same issue. I only have two sonos ones. On all controllers (mac / ipad / iphone)  I only see the same subset of the albums in my apple music library. In the Sonos app I see 84 albums, while I have 630 albums in my apple music library.

 

Two strange thing:

  1. The albums are showing when I go from apple music → My Music → Artist. When I select an artist, I see all the albums from that artist that are in my apple music library (cloud). When browsing via my Music → Albums, a lot of these albums are missing.
  2. When  browsing by artist or by album or by number. The letter dividers are wrong.

Hope this is solved soon.

Userlevel 2

The albums are showing when I go from apple music → My Music → Artist. When I select an artist, I see all the albums from that artist that are in my apple music library (cloud). When browsing via my Music → Albums, a lot of these albums are missing.

 

I can confirm that I see that too. Everything seems to be there under “Artists”, and “Playlists” are fine too. I’m not sure about “Songs” as I don’t find it generally useful. I think the problem may be confined to “Albums”.

Userlevel 4
Badge +13

Hi @m1maj.

Thanks for the detailed feedback that clarified everything.

upon checking out internal articles about this issue, I came across the following recommendations.

  • I recommend to use search for the particular Album within Apple Music-> My Music -> on Sonos.
  • You should then see the respective Album in their library and be able play it.
  • I would recommend subscribing to this thread for future updates from Sonos.

Just to set your expectation, I will be morethan happy to report this to our engineering team for collation. Please keep an eye out on this thread for updates regarding possible resolution or fix to the problem.

Please let me know if you still have further issues or concerns. We are always here to help.

Thanks,

Userlevel 4
Badge +13

Hi @douweh.

Welcome to the Sonos community. Thanks for reaching out to us.

Please be guided of the post above and let me know if you still have further questions or concerns. We are always here to help out.

Thanks,

Userlevel 2

I recommend to use search for the particular Album within Apple Music-> My Music -> on Sonos.

 

Thanks, that does seem to work, but often the simple alphabetic list is more convenient. I am usually looking for classical music albums, where searching often brings up many different versions of the same work. I’ve got used to just looking down a list of familiar album titles.

The fact that search works seems to suggest that the list of albums in the library is being picked up correctly from Apple, but just being displayed wrongly.

 

I will be morethan happy to report this to our engineering team for collation.

 

Thank you, please do.  As I said, this facility used to work perfectly and has only recently gone wrong, so presumably a bug has crept in somewhere.

 

 

Userlevel 4
Badge +13

Hi @m1maj.

Thanks for the immediate feedback.

I have already shared this thread to our engineering team. Please subscribe to this thread so that you will be notified once the issue has been resolved.

Please let me know if you still have further questions or concerns. We are always here to help.

Thanks,

I have the same problem. I’d like to subscribe to the thread but it’s not at clear how to do that. 
 

how do you subscribe to a thread?

 

I have the same problem. I’d like to subscribe to the thread but it’s not at clear how to do that. 
 

how do you subscribe to a thread?

I also have this problem with missing albums which appeared to coincide with the latest upgrade release.  It’s not obvious how to subscribe to a thread however I appear to have done this by clicking the “Add to Favorites” button in the original question.  You can check that you are subscribed by clicking your account icon in the top right of the page and it should show the number of your subscriptions. 

I have the same problem. I’d like to subscribe to the thread but it’s not at clear how to do that. 
 

how do you subscribe to a thread?

On the first post in the thread, there’s a ‘add to favorites’ that you would click on. 

Thanks. 

Add to Favorites only appears if you’ve logged in - which does make sense, I guess.

Ah, yes. Hard to subscribe if the forum doesn’t know who you are ;)

Badge

I have this problem too - the “Albums” menu item only contains a tiny fraction of my music library - almost everything is missing.

I have subscribed - waiting on a fix.

Userlevel 2
Badge +2

I also have the same problem. Within Sonos, my albums (Apple Music) shows only 3 albums. It used to show all of them. Will subscribe & hope for a fix. Thanks

Badge

Similar problem, within Sonos S2, my albums view of Apple Music shows “No selections are available.”  I can see my Apple Music under Artists or Songs just nothing under albums.  As with others, the albums are searchable and play just fine.  I just can’t see a list of them.

 

I also have this problem.  The My Music > Albums path only shows a fraction of the albums I have uploaded - 80/1,345.  This means browsing for an album is impossible.

The problem is the same on iOS (iPhone & iPad) and MacOS.  Browsing using Artists is OK - though I haven’t counted every Artist/Album combination!  I’ve recently ‘upgraded’ to the SONOS S2 apps.

 

Hopeful for a resolution quickly as this is the main way that I play my music using my SONOS Connect and my Hi-Fi system.

Same Problem for me. I think the problem appears after upgrading to sonos S2.

Really annoying, I constantly use the album view for choosing my music.

Please fix this !

I think you’re right. The upgrade to S2 was the only change recently.

However, in recent days the problem seems to have been resolved - or at least has got a lot better. I now have access to a lot more albums using that method of browsing. Can’t tell if I’ve got access to all of them (too many to count) but certainly a lot more.

I’m using S1 and have the same problem.  I listen to classical music and the best way to use is through albums.  It’s very frustrating.  Any news on the fix?

Userlevel 4
Badge +13

Hi @peterthewolf.

Welcome to the Sonos community and thanks for reaching out to us.

I have already shared this thread with our engineering team. Please subscribe to this thread so that you will be notified once the issue has been resolved. The engineering team is still working on this issue.

Please let me know if you still have further questions or concerns. We are always here to help.

Thanks,

Is there an update on the thread please? I have exactly the same problem described perfectly by m1maj above. In case it helps, when using the windows S2 app, if I scroll to the bottom of the (much shortened) Albums list, it crashes every time. 

Userlevel 4
Badge +13

Hi @Simon M.

Welcome to the Sonos community and thanks for reaching out.

Just to set your expectation, I would suggest subscribing to this thread and our announcement topic for any feature releases, bug fixes, and updates. This thread will be updated once the feature request has been addressed and the same information would be posted on our announcement topic.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

 

Same here, also removed Apple Music account and reauthorized but same thing. I really wish this isfixed, thanks.

Userlevel 2

Just to set your expectation, I would suggest subscribing to this thread and our announcement topic for any feature releases, bug fixes, and updates. This thread will be updated once the feature request has been addressed and the same information would be posted on our announcement topic.

 

 

With respect, I don’t think it is reasonable to describe this as a “feature request”. It’s a bug. It used to work, and now it doesn’t. The current behaviour is self evidently wrong. It’s a bug which affects the core functionality of the product. It shouldn’t take this long to fix it.

Reply