Question

Apple Music - can't connect

  • 3 October 2020
  • 18 replies
  • 565 views

Hi there, for the past couple of weeks I’ve been unable to connect to Apple Music. “We’ve run into a problem. Please try again.”

 

Tried signing out of Apple Music, reinstalling sonos app etc. No luck.

 


18 replies

Userlevel 5
Badge +15

Hi @User262360.

Thanks for reaching out and I appreciate the troubleshooting you did, let me help and try to figure this out.

Is this the only music service you’re experiencing the issue?

Was there any change made on the network recently or a power outage?

Have you tried to remove and add back Apple music service in the Sonos app?

 

Kindly submit a diagnostic report through the Sonos app when the issue occurs, and reply with the confirmation number.

I'd start by reviewing your system as well as the status of the devices, it will also help in identifying what's possibly causing the issue.

 

I’m looking forward to assisting you further from here.

If you have any other questions or run into any issues,  please do not hesitate to reach out,  we are always here to help.

Hi there,

I am also having the same problem. I can load other streaming services with no problem.

wvery time I try to load the Apple Music service I either get “make sure your Music app is updated to the latest version” which it is, followed by “we’ve run into a problem, please try again”.

I submitted a diagnostic report, number 396044011

this is very frustrating.

thanks,

Mick

Badge

I can confirm I have this same problem.

I discovered it because I noticed that updates I was making in Apple Music were not appearing on Sonos. For example, I added two playlists, and they did not appear in the Sonos app.

Therefore, my plan was to remove the service and re-add it, forcing an update, but now I cannot reconnect to Apple Music at all, as I get a “We’ve run into a problem, please try again” error.

Please let us know when a fix is coming!

Badge

Is anyone here running a beta version of iOS by chance? I’m running 14.2 beta, so maybe it’s connected to that???

Sonos rarely plays well with Apple beta OS’s. I suspect it’s something in the beta code or server back end, as as soon as they go gold master, it suddenly starts working, with no updates from Sonos involved. 

Is anyone here running a beta version of iOS by chance? I’m running 14.2 beta, so maybe it’s connected to that???

On one of our phones yes, on the other no, so that doesn’t seem to make a difference,

I’m having the same problem, just started today. Running iOS 14.01. Is there a fix?

I’m having the same issue. Started about a week ago before updating iOS to 14.01. Also looking for a fix, anyone have one yet? 

No further responses from the folks at Sonos, one would have hoped they would have a fix by now.

Userlevel 5
Badge +15

Hi everyone. Thank you for your patience in this.

It will be helpful to submit a diagnostic report on the Sonos app when the issue happens and reach out to 

Sonos Support as we can take a closer look and discuss it with all of you individually in real-time. 

I recommend our phone team, for they have more resources available for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the computer/controller to see what's going on.

 

If you have any other questions or concerns, feel free to reach out, we’re always here to help.

338875149
 

unfortunately it’s still occurring! S1 and S2

Phone support is a pain - can Sonos please start offering email support again?

Badge +1

I'm having the same issue with my Apple music account. I have a family plan and my partner can log into her Apple music account on the Sonos app, but I can't. 

I'd updated my Apple ID password yesterday and I believe this is why it won't work. The Sonos app doesn't seem to recognise that I've updated my password.

same issue here, diagnostic code 44988101

 

error logs say a series of “unable to browse music - there was a problem connecting to apple music” messages and then a series of “we’ve run into a problem, try again”

 

i have removed and added the apple music service, reauthenticated. happens on my home network and when on VPN for work, has been consistent since iOS14 update, perhaps earlier.

The VPN should be blocking the ability of the speakers to reach out to the Apple servers. 

You also may want to try a reboot of your router, but that won’t change the VPN issue. 

to clarify, my computer where i was running the sonos controller is sometimes on VPN. the speakers have their own network connection and are never on VPN. regardless of the VPN status, the issue is the same

Ah, that wasn’t clear. Still, you should at least try a reboot of your router, followed by a reboot of the speakers. In the meantime, I’ll wait to see what the diagnostic suggests. 

Any update? Also having the same issue (diagnostic info to be sent).

Reply