Answered

Amazon streaming music broken with last update?


After updating my sonos app two days ago Amazon streaming has fallen apart. About 75% of my 20,000+ songs on the amazon cloud will not play through Sonos.

I mostly get the error "That song is no longer included in your Amazon Music streaming service. Please try another song." though every 5-7th one gives me the "Unable to play 'XXX' - the song is not encoded correctly." error.

These are purchased and uploaded songs, not free prime or unlimited songs. They stream and download perfectly through Amazon's mobile app, web browser, and desktop players.

I have reauthorized my Amazon account through Sonos with no change. I have removed the Amazon service and re-added it completely to Sonos with no change. Before and after those steps it is the same songs that play and fail.

The songs failing today played through Sonos three days ago, before I updated. What is the next step to correct this?
icon

Best answer by Smilja 18 May 2019, 10:34

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Userlevel 1

Hey, it might actually be more helpful if you were to submit a system diagnostic within 10 minutes of experiencing this issue, and either post the number here, or contact Sonos Support to discuss it.

I usually suggest the phone folks, they have more tools available, but are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

But even before you do that, I'd try at least a reboot of your router, and then your Den set of speakers.

Same problem here...still. I have been frustrated with this for probably 8 months, too.

Some replies say the issue has been fixed.

Why are some, apparently, resolved of this issue? Glad for them. Sucks to be me.

Have you tried the suggestion I wrote about five months ago, in the post immediately before yours?

Hi, airgetlam-

I have performed the usual...rebooting, install/uninstall, reload Song Library, etc.

Spent about 2hrs in a chat with 3 Amazon techs; they tried but nothing changed.

i will probably try a phone call with Sonos. 

Thanks for your input.