Question

Amazon Music Unlimited Titles Not Found in Desktop App Only


Userlevel 5
Badge +9

I recently discovered that any music searches in the desktop app for artists or albums available through Amazon Music Unlimited will give me the message shown in the attached. My sample suggests that only non-unlimited artists and albums are available.

This problem is NOT present in the mobile app, regardless of the network used. I can play any of the albums (i.e., Halsey's Manic) if I initiate playback from the phone, but the desktop app can't find them.  

Note that I recently transitioned to S2, and all apps, including the desktop app have been updated.

So far I have tried:

  • Reauthorizing my Amazon Music account
  • Removing and re-adding my Amazon Music account
  • Disabling Windows Defender & Malwarebytes
  • Powering Down & Rebooting Everything
  • Banging my head against the wall.

My wife and I manage most of our playlists via the desktop, so this issue (which was never present before) is a major annoyance for me.

Any suggestions or solutions welcome. Hopefully, I’m missing something obvious…

 

 


16 replies

I would maybe try resetting the App itself and connecting it back to the ‘existing’ S2 system and just see if that works.🤞

Userlevel 5
Badge +9

Ah, should have mentioned that I removed and reinstalled the desktop app as well.  But thanks for the suggestion!

My only thoughtS now are the firewall/security/connection you maybe using on the PC .. I have the same Amazon search working here, so it’s unlikely going to be the sonos App. So maybe look closer at the PC security itself… Hope that assists.👍

 

Userlevel 5
Badge +9

That was one of my thoughts as well, but I’m only using Windows defender (and sometimes, Malwarebytes) and as I noted I disabled both with no improvement.

That was one of my thoughts as well, but I’m only using Windows defender (and sometimes, Malwarebytes) and as I noted I disabled both with no improvement.

I believe those apps are mostly just anti-malware protection, how about your PC’s firewall, have you tried configuring that, or switching that off too?

Userlevel 5
Badge +9

That’s incorrect.  Windows Defender is the firewall.

That’s incorrect.  Windows Defender is the firewall.

Ah right, okay. 👍

Userlevel 7
Badge +21

Check your language selection, the Amazon SMAPI service is very sensitive to locale. Check the language option in the app and in Windows.

Userlevel 5
Badge +9

Both English.

Master T,

It must be something related to the PC as the other controllers are working okay, from what I’ve gleaned so far, at least.
 

When you disable Windows defender does it allow the Windows built-in firewall to take back control I’m just thinking to check that and also reboot the PC after disabling the firewall and on restart just ensure they are still ‘switched off’ and perhaps then see if the seach might work,

Also ensure that your Windows network profile is set to ‘private’ as mentioned in this link…

https://support.sonos.com/s/article/813?language=en_US

@Ken_Griffiths, Windows Defender is the built-in firewall/virus protection; I have never had any issues with it re the Sonos Controller.

 

@Master T, Is the Amazon Music Desktop Application installed on the PC? If so, logging out → logging in may be worth a try.

Userlevel 7
Badge +21

Both English.

Which English though? The Amazon service works fine with en-US but balks at any other en- values. It is possible the code that turns other-English into en-US was forgotten in the S2 app.

Try my app, if that fails I can diagnose it. (See my profile for the link).

Userlevel 5
Badge +9

Master T,

It must be something related to the PC as the other controllers are working okay, from what I’ve gleaned so far, at least.

That’s high on my list of possibilities, although everything worked properly for years, and the only change that was made to the computer in the past two weeks was the installation of the new S2 desktop app.  So, the S2 Desktop App and/or a Sonos/Amazon account issue both remain suspects as well.

Also, my Windows Network profile is set to private and always has been.

 

 

@Master T, Is the Amazon Music Desktop Application installed on the PC? If so, logging out → logging in may be worth a try.

No, it is not and  never has been. 

 

Both English.

Which English though? The Amazon service works fine with en-US but balks at any other en- values. It is possible the code that turns other-English into en-US was forgotten in the S2 app.

Try my app, if that fails I can diagnose it. (See my profile for the link).

The Sonos app only has English. The Windows desktop is and always has been English U.S.  (I am in the U.S.) 

I’ll take a look at your app.

 

 

Userlevel 5
Badge +9

Also, @Ryan S any ideas?

Userlevel 5
Badge +9

Well, I’m not quite sure what I did, but it’s working again. I logged off everything (including Amazon, etc), uninstalled the Sonos app, fully powered everything down (the PC, speakers, and router), ensured I had the latest Windows updates installed, and did a little good luck dance. 

It must have been the dance. 😉

Thanks to everyone who contributed. I don’t work in IT, but I’m fairly knowledgeable with computers and can usually find the problem (most often, it’s me). This glitch still has me a little baffled, but whatever.

 

Reply