Always Group Rooms with Airplay

  • 19 January 2020
  • 6 replies

Until recently I had a number of Sonos devices but only one of them was Airplay compatible. All devices are always grouped as Everywhere. When I play sound on an Apple Ipad it would automatically be distributed to all Sonos devices. This is great. Sonos is ecouraging owners to trade up to newer devices that are Airplay compatible. So I now have 3 Sonos devices which are Airplay compatible. But now when I connect to the same Airplay device that I previously did the sound is no longer passed to all devices. The 2 new Airplay devices are removed from the Everywhere group. Why is this happening and how do I stop this? I just want all the devices to be in one group.

6 replies

Badge +1

Does anybody know how to fix this?

Go to ‘Sonos app → Settings → System → Airplay’ and toggle on ‘Group Non-Airplay Speakers’.


If you want the Airplay stream distributed to these 3 Airplay-enabled Sonos speakers only, tick them off in the Airplay menu on your iOS device.

I already have this toggled on. On my system this causes the non-airplay compatible speakers to remain grouped to the selected airplay compatible speakers when audio is played from the Apple device. But the other airplay compatible devices are dropped from the Everywhere group. How do I keep all Sonos devices grouped Everywhere? When I only had one Airplay device eveywhere meant everywhere.

You have to tick off all 3 Airplay-enabled devices in the Airplay menu before starting playback.



Right that does now work! I am sure I tried this previously and selecting a second airplay device toggled the first off so only one worked? But now I can select multiple airplay devices. It’s going to be a bit tedious when there are even more sonos airplay devices. Imagine if you only had airplay compatible sonos devices? I have 9 devices and the convenience of Sonos is somewhat diminshed if I always have to tick loads of boxes. One solution would be the facility to disable the airplay feature in a device. Then you could set your system so that only one airplay device existed and just connect to that one device and have all other Sonos devices linked as non-airplay compatible.

Airplay ist a proprietary protocol developed by Apple, the aforementioned Airplay menu is embedded within iOS. Sonos can’t alter the way Airplay is working.