All tracks in music library now in alphabetical order


Badge
For some reason, all of my album tracks are now listed alphabetically instead of by track number. Any ideas as to why and how to fix?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

53 replies

Which library view are you looking at? If it's the Folder view you need to change the library option to view tracks by track number. If you're in, say, the Artists view you're probably looking at the 'All' item for the chosen artist.
Badge
Already changed the order in music library settings to sort by track number. This action did not work.
That only affects the Folder view, which is why I asked ....
Badge
Do you know if there is a solution to this issue?
Userlevel 7
Badge +21
It's not normally am issue. What version of the app are you on?
Badge
Newest, I assume. "No updates are necessary." Same with PC version.
Userlevel 7
Badge +22
Is this on a PC? If so, could be a side-effect of the new http-based file sharing that replaced the SMB one.
Userlevel 7
Badge +21
Newest, I assume. "No updates are necessary." Same with PC version. but what version? 8.6? You can check in settings, about my system.
Badge
The same thing is happening with the mobile app; it doesn't matter which device I use to play music.
Badge
It is version 8.6. Thank you for your help, BTW.
Userlevel 7
Badge +21
Thanks. My theory is out then 😞

More investigation:-
What source is the music coming from?
When did this start happening?
Have you made any other changes to your PC or music source?

This is odd.
Drill down Artists>(Artist)>(Album) and look at the track list. Are there numbers down the left side? If not, try removing and re-adding the network share, so as to force a full re-indexing.
Badge
How would I re-add the network share? The source is - and has been from the beginning - a laptop hard drive.
Badge
Are you suggesting I remove the files from the computer? Or simply Sonos?
Just go into library settings and remove the share from Sonos. Add it back again and Sonos will re-index everything.
Badge
I removed the shared music folders from Sonos and re-shared them. This did nothing to change the issue.
Backing up to an earlier question, when you go to Library>Artists, then select an artist, then select an album, are there any numbers against the tracks?
Badge
There are no numbers in front of the tracks.
Submit a diagnostic and post the confirmation number. Sonos Support can look and see if the index actually contains track numbers.
Badge
Will do. Thank you.
Badge
hi all, this is an issue for me too. as described by the OP, all of my tracks are now displayed in alphabetical order since the last music index update. this was the first i've done since the most recent application update. i'm running 8.6 (build 43354030). are sonos aware of the issue and is it affecting others?
Userlevel 1
Badge
Same problem here. Not sure if it matters, but all of my files are FLAC and I use the "0x/xx" convention for the track number field.

This is very frustrating for someone who listens to 99% local music library.
Badge
Update from me... The problem only seems to be with files I've ripped from CD to variable bit rate WMA (this is approx 90% of my library). The track number is missing from the library view and the tracks are displayed alphabetically. Downloaded MP3 files are still OK and display the track number. This is really annoying for me as I'm an album kinda guy, not one for skipping around playing individual tracks.
Userlevel 1
Badge
I found the problem.

At some point Sonos silently stopped supporting track numbers containing slashes.

After some tag edits and media library refreshes here's what I was able to confirm just now:

- Sonos can only understand simple track numbers like "1" and will use them to sort the songs within albums correctly.
- Track numbers like "01/11" and "1/11" are effectively now invisible to Sonos. It treats them as if the field is blank and will instead fall back to order tracks alphabetically.

I'm not sure when this behavior might have changed, but I'm really not looking forward to re-tagging my entire library, so I've got my fingers crossed that this is just a bug...
That's indeed fascinating. Might be worth posting a diagnostic from your system, so that they can be sure to duplicate it properly when replicating the bug.