Answered

Sonos Beam + One (Surrounds) keep disconnecting

  • 4 December 2022
  • 6 replies
  • 108 views

Hello,

Sorry I know this has been asked before, but I'm unable to find a solution to get mine stable again.

I've had a beam and one surrounds for a few years now, have always worked faultlessly and connected to the TV when audio started playing. I have always used the optical to hdmi adaptor to connect to the beam, with wireless connection for the pair of ones.

A few weeks ago, the TV started disconnecting from the TV. It would not connect when audio played. The only solution I found was unplugging the beam from the power and resetting the unit. Fine during the day, but every morning when the TV goes on, nothing, so I need to unplug the device and reset, this gets tedious!

Yesterday the pair of one devices could not be found, so have to factory reset them and repair to the sound bar to create the surrounds.

The frustrating part is this system has worked so well for a while, but now I have daily issues with connectivity or having to restart devices. It's worth noting that nothing in the home has changed, broadband provider is the same, WiFi router if the BT smart hub. We haven't split the router into separate 2/5GHz bands - would this be worth trying?

I have also submitted a diagnostic, hopefully this provides some insight, or any other help or advice would be much appreciated!

Tom

icon

Best answer by Ken_Griffiths 5 December 2022, 22:58

View original

6 replies

Userlevel 7
Badge +17

For comments from Sonos on your diagnostic you need to copy it here, or (faster) call Sonos and speak to them about it.

Wifi connections can be changed by influences outside of your household, say your neighbours installing a new router. If nothing has changed in your home, does not mean your wifi reception environment has not changed.

Thanks for your response!

The diagnostic code is 1753506880, but I didn't seem to get any further information?

That's interesting on the WiFi environment changing too. It seems strange to me that the beam needs unplugging daily? Especially as that is the one connected to the TV? I'd have thought a new device in a neighbouring property would knock it out once when installed, not sporadically?

Are there any other options to aid connectivity? I could run an eternal cable to the beam, but not ideal and was really happy with the wireless capability of Sonos, while it worked!

 

@TomS23,

Perhaps try toggling off/on the ‘TV Autoplay’ feature in the Sonos App ‘Settings/System/[Beam Room Name]’ and ensure it’s left to the ‘on’ position. Then also power off (at wall socket) both the TV and Beam for at least 5 minutes and then bring both back online. Next reboot each of the two surrounds and let things settle and just see if that resolves the issue. 
 

If problems persist, then report back here, as there are a few other things you could also try, but see how the above goes first of all.

@TomS23,

Perhaps try toggling off/on the ‘TV Autoplay’ feature in the Sonos App ‘Settings/System/[Beam Room Name]’ and ensure it’s left to the ‘on’ position. Then also power off (at wall socket) both the TV and Beam for at least 5 minutes and then bring both back online. Next reboot each of the two surrounds and let things settle and just see if that resolves the issue. 
 

If problems persist, then report back here, as there are a few other things you could also try, but see how the above goes first of all.

 

Hi Ken, followed the steps as you described, seemed to work this morning without having to unplug the beam, however this evening the same issue occured this evening. Unplugged the power to beam, wait a few minutes, plugged back in and it's working again. Does appear to be a temperamental issue!

Do you have any suggestions on what to look at next? I have tried changing the router channels, but could try seperating out the 2.4 / 5 GHz  frequencies?

@TomS23
Firstly, the BT Routers are often mentioned as being problematic in several threads within the community here, which I’m sure you will see if you search for that, but many do solve their issues in a variety of ways…

One way is to split the routers 2.4Ghz and 5Ghz bands by adding -5G to the 5Ghz SSID and ensuring the Sonos products run on a fixed non-overlapping channel (1, 6, or 11) on the 2.4Ghz band only. 

If the router allows, its also helpful to set the 2.4Ghz band channel-width to 20Mhz only and (optionally) to add all your Sonos IP addresses to the routers DHCP reservation table.

If that doesn’t solve the issue, then the one other further/alternative option, if convenient, is to wire the Beam device only direct to the BT router.

I hope those suggestions are easy for you to follow and heres hoping that they work for you and resolve your issue.

@TomS23
Firstly, the BT Routers are often mentioned as being problematic in several threads within the community here, which I’m sure you will see if you search for that, but many do solve their issues in a variety of ways…

One way is to split the routers 2.4Ghz and 5Ghz bands by adding -5G to the 5Ghz SSID and ensuring the Sonos products run on a fixed non-overlapping channel (1, 6, or 11) on the 2.4Ghz band only. 

If the router allows, its also helpful to set the 2.4Ghz band channel-width to 20Mhz only and (optionally) to add all your Sonos IP addresses to the routers DHCP reservation table.

If that doesn’t solve the issue, then the one other further/alternative option, if convenient, is to wire the Beam device only direct to the BT router.

I hope those suggestions are easy for you to follow and heres hoping that they work for you and resolve your issue.

Quick update, I started with the easiest option first.. adding the Sonos IP addresses to the routers reservation table, we've gone more than 24 hours without an issue so it's looking promising.

If the issue occurs again, the next steps will be to seperate the 2.4/5Ghz bands and try again.

Thanks again for your support, really appreciated 👍

Reply